summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Erik Hanson2014-11-02 19:21:14 +0100
committer Willy Sudiarto Raharjo2014-11-08 00:39:19 +0100
commit75a447d1f9e5e01fc22f5f475a4b960a371029ab (patch)
treee45b7823b66d9d64dfb5db21695c08f9c2f7920f
parent6af172951fc3b69d3b896258bd68057c8853dbc3 (diff)
downloadslackbuilds-75a447d1f9e5e01fc22f5f475a4b960a371029ab.tar.gz
network/claws-mail: Updated for version 3.11.1.
Thanks to Chris Schrauben for the Makefile patches. Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--network/claws-mail/Makefile.patch129
-rw-r--r--network/claws-mail/claws-mail.SlackBuild5
-rw-r--r--network/claws-mail/claws-mail.info6
3 files changed, 136 insertions, 4 deletions
diff --git a/network/claws-mail/Makefile.patch b/network/claws-mail/Makefile.patch
new file mode 100644
index 0000000000..9f0002e460
--- /dev/null
+++ b/network/claws-mail/Makefile.patch
@@ -0,0 +1,129 @@
+--- Makefile.am 2014-10-28 02:56:56.000000000 +0800
++++ Makefile.am.new 2014-11-01 16:41:05.534958325 +0800
+@@ -34,6 +34,11 @@
+ pixmap128dir=$(datadir)/icons/hicolor/128x128/apps
+ pixmap128_DATA=claws-mail-128x128.png
+
++# when changing the name or location of the .desktop file,
++# also update src/common/Makefile.am
++gnomapdir = $(datadir)/applications
++gnomap_DATA=claws-mail.desktop
++
+ rename-icons:
+ @cd $(DESTDIR)$(datadir)/icons/hicolor/64x64/apps && \
+ mv claws-mail-64x64.png claws-mail.png
+--- Makefile.in 2014-10-28 02:59:07.000000000 +0800
++++ Makefile.in.new 2014-11-01 16:57:58.497854587 +0800
+@@ -165,11 +165,12 @@
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
+-am__installdirs = "$(DESTDIR)$(pixmapdir)" "$(DESTDIR)$(pixmap128dir)" \
+- "$(DESTDIR)$(pixmap64dir)" "$(DESTDIR)$(pkgconfigdir)" \
+- "$(DESTDIR)$(relnotesdir)" "$(DESTDIR)$(clawsincludedir)"
+-DATA = $(pixmap_DATA) $(pixmap128_DATA) $(pixmap64_DATA) \
+- $(pkgconfig_DATA) $(relnotes_DATA)
++am__installdirs = "$(DESTDIR)$(gnomapdir)" "$(DESTDIR)$(pixmapdir)" \
++ "$(DESTDIR)$(pixmap128dir)" "$(DESTDIR)$(pixmap64dir)" \
++ "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(relnotesdir)" \
++ "$(DESTDIR)$(clawsincludedir)"
++DATA = $(gnomap_DATA) $(pixmap_DATA) $(pixmap128_DATA) \
++ $(pixmap64_DATA) $(pkgconfig_DATA) $(relnotes_DATA)
+ HEADERS = $(clawsinclude_HEADERS)
+ RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
+ distclean-recursive maintainer-clean-recursive
+@@ -512,6 +513,11 @@
+ pixmap64_DATA = claws-mail-64x64.png
+ pixmap128dir = $(datadir)/icons/hicolor/128x128/apps
+ pixmap128_DATA = claws-mail-128x128.png
++
++# when changing the name or location of the .desktop file,
++# also update src/common/Makefile.am
++gnomapdir = $(datadir)/applications
++gnomap_DATA = claws-mail.desktop
+ @UPDATE_GTK_ICON_CACHE_TRUE@gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = claws-mail.pc
+@@ -593,6 +599,27 @@
+
+ distclean-libtool:
+ -rm -f libtool config.lt
++install-gnomapDATA: $(gnomap_DATA)
++ @$(NORMAL_INSTALL)
++ @list='$(gnomap_DATA)'; test -n "$(gnomapdir)" || list=; \
++ if test -n "$$list"; then \
++ echo " $(MKDIR_P) '$(DESTDIR)$(gnomapdir)'"; \
++ $(MKDIR_P) "$(DESTDIR)$(gnomapdir)" || exit 1; \
++ fi; \
++ for p in $$list; do \
++ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
++ echo "$$d$$p"; \
++ done | $(am__base_list) | \
++ while read files; do \
++ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(gnomapdir)'"; \
++ $(INSTALL_DATA) $$files "$(DESTDIR)$(gnomapdir)" || exit $$?; \
++ done
++
++uninstall-gnomapDATA:
++ @$(NORMAL_UNINSTALL)
++ @list='$(gnomap_DATA)'; test -n "$(gnomapdir)" || list=; \
++ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
++ dir='$(DESTDIR)$(gnomapdir)'; $(am__uninstall_files_from_dir)
+ install-pixmapDATA: $(pixmap_DATA)
+ @$(NORMAL_INSTALL)
+ @list='$(pixmap_DATA)'; test -n "$(pixmapdir)" || list=; \
+@@ -1017,7 +1044,7 @@
+ all-am: Makefile $(DATA) $(HEADERS) config.h claws-features.h
+ installdirs: installdirs-recursive
+ installdirs-am:
+- for dir in "$(DESTDIR)$(pixmapdir)" "$(DESTDIR)$(pixmap128dir)" "$(DESTDIR)$(pixmap64dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(relnotesdir)" "$(DESTDIR)$(clawsincludedir)"; do \
++ for dir in "$(DESTDIR)$(gnomapdir)" "$(DESTDIR)$(pixmapdir)" "$(DESTDIR)$(pixmap128dir)" "$(DESTDIR)$(pixmap64dir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(relnotesdir)" "$(DESTDIR)$(clawsincludedir)"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: install-recursive
+@@ -1072,9 +1099,9 @@
+
+ info-am:
+
+-install-data-am: install-clawsincludeHEADERS install-pixmap128DATA \
+- install-pixmap64DATA install-pixmapDATA install-pkgconfigDATA \
+- install-relnotesDATA
++install-data-am: install-clawsincludeHEADERS install-gnomapDATA \
++ install-pixmap128DATA install-pixmap64DATA \
++ install-pixmapDATA install-pkgconfigDATA install-relnotesDATA
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+ install-dvi: install-dvi-recursive
+@@ -1122,7 +1149,8 @@
+
+ ps-am:
+
+-uninstall-am: uninstall-clawsincludeHEADERS uninstall-pixmap128DATA \
++uninstall-am: uninstall-clawsincludeHEADERS \
++ uninstall-gnomapDATA uninstall-pixmap128DATA \
+ uninstall-pixmap64DATA uninstall-pixmapDATA \
+ uninstall-pkgconfigDATA uninstall-relnotesDATA
+ @$(NORMAL_INSTALL)
+@@ -1138,8 +1166,9 @@
+ distclean-hdr distclean-libtool distclean-tags distcleancheck \
+ distdir distuninstallcheck dvi dvi-am html html-am info \
+ info-am install install-am install-clawsincludeHEADERS \
+- install-data install-data-am install-data-hook install-dvi \
+- install-dvi-am install-exec install-exec-am install-html \
++ install-data install-data-am install-data-hook \
++ install-dvi install-dvi-am install-exec \
++ install-exec-am install-gnomapDATA install-html \
+ install-html-am install-info install-info-am install-man \
+ install-pdf install-pdf-am install-pixmap128DATA \
+ install-pixmap64DATA install-pixmapDATA install-pkgconfigDATA \
+@@ -1148,8 +1177,8 @@
+ maintainer-clean maintainer-clean-generic \
+ maintainer-clean-local mostlyclean mostlyclean-generic \
+ mostlyclean-libtool pdf pdf-am ps ps-am tags tags-am uninstall \
+- uninstall-am uninstall-clawsincludeHEADERS uninstall-hook \
+- uninstall-pixmap128DATA uninstall-pixmap64DATA \
++ uninstall-am uninstall-clawsincludeHEADERS uninstall-gnomapDATA \
++ uninstall-hook uninstall-pixmap128DATA uninstall-pixmap64DATA \
+ uninstall-pixmapDATA uninstall-pkgconfigDATA \
+ uninstall-relnotesDATA
+
diff --git a/network/claws-mail/claws-mail.SlackBuild b/network/claws-mail/claws-mail.SlackBuild
index 77452d1a25..11dd8bf5f0 100644
--- a/network/claws-mail/claws-mail.SlackBuild
+++ b/network/claws-mail/claws-mail.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=claws-mail
-VERSION=${VERSION:-3.10.1}
+VERSION=${VERSION:-3.11.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch to bring back claws-mail.desktop
+patch --verbose -p0 < $CWD/Makefile.patch
+
CFLAGS="$SLKCFLAGS" \
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
./configure \
diff --git a/network/claws-mail/claws-mail.info b/network/claws-mail/claws-mail.info
index dd36916842..00ca26f6cf 100644
--- a/network/claws-mail/claws-mail.info
+++ b/network/claws-mail/claws-mail.info
@@ -1,8 +1,8 @@
PRGNAM="claws-mail"
-VERSION="3.10.1"
+VERSION="3.11.1"
HOMEPAGE="http://www.claws-mail.org/"
-DOWNLOAD="http://downloads.sourceforge.net/claws-mail/claws-mail-3.10.1.tar.xz"
-MD5SUM="ab2b5a98c3c4e4341dfe563a4a8384e8"
+DOWNLOAD="http://downloads.sourceforge.net/claws-mail/claws-mail-3.11.1.tar.xz"
+MD5SUM="4cbf9b53c4cf691e093bd98efc0dbb63"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libetpan"