summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-04-30 08:24:56 +0200
committer Willy Sudiarto Raharjo2014-04-30 08:24:56 +0200
commit99892ffa51e98f8b6d7d6154e1f46ce01dc4c1de (patch)
treefcdef7d0f9063d5eae6dd5c9596cb5cc70abfe2a
parentafc8a23d332187e0ee41efdaeaa5a2d5258f5133 (diff)
downloadslackbuilds-99892ffa51e98f8b6d7d6154e1f46ce01dc4c1de.tar.gz
system/autoarchive: Updated for version 1.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/autoarchive/autoarchive.SlackBuild18
-rw-r--r--system/autoarchive/autoarchive.info6
-rw-r--r--system/autoarchive/doinst.sh2
3 files changed, 13 insertions, 13 deletions
diff --git a/system/autoarchive/autoarchive.SlackBuild b/system/autoarchive/autoarchive.SlackBuild
index 0c2c17a993..e210ffabb6 100644
--- a/system/autoarchive/autoarchive.SlackBuild
+++ b/system/autoarchive/autoarchive.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=autoarchive
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,24 +69,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# fix docs path
+sed -i 's/share\/doc/doc/' setup.py
+# fix man pages path
+sed -i 's/share\/man/man/g' setup.py
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/etc/aa/aa.conf $PKG/etc/aa/aa.conf.new
+mv $PKG/etc/aa/aa.conf $PKG/etc/aa/aa.conf.new
+
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README COPYING NEWS PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION/examples/ $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION/html/ $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/system/autoarchive/autoarchive.info b/system/autoarchive/autoarchive.info
index 9dd2be1560..1de9dd454f 100644
--- a/system/autoarchive/autoarchive.info
+++ b/system/autoarchive/autoarchive.info
@@ -1,8 +1,8 @@
PRGNAM="autoarchive"
-VERSION="1.1.0"
+VERSION="1.1.1"
HOMEPAGE="http://autoarchive.sourceforge.net/"
-DOWNLOAD="http://sourceforge.net/projects/autoarchive/files/autoarchive/1.1.0/autoarchive-1.1.0.tar.bz2"
-MD5SUM="43395e2d0f3619c04d6c828bc98f6cf0"
+DOWNLOAD="http://sourceforge.net/projects/autoarchive/files/autoarchive/1.1.1/autoarchive-1.1.1.tar.bz2"
+MD5SUM="5fc072f8c90e66cfb6da7ed135b3978b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"
diff --git a/system/autoarchive/doinst.sh b/system/autoarchive/doinst.sh
index 13f58a01e8..19236f59ed 100644
--- a/system/autoarchive/doinst.sh
+++ b/system/autoarchive/doinst.sh
@@ -8,7 +8,7 @@ config() {
fi
}
-config /etc/aa/aa.conf.new
+config /etc/aa/aa.conf.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1