summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-06 13:20:31 +0100
committer Erik Hanson2014-02-08 18:10:11 +0100
commit5f72ac5229f6cb32530d04aa40f5feab2ebae43d (patch)
treee6a5359bfcb459feaf1d42bf9ce3fc137ed184a5
parent117fbc6af05f0d4cef3c95e922d3d9245e7d1778 (diff)
downloadslackbuilds-5f72ac5229f6cb32530d04aa40f5feab2ebae43d.tar.gz
libraries/pysendfile: Added (Interface to sendfile syscall).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/pysendfile/README9
-rw-r--r--libraries/pysendfile/pysendfile.SlackBuild90
-rw-r--r--libraries/pysendfile/pysendfile.info10
-rw-r--r--libraries/pysendfile/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/libraries/pysendfile/README b/libraries/pysendfile/README
new file mode 100644
index 0000000000..f4087ba0c1
--- /dev/null
+++ b/libraries/pysendfile/README
@@ -0,0 +1,9 @@
+A Python interface to sendfile(2) syscall.
+
+sendfile(2) is a system call which provides a "zero-copy" way of copying data
+from one file descriptor to another (a socket).
+
+The phrase "zero-copy" refers to the fact that all of the copying of data
+between the two descriptors is done entirely by the kernel, with no
+copying of data into userspace buffers. This is particularly useful
+when sending a file over a socket (e.g. FTP).
diff --git a/libraries/pysendfile/pysendfile.SlackBuild b/libraries/pysendfile/pysendfile.SlackBuild
new file mode 100644
index 0000000000..8302a07b66
--- /dev/null
+++ b/libraries/pysendfile/pysendfile.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for pysendfile
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=pysendfile
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README HISTORY LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pysendfile/pysendfile.info b/libraries/pysendfile/pysendfile.info
new file mode 100644
index 0000000000..b029d0b5fb
--- /dev/null
+++ b/libraries/pysendfile/pysendfile.info
@@ -0,0 +1,10 @@
+PRGNAM="pysendfile"
+VERSION="2.0.0"
+HOMEPAGE="http://code.google.com/p/pysendfile/"
+DOWNLOAD="http://pysendfile.googlecode.com/files/pysendfile-2.0.0.tar.gz"
+MD5SUM="bd8d96b64e7c5c5b91ea2a6659aa82a3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pysendfile/slack-desc b/libraries/pysendfile/slack-desc
new file mode 100644
index 0000000000..3ce3996f10
--- /dev/null
+++ b/libraries/pysendfile/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pysendfile: pysendfile (A Python interface to sendfile(2) syscall)
+pysendfile:
+pysendfile: sendfile(2) is a system call which provides a "zero-copy" way of
+pysendfile: copying data from one file descriptor to another (a socket).
+pysendfile:
+pysendfile: Homepage: http://code.google.com/p/pysendfile/
+pysendfile:
+pysendfile:
+pysendfile:
+pysendfile:
+pysendfile: