summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn2013-11-25 05:37:44 +0100
committer Robby Workman2014-01-31 07:53:40 +0100
commiteb69a19f3c22f408cb1a035f4fdfcea248689acb (patch)
tree3443ae3112325e603888c35cfd512035e805c0fe
parent630bc18117b5c316cdf0d27458e5bc1338a7b70d (diff)
downloadslackbuilds-eb69a19f3c22f408cb1a035f4fdfcea248689acb.tar.gz
libraries/CXSparse: Upgraded for version 3.1.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/CXSparse/CXSparse.SlackBuild25
-rw-r--r--libraries/CXSparse/CXSparse.info10
-rw-r--r--libraries/CXSparse/autotoolize.diff196
3 files changed, 130 insertions, 101 deletions
diff --git a/libraries/CXSparse/CXSparse.SlackBuild b/libraries/CXSparse/CXSparse.SlackBuild
index df3f489ae4..a816567a3b 100644
--- a/libraries/CXSparse/CXSparse.SlackBuild
+++ b/libraries/CXSparse/CXSparse.SlackBuild
@@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for CXSparse
-# Written by Kyle Guinn <elyk03@gmail.com>
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=CXSparse
-VERSION=${VERSION:-2.2.5}
+VERSION=${VERSION:-3.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,9 +88,11 @@ CFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
+ --disable-dependency-tracking \
--build=$ARCH-slackware-linux
make
+make check
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/libraries/CXSparse/CXSparse.info b/libraries/CXSparse/CXSparse.info
index 9b681b94c4..d0e120d733 100644
--- a/libraries/CXSparse/CXSparse.info
+++ b/libraries/CXSparse/CXSparse.info
@@ -1,10 +1,10 @@
PRGNAM="CXSparse"
-VERSION="2.2.5"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
-DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CXSparse/versions/CXSparse-2.2.5.tar.gz"
-MD5SUM="03750f3501fb3ccb7f2518bd24c4abbc"
+VERSION="3.1.2"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/CXSparse/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/CXSparse/versions/CXSparse-3.1.2.tar.gz"
+MD5SUM="1406442cd2741e9786393bfa7514c17f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="UFconfig"
+REQUIRES="SuiteSparse_config"
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"
diff --git a/libraries/CXSparse/autotoolize.diff b/libraries/CXSparse/autotoolize.diff
index 151b75a9ae..524c26f0f8 100644
--- a/libraries/CXSparse/autotoolize.diff
+++ b/libraries/CXSparse/autotoolize.diff
@@ -3,7 +3,7 @@ new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
@@ -0,0 +1,131 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
+LDADD = $(top_builddir)/Source/libcxsparse.la
+
+noinst_HEADERS = \
@@ -53,93 +53,92 @@ new file mode 100644
+cs_ldemo_CPPFLAGS = $(AM_CPPFLAGS) -DCS_LONG
+
+MATRICES = \
-+ ../Matrix/ash219 \
-+ ../Matrix/bcsstk01 \
-+ ../Matrix/bcsstk16 \
-+ ../Matrix/c4 \
-+ ../Matrix/c_mbeacxc \
-+ ../Matrix/c_west0067 \
-+ ../Matrix/fs_183_1 \
-+ ../Matrix/lp_afiro \
-+ ../Matrix/mbeacxc \
-+ ../Matrix/mhd1280b \
-+ ../Matrix/neumann \
-+ ../Matrix/qc324 \
-+ ../Matrix/t1 \
-+ ../Matrix/t2 \
-+ ../Matrix/t3 \
-+ ../Matrix/t4 \
-+ ../Matrix/west0067 \
-+ ../Matrix/young1c
++ $(top_srcdir)/Matrix/ash219 \
++ $(top_srcdir)/Matrix/bcsstk01 \
++ $(top_srcdir)/Matrix/bcsstk16 \
++ $(top_srcdir)/Matrix/c4 \
++ $(top_srcdir)/Matrix/c_mbeacxc \
++ $(top_srcdir)/Matrix/c_west0067 \
++ $(top_srcdir)/Matrix/fs_183_1 \
++ $(top_srcdir)/Matrix/lp_afiro \
++ $(top_srcdir)/Matrix/mbeacxc \
++ $(top_srcdir)/Matrix/mhd1280b \
++ $(top_srcdir)/Matrix/neumann \
++ $(top_srcdir)/Matrix/qc324 \
++ $(top_srcdir)/Matrix/t1 \
++ $(top_srcdir)/Matrix/t2 \
++ $(top_srcdir)/Matrix/t3 \
++ $(top_srcdir)/Matrix/t4 \
++ $(top_srcdir)/Matrix/west0067 \
++ $(top_srcdir)/Matrix/young1c
+
+check-local: $(check_PROGRAMS) $(MATRICES)
-+ -./cs_demo1 < ../Matrix/t1
-+ -./cs_demo2 < ../Matrix/t1
-+ -./cs_demo2 < ../Matrix/fs_183_1
-+ -./cs_demo2 < ../Matrix/west0067
-+ -./cs_demo2 < ../Matrix/lp_afiro
-+ -./cs_demo2 < ../Matrix/ash219
-+ -./cs_demo2 < ../Matrix/mbeacxc
-+ -./cs_demo2 < ../Matrix/bcsstk01
-+ -./cs_demo3 < ../Matrix/bcsstk01
-+ -./cs_demo2 < ../Matrix/bcsstk16
-+ -./cs_demo3 < ../Matrix/bcsstk16
-+ -./cs_di_demo1 < ../Matrix/t1
-+ -./cs_di_demo2 < ../Matrix/t1
-+ -./cs_di_demo2 < ../Matrix/fs_183_1
-+ -./cs_di_demo2 < ../Matrix/west0067
-+ -./cs_di_demo2 < ../Matrix/lp_afiro
-+ -./cs_di_demo2 < ../Matrix/ash219
-+ -./cs_di_demo2 < ../Matrix/mbeacxc
-+ -./cs_di_demo2 < ../Matrix/bcsstk01
-+ -./cs_di_demo3 < ../Matrix/bcsstk01
-+ -./cs_di_demo2 < ../Matrix/bcsstk16
-+ -./cs_di_demo3 < ../Matrix/bcsstk16
-+ -./cs_dl_demo1 < ../Matrix/t1
-+ -./cs_dl_demo2 < ../Matrix/t1
-+ -./cs_dl_demo2 < ../Matrix/fs_183_1
-+ -./cs_dl_demo2 < ../Matrix/west0067
-+ -./cs_dl_demo2 < ../Matrix/lp_afiro
-+ -./cs_dl_demo2 < ../Matrix/ash219
-+ -./cs_dl_demo2 < ../Matrix/mbeacxc
-+ -./cs_dl_demo2 < ../Matrix/bcsstk01
-+ -./cs_dl_demo3 < ../Matrix/bcsstk01
-+ -./cs_dl_demo2 < ../Matrix/bcsstk16
-+ -./cs_dl_demo3 < ../Matrix/bcsstk16
-+ -./cs_ci_demo1 < ../Matrix/t2
-+ -./cs_ci_demo2 < ../Matrix/t2
-+ -./cs_ci_demo2 < ../Matrix/t3
-+ -./cs_ci_demo2 < ../Matrix/t4
-+ -./cs_ci_demo2 < ../Matrix/c_west0067
-+ -./cs_ci_demo2 < ../Matrix/c_mbeacxc
-+ -./cs_ci_demo2 < ../Matrix/young1c
-+ -./cs_ci_demo2 < ../Matrix/qc324
-+ -./cs_ci_demo2 < ../Matrix/neumann
-+ -./cs_ci_demo2 < ../Matrix/c4
-+ -./cs_ci_demo3 < ../Matrix/c4
-+ -./cs_ci_demo2 < ../Matrix/mhd1280b
-+ -./cs_ci_demo3 < ../Matrix/mhd1280b
-+ -./cs_cl_demo1 < ../Matrix/t2
-+ -./cs_cl_demo2 < ../Matrix/t2
-+ -./cs_cl_demo2 < ../Matrix/t3
-+ -./cs_cl_demo2 < ../Matrix/t4
-+ -./cs_cl_demo2 < ../Matrix/c_west0067
-+ -./cs_cl_demo2 < ../Matrix/c_mbeacxc
-+ -./cs_cl_demo2 < ../Matrix/young1c
-+ -./cs_cl_demo2 < ../Matrix/qc324
-+ -./cs_cl_demo2 < ../Matrix/neumann
-+ -./cs_cl_demo2 < ../Matrix/c4
-+ -./cs_cl_demo3 < ../Matrix/c4
-+ -./cs_cl_demo2 < ../Matrix/mhd1280b
-+ -./cs_cl_demo3 < ../Matrix/mhd1280b
-+ -./cs_idemo < ../Matrix/t2
-+ -./cs_ldemo < ../Matrix/t2
++ -./cs_demo1 < $(top_srcdir)/Matrix/t1
++ -./cs_demo2 < $(top_srcdir)/Matrix/t1
++ -./cs_demo2 < $(top_srcdir)/Matrix/fs_183_1
++ -./cs_demo2 < $(top_srcdir)/Matrix/west0067
++ -./cs_demo2 < $(top_srcdir)/Matrix/lp_afiro
++ -./cs_demo2 < $(top_srcdir)/Matrix/ash219
++ -./cs_demo2 < $(top_srcdir)/Matrix/mbeacxc
++ -./cs_demo2 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_demo3 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_demo2 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_demo3 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_di_demo1 < $(top_srcdir)/Matrix/t1
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/t1
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/fs_183_1
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/west0067
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/lp_afiro
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/ash219
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/mbeacxc
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_di_demo3 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_di_demo2 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_di_demo3 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_dl_demo1 < $(top_srcdir)/Matrix/t1
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/t1
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/fs_183_1
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/west0067
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/lp_afiro
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/ash219
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/mbeacxc
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_dl_demo3 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_dl_demo2 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_dl_demo3 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_ci_demo1 < $(top_srcdir)/Matrix/t2
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/t2
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/t3
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/t4
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/c_west0067
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/c_mbeacxc
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/young1c
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/qc324
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/neumann
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/c4
++ -./cs_ci_demo3 < $(top_srcdir)/Matrix/c4
++ -./cs_ci_demo2 < $(top_srcdir)/Matrix/mhd1280b
++ -./cs_ci_demo3 < $(top_srcdir)/Matrix/mhd1280b
++ -./cs_cl_demo1 < $(top_srcdir)/Matrix/t2
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/t2
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/t3
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/t4
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/c_west0067
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/c_mbeacxc
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/young1c
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/qc324
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/neumann
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/c4
++ -./cs_cl_demo3 < $(top_srcdir)/Matrix/c4
++ -./cs_cl_demo2 < $(top_srcdir)/Matrix/mhd1280b
++ -./cs_cl_demo3 < $(top_srcdir)/Matrix/mhd1280b
++ -./cs_idemo < $(top_srcdir)/Matrix/t2
++ -./cs_ldemo < $(top_srcdir)/Matrix/t2
diff --git a/Include/Makefile.am b/Include/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Include/Makefile.am
-@@ -0,0 +1,2 @@
-+pkgincludedir = $(includedir)/cxsparse
+@@ -0,0 +1 @@
+pkginclude_HEADERS = cs.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
@@ -184,7 +183,7 @@ new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,72 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
+
+CS_SOURCE = \
+ cs_add.c \
@@ -255,35 +254,43 @@ new file mode 100644
+
+libcxsparse_la_SOURCES = cs_convert.c
+libcxsparse_la_LIBADD = libcxsparse_di.la libcxsparse_dl.la libcxsparse_ci.la libcxsparse_cl.la -lm
-+libcxsparse_la_LDFLAGS = -no-undefined -version-info 4:5:2
++libcxsparse_la_LDFLAGS = -no-undefined -version-number 3:1:2
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,37 @@
-+AC_PREREQ([2.68])
-+AC_INIT([CXSparse],[2.2.5],[davis@cise.ufl.edu])
+@@ -0,0 +1,45 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([CXSparse],[3.1.2],[DrTimothyAldenDavis@gmail.com],[cxsparse],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/cs_print.c])
-+AC_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
++# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+
+LIBS_SAVED=$LIBS
+
++# Checks for libraries.
+AC_CHECK_LIB([m], [sqrt])
+
-+AC_CHECK_HEADERS([limits.h stdlib.h])
-+
+PKG_PROG_PKG_CONFIG
-+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
+ [],
-+ [AC_MSG_ERROR([cannot find ufconfig])])
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stdlib.h])
+
++# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+
++# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([sqrt])
@@ -302,7 +309,7 @@ diff --git a/cxsparse.pc.in b/cxsparse.pc.in
new file mode 100644
--- /dev/null
+++ b/cxsparse.pc.in
-@@ -0,0 +1,12 @@
+@@ -0,0 +1,13 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@@ -311,7 +318,8 @@ new file mode 100644
+Name: @PACKAGE_NAME@
+Description: An extended version of CSparse
+Version: @PACKAGE_VERSION@
-+Requires.private: ufconfig
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
+Libs: -L${libdir} -lcxsparse
+Libs.private: -lm
+Cflags: -I${includedir}/cxsparse