summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn2013-11-25 06:25:54 +0100
committer Robby Workman2014-01-31 07:53:45 +0100
commit2b966ae2851e2547358cc9b9382347d323e2932e (patch)
tree93430230726cc12ff55d361f28d400a40043689b
parented6a99bbf8762e5d05044e6944dcbd8058d92216 (diff)
downloadslackbuilds-2b966ae2851e2547358cc9b9382347d323e2932e.tar.gz
libraries/CSparse: Updated for version 3.1.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/CSparse/CSparse.SlackBuild25
-rw-r--r--libraries/CSparse/CSparse.info8
-rw-r--r--libraries/CSparse/autotoolize.diff68
3 files changed, 65 insertions, 36 deletions
diff --git a/libraries/CSparse/CSparse.SlackBuild b/libraries/CSparse/CSparse.SlackBuild
index 029fb2b4c2..f485f58147 100644
--- a/libraries/CSparse/CSparse.SlackBuild
+++ b/libraries/CSparse/CSparse.SlackBuild
@@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for CSparse
-# Written by Kyle Guinn <elyk03@gmail.com>
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=CSparse
-VERSION=${VERSION:-2.2.5}
+VERSION=${VERSION:-3.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,9 +88,11 @@ CFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
+ --disable-dependency-tracking \
--build=$ARCH-slackware-linux
make
+make check
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/libraries/CSparse/CSparse.info b/libraries/CSparse/CSparse.info
index f5de1b0492..81bff38b4d 100644
--- a/libraries/CSparse/CSparse.info
+++ b/libraries/CSparse/CSparse.info
@@ -1,8 +1,8 @@
PRGNAM="CSparse"
-VERSION="2.2.5"
-HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CSparse/"
-DOWNLOAD="http://www.cise.ufl.edu/research/sparse/CSparse/versions/CSparse-2.2.5.tar.gz"
-MD5SUM="74da840c9de1312e5575d0b21b00b12e"
+VERSION="3.1.2"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/CSparse/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/CSparse/versions/CSparse-3.1.2.tar.gz"
+MD5SUM="c610815814fe38de69aaf00d38604012"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/CSparse/autotoolize.diff b/libraries/CSparse/autotoolize.diff
index 116e15d3e9..5fa2b85643 100644
--- a/libraries/CSparse/autotoolize.diff
+++ b/libraries/CSparse/autotoolize.diff
@@ -27,34 +27,33 @@ new file mode 100644
+cs_demo3_SOURCES = cs_demo3.c cs_demo.c
+
+MATRICES = \
-+ ../Matrix/ash219 \
-+ ../Matrix/bcsstk01 \
-+ ../Matrix/bcsstk01 \
-+ ../Matrix/bcsstk16 \
-+ ../Matrix/fs_183_1 \
-+ ../Matrix/lp_afiro \
-+ ../Matrix/mbeacxc \
-+ ../Matrix/t1 \
-+ ../Matrix/west0067
++ $(top_srcdir)/Matrix/ash219 \
++ $(top_srcdir)/Matrix/bcsstk01 \
++ $(top_srcdir)/Matrix/bcsstk01 \
++ $(top_srcdir)/Matrix/bcsstk16 \
++ $(top_srcdir)/Matrix/fs_183_1 \
++ $(top_srcdir)/Matrix/lp_afiro \
++ $(top_srcdir)/Matrix/mbeacxc \
++ $(top_srcdir)/Matrix/t1 \
++ $(top_srcdir)/Matrix/west0067
+
+check-local: $(check_PROGRAMS) $(MATRICES)
-+ -./cs_demo1 < ../Matrix/t1
-+ -./cs_demo2 < ../Matrix/t1
-+ -./cs_demo2 < ../Matrix/ash219
-+ -./cs_demo2 < ../Matrix/bcsstk01
-+ -./cs_demo2 < ../Matrix/fs_183_1
-+ -./cs_demo2 < ../Matrix/mbeacxc
-+ -./cs_demo2 < ../Matrix/west0067
-+ -./cs_demo2 < ../Matrix/lp_afiro
-+ -./cs_demo2 < ../Matrix/bcsstk16
-+ -./cs_demo3 < ../Matrix/bcsstk01
-+ -./cs_demo3 < ../Matrix/bcsstk16
++ -./cs_demo1 < $(top_srcdir)/Matrix/t1
++ -./cs_demo2 < $(top_srcdir)/Matrix/t1
++ -./cs_demo2 < $(top_srcdir)/Matrix/ash219
++ -./cs_demo2 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_demo2 < $(top_srcdir)/Matrix/fs_183_1
++ -./cs_demo2 < $(top_srcdir)/Matrix/mbeacxc
++ -./cs_demo2 < $(top_srcdir)/Matrix/west0067
++ -./cs_demo2 < $(top_srcdir)/Matrix/lp_afiro
++ -./cs_demo2 < $(top_srcdir)/Matrix/bcsstk16
++ -./cs_demo3 < $(top_srcdir)/Matrix/bcsstk01
++ -./cs_demo3 < $(top_srcdir)/Matrix/bcsstk16
diff --git a/Include/Makefile.am b/Include/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Include/Makefile.am
-@@ -0,0 +1,2 @@
-+pkgincludedir = $(includedir)/csparse
+@@ -0,0 +1 @@
+pkginclude_HEADERS = cs.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
@@ -87,7 +86,7 @@ new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,62 @@
-+AM_CPPFLAGS = -I$(top_builddir)/Include
++AM_CPPFLAGS = -I$(top_srcdir)/Include
+
+EXTRA_DIST = \
+ README.txt
@@ -148,30 +147,38 @@ new file mode 100644
+lib_LTLIBRARIES = libcsparse.la
+libcsparse_la_SOURCES = $(CSPARSESRC)
+libcsparse_la_LIBADD = -lm
-+libcsparse_la_LDFLAGS = -no-undefined -version-info 4:5:2
++libcsparse_la_LDFLAGS = -no-undefined -version-number 3:1:2
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,32 @@
-+AC_PREREQ([2.68])
-+AC_INIT([CSparse],[2.2.5],[davis@cise.ufl.edu])
+@@ -0,0 +1,40 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([CSparse],[3.1.2],[DrTimothyAldenDavis@gmail.com],[csparse],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/cs_print.c])
-+AC_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
++# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+
+LIBS_SAVED=$LIBS
+
++# Checks for libraries.
+AC_CHECK_LIB([m], [sqrt])
+
-+AC_CHECK_HEADERS([limits.h stdlib.h])
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
+
++# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+
++# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([sqrt])
@@ -190,7 +197,7 @@ diff --git a/csparse.pc.in b/csparse.pc.in
new file mode 100644
--- /dev/null
+++ b/csparse.pc.in
-@@ -0,0 +1,11 @@
+@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@@ -199,6 +206,7 @@ new file mode 100644
+Name: @PACKAGE_NAME@
+Description: A concise sparse matrix package
+Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
+Libs: -L${libdir} -lcsparse
+Libs.private: -lm
+Cflags: -I${includedir}/csparse