summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Reichelt2013-12-27 01:12:16 +0100
committer Erik Hanson2014-01-07 18:13:56 +0100
commita5c73390fe53752fbff1776c8efaf6c8f851878e (patch)
tree5cce882f94c36b123c60bd7eb9ffdad8594e2f10
parentbac2de9ace601bb165d4807fcde878b34ff59f97 (diff)
downloadslackbuilds-a5c73390fe53752fbff1776c8efaf6c8f851878e.tar.gz
libraries/zbase32: Updated for version 1.1.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/zbase32/zbase32.SlackBuild28
-rw-r--r--libraries/zbase32/zbase32.info6
2 files changed, 19 insertions, 15 deletions
diff --git a/libraries/zbase32/zbase32.SlackBuild b/libraries/zbase32/zbase32.SlackBuild
index 48e55b6e76..514300b094 100644
--- a/libraries/zbase32/zbase32.SlackBuild
+++ b/libraries/zbase32/zbase32.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for zbase32.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012 Markus Reichelt, Aachen, DE
+# Copyright 2012-2013 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=zbase32
-VERSION=${VERSION:-1.1.3}
+VERSION=${VERSION:-1.1.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -44,14 +44,18 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="DESIGN README"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -64,19 +68,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py build
+python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a DESIGN README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/zbase32/zbase32.info b/libraries/zbase32/zbase32.info
index 0589aec096..ccad047271 100644
--- a/libraries/zbase32/zbase32.info
+++ b/libraries/zbase32/zbase32.info
@@ -1,8 +1,8 @@
PRGNAM="zbase32"
-VERSION="1.1.3"
+VERSION="1.1.5"
HOMEPAGE="http://pypi.python.org/pypi/zbase32/"
-DOWNLOAD="http://pypi.python.org/packages/source/z/zbase32/zbase32-1.1.3.tar.gz"
-MD5SUM="0614df3116aa52797000ee8a06c47167"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zbase32/zbase32-1.1.5.tar.gz"
+MD5SUM="4dba0be4ac6d66968de8e5173f51d65d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"