summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Adis Nezirović2014-01-03 23:15:14 +0100
committer Erik Hanson2014-01-07 18:14:00 +0100
commit707fe5f4aaa40c7332d9996c4b0b85d0bed723f9 (patch)
tree7ed5cd9b6ad2cb8cb49bf4fa0b95e91270f03d94
parentfdcb69ad13be2d74bf3f7b6c86396c28eff8e99e (diff)
downloadslackbuilds-707fe5f4aaa40c7332d9996c4b0b85d0bed723f9.tar.gz
libraries/greenlet: Added (micro-threads for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/greenlet/README10
-rw-r--r--libraries/greenlet/greenlet.SlackBuild91
-rw-r--r--libraries/greenlet/greenlet.info10
-rw-r--r--libraries/greenlet/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/libraries/greenlet/README b/libraries/greenlet/README
new file mode 100644
index 0000000000..ae2ca5317a
--- /dev/null
+++ b/libraries/greenlet/README
@@ -0,0 +1,10 @@
+The greenlet package is a spin-off of Stackless, a version of CPython
+that supports micro-threads called "tasklets". Tasklets run
+pseudo-concurrently (typically in a single or a few OS-level threads)
+and are synchronized with data exchanges on "channels".
+
+Greenlets are provided as a C extension module for the regular
+unmodified Python interpreter.
+
+Greenlets are lightweight coroutines for in-process concurrent
+programming.
diff --git a/libraries/greenlet/greenlet.SlackBuild b/libraries/greenlet/greenlet.SlackBuild
new file mode 100644
index 0000000000..f74bd5e785
--- /dev/null
+++ b/libraries/greenlet/greenlet.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for Greenlet
+#
+# $Revision: b7d6e885f8ce $
+# $Date: 2014/01/03 20:11:43 $
+#
+# Copyright 2014 Adis Nezirović <adis_at_linux.org.ba>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=greenlet
+VERSION=${VERSION:-0.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS NEWS README.rst doc/greenlet.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/greenlet/greenlet.info b/libraries/greenlet/greenlet.info
new file mode 100644
index 0000000000..0ba9016112
--- /dev/null
+++ b/libraries/greenlet/greenlet.info
@@ -0,0 +1,10 @@
+PRGNAM="greenlet"
+VERSION="0.4.1"
+HOMEPAGE="https://github.com/python-greenlet/greenlet"
+DOWNLOAD="https://pypi.python.org/packages/source/g/greenlet/greenlet-0.4.1.zip"
+MD5SUM="c2deda75bdda59c38cae12a77cc53adc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Adis Nezirović"
+EMAIL="adis_at_linux.org.ba"
diff --git a/libraries/greenlet/slack-desc b/libraries/greenlet/slack-desc
new file mode 100644
index 0000000000..3748bd4964
--- /dev/null
+++ b/libraries/greenlet/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+greenlet: greenlet (micro-threads for Python)
+greenlet:
+greenlet: The greenlet package is a spin-off of Stackless, a version of
+greenlet: CPython that supports micro-threads called "tasklets". Tasklets run
+greenlet: pseudo-concurrently (typically in a single or a few OS-level threads)
+greenlet: and are synchronized with data exchanges on "channels".
+greenlet:
+greenlet: Greenlets are lightweight coroutines for in-process concurrent
+greenlet: programming. They are provided as a C extension module for the
+greenlet: regular unmodified interpreter.
+greenlet: