summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn2013-10-28 04:10:34 +0100
committer Robby Workman2013-10-28 05:39:08 +0100
commit7a1c6033678c4fa82a692b20ded778b37fe7f2bd (patch)
tree7f819e40bdd2da402f0a7ce114104bc0dc5b26dd
parentebf7ea616428881d6506c4889f66d11ed30c76d8 (diff)
downloadslackbuilds-7a1c6033678c4fa82a692b20ded778b37fe7f2bd.tar.gz
development/udis86: Updated for version 1.7.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--development/udis86/slack-desc10
-rw-r--r--development/udis86/udis86.SlackBuild58
-rw-r--r--development/udis86/udis86.info6
3 files changed, 46 insertions, 28 deletions
diff --git a/development/udis86/slack-desc b/development/udis86/slack-desc
index ea7cb36940..066e5a3df0 100644
--- a/development/udis86/slack-desc
+++ b/development/udis86/slack-desc
@@ -1,9 +1,9 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
udis86: Udis86 (x86 disassembler)
diff --git a/development/udis86/udis86.SlackBuild b/development/udis86/udis86.SlackBuild
index 7edc2b8829..d465cb0eee 100644
--- a/development/udis86/udis86.SlackBuild
+++ b/development/udis86/udis86.SlackBuild
@@ -1,19 +1,36 @@
#!/bin/sh
# Slackware build script for udis86
-# Written by Kyle Guinn <elyk03@gmail.com>
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=udis86
-VERSION=${VERSION:-1.7}
+VERSION=${VERSION:-1.7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -48,25 +65,26 @@ rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+chmod -R u+w,go-w,a+rX-st .
+
+# Respect --docdir.
+sed -i '/^docdir = /s/\${datadir}\/docs\/udis86/@docdir@/' \
+ docs/manual/Makefile.am \
+ docs/x86/Makefile.am
+autoreconf -vif
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --infodir=/usr/info \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-shared \
- --disable-static \
- --build=$ARCH-slackware-linux
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
diff --git a/development/udis86/udis86.info b/development/udis86/udis86.info
index 16ad75b774..55561be5e6 100644
--- a/development/udis86/udis86.info
+++ b/development/udis86/udis86.info
@@ -1,8 +1,8 @@
PRGNAM="udis86"
-VERSION="1.7"
+VERSION="1.7.2"
HOMEPAGE="http://udis86.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/udis86/udis86-1.7.tar.gz"
-MD5SUM="e279108e10f774e6c3af83caa18f5dc3"
+DOWNLOAD="http://downloads.sourceforge.net/udis86/udis86-1.7.2.tar.gz"
+MD5SUM="b7def25257afb612e8da052ee6759dac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""