summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mathew Holleran2013-10-27 06:38:35 +0100
committer Robby Workman2013-10-28 05:39:00 +0100
commit15194b28e34099a4be52f6327e5951ee01db709a (patch)
tree9fac98e5e4663bbd47223dab92cd2e32fd5c2048
parent07e2b2df51756387951bb5cd3fb7f8d672658f33 (diff)
downloadslackbuilds-15194b28e34099a4be52f6327e5951ee01db709a.tar.gz
libraries/pangox-compat: Added (X font support for Pango)
This will needed for gtkglext to build on Slackware 14.1, as pangox is no longer part of the pango package there. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/pangox-compat/README1
-rw-r--r--libraries/pangox-compat/pangox-compat.SlackBuild121
-rw-r--r--libraries/pangox-compat/pangox-compat.info10
-rw-r--r--libraries/pangox-compat/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/libraries/pangox-compat/README b/libraries/pangox-compat/README
new file mode 100644
index 0000000000..ea87b806e5
--- /dev/null
+++ b/libraries/pangox-compat/README
@@ -0,0 +1 @@
+X Window System font support for Pango.
diff --git a/libraries/pangox-compat/pangox-compat.SlackBuild b/libraries/pangox-compat/pangox-compat.SlackBuild
new file mode 100644
index 0000000000..93cfadb2f9
--- /dev/null
+++ b/libraries/pangox-compat/pangox-compat.SlackBuild
@@ -0,0 +1,121 @@
+#!/bin/sh
+
+# Slackware build script for pangox-compat.
+
+# Copyright 2013 Mathew Holleran.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pangox-compat
+VERSION=${VERSION:-0.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-${TMP}/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --disable-static \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux \
+ --host=$ARCH-slackware-linux \
+ --target=$ARCH-slackware-linux
+
+make
+
+# Check the host value that is passed to the compile to the one in this script:
+host="$ARCH-slackware-linux-gnu"
+compile_host=$(grep 'host_triplet =' $TMP/$PRGNAM-$VERSION/Makefile | sed "s/.* = //")
+if [ "x$compile_host" != "x$host" ]; then
+ echo "Host mismatch: compile='$compile_host', SlackBuild='$host'" && exit 1
+fi
+
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+# Compress and link manpages, if any:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.?
+ )
+ done
+ )
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pangox-compat/pangox-compat.info b/libraries/pangox-compat/pangox-compat.info
new file mode 100644
index 0000000000..3a0634eb7d
--- /dev/null
+++ b/libraries/pangox-compat/pangox-compat.info
@@ -0,0 +1,10 @@
+PRGNAM="pangox-compat"
+VERSION="0.0.2"
+HOMEPAGE="http://www.pango.org"
+DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/pangox-compat/0.0/pangox-compat-0.0.2.tar.xz"
+MD5SUM="7bcbd0187f03e1e27af9a81e07249c33"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mathew Holleran"
+EMAIL="mathew.holleran@gmail.com"
diff --git a/libraries/pangox-compat/slack-desc b/libraries/pangox-compat/slack-desc
new file mode 100644
index 0000000000..4df5056555
--- /dev/null
+++ b/libraries/pangox-compat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pangox-compat: pangox-compat (X font support for Pango)
+pangox-compat:
+pangox-compat: X Window System font support for Pango.
+pangox-compat:
+pangox-compat: http://www.pango.org
+pangox-compat:
+pangox-compat:
+pangox-compat:
+pangox-compat:
+pangox-compat:
+pangox-compat: