summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2013-10-26 23:26:36 +0200
committer Robby Workman2013-10-28 05:38:54 +0100
commit0dac9d811746f9b86e44f06ecb8f5f16c577c288 (patch)
tree41d81c8a772ff50187507f705ba9b980e95dc2f9
parentaaee5e48d5178ded066254e7ec858fb850ef85d4 (diff)
downloadslackbuilds-0dac9d811746f9b86e44f06ecb8f5f16c577c288.tar.gz
python/apsw: Added (Another Python SQLite Wrapper)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--python/apsw/README7
-rw-r--r--python/apsw/apsw.SlackBuild77
-rw-r--r--python/apsw/apsw.info10
-rw-r--r--python/apsw/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/apsw/README b/python/apsw/README
new file mode 100644
index 0000000000..c226b3fbcc
--- /dev/null
+++ b/python/apsw/README
@@ -0,0 +1,7 @@
+APSW is a Python wrapper for the SQLite embedded relational database engine. In
+contrast to other wrappers such as pysqlite it focuses on being a minimal layer
+over SQLite attempting just to translate the complete SQLite API into Python.
+The documentation has a section on the differences between APSW and pysqlite.
+APSW supports CPython 2.3 onwards and CPython 3.1 onwards.
+
+Optionally Python 3 extension will be built if Python 3 is installed.
diff --git a/python/apsw/apsw.SlackBuild b/python/apsw/apsw.SlackBuild
new file mode 100644
index 0000000000..0164ccaab9
--- /dev/null
+++ b/python/apsw/apsw.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for apsw
+
+# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=apsw
+VERSION=${VERSION:-3.7.14.1_r1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${VERSION/_/-}
+unzip $CWD/$PRGNAM-${VERSION/_/-}.zip
+cd $PRGNAM-${VERSION/_/-}
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build --enable-all-extensions
+python setup.py install --root=$PKG --skip-build
+
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py build --enable-all-extensions
+ python3 setup.py install --root=$PKG --skip-build
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/apsw/apsw.info b/python/apsw/apsw.info
new file mode 100644
index 0000000000..a6f75f915f
--- /dev/null
+++ b/python/apsw/apsw.info
@@ -0,0 +1,10 @@
+PRGNAM="apsw"
+VERSION="3.7.14.1_r1"
+HOMEPAGE="http://code.google.com/p/apsw/"
+DOWNLOAD="http://apsw.googlecode.com/files/apsw-3.7.14.1-r1.zip"
+MD5SUM="ae32e46df985b5fbbdbdd17640367711"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/apsw/slack-desc b/python/apsw/slack-desc
new file mode 100644
index 0000000000..50e49ff185
--- /dev/null
+++ b/python/apsw/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+apsw: apsw (Another Python SQLite Wrapper)
+apsw:
+apsw: APSW is a Python wrapper for the SQLite embedded relational database
+apsw: engine. In contrast to other wrappers such as pysqlite it focuses on
+apsw: being a minimal layer over SQLite attempting just to translate the
+apsw: complete SQLite API into Python. The documentation has a section on
+apsw: the differences between APSW and pysqlite. APSW supports CPython 2.3
+apsw: onwards and CPython 3.1 onwards.
+apsw:
+apsw: Homepage: http://code.google.com/p/apsw/
+apsw: