summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Roberto Neri2013-06-30 20:47:40 +0200
committer Erik Hanson2013-06-30 20:47:40 +0200
commitd549cf473f466603eb32c2d6c7499a3fceb62040 (patch)
treed39083b948d21906f029bc3fd259a642b6e3e94d
parent28a41c331f37275da70b1ca844227f37c7c2be5f (diff)
downloadslackbuilds-d549cf473f466603eb32c2d6c7499a3fceb62040.tar.gz
development/KKEdit: Added (a simple text editor)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--development/KKEdit/KKEdit-0.0.16.patch20
-rw-r--r--development/KKEdit/KKEdit.SlackBuild100
-rw-r--r--development/KKEdit/KKEdit.info10
-rw-r--r--development/KKEdit/README1
-rw-r--r--development/KKEdit/doinst.sh4
-rw-r--r--development/KKEdit/slack-desc19
6 files changed, 154 insertions, 0 deletions
diff --git a/development/KKEdit/KKEdit-0.0.16.patch b/development/KKEdit/KKEdit-0.0.16.patch
new file mode 100644
index 0000000000..0780e36222
--- /dev/null
+++ b/development/KKEdit/KKEdit-0.0.16.patch
@@ -0,0 +1,20 @@
+diff -Nru KKEdit.orig/KKEdit/app/Makefile.am KKEdit/KKEdit/app/Makefile.am
+--- KKEdit.orig/KKEdit/app/Makefile.am 2013-05-24 15:21:21.000000000 +0200
++++ KKEdit/KKEdit/app/Makefile.am 2013-06-10 11:20:42.857232918 +0200
+@@ -21,10 +21,12 @@
+ #man1_MANS = ../resources/man/kkedit.1
+
+ install-exec-hook:
+- cp ../resources/pixmaps/KKEdit.desktop /usr/share/applications/KKEdit.desktop
+- cp ../resources/pixmaps/KKEdit.png /usr/share/pixmaps
+- echo Icon=${prefix}/share/KKEdit/pixmaps/KKEdit.png >> /usr/share/applications/KKEdit.desktop
+- echo Exec=${prefix}/bin/kkedit >> /usr/share/applications/KKEdit.desktop
++ $(MKDIR_P) $(DESTDIR)${prefix}/share/applications
++ $(MKDIR_P) $(DESTDIR)${prefix}/share/pixmaps
++ cp ../resources/pixmaps/KKEdit.desktop $(DESTDIR)${prefix}/share/applications/KKEdit.desktop
++ cp ../resources/pixmaps/KKEdit.png $(DESTDIR)${prefix}/share/pixmaps
++ echo Icon=${prefix}/share/KKEdit/pixmaps/KKEdit.png >> $(DESTDIR)${prefix}/share/applications/KKEdit.desktop
++ echo Exec=${prefix}/bin/kkedit >> $(DESTDIR)${prefix}/share/applications/KKEdit.desktop
+
+ uninstall-hook:
+ rm -f /usr/share/applications/KKEdit.desktop /usr/share/pixmaps/KKEdit.png
diff --git a/development/KKEdit/KKEdit.SlackBuild b/development/KKEdit/KKEdit.SlackBuild
new file mode 100644
index 0000000000..3700192b27
--- /dev/null
+++ b/development/KKEdit/KKEdit.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for KKEdit
+
+# Copyright 2013 Roberto Neri, Palermo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=KKEdit
+VERSION=${VERSION:-0.0.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix KKEdit/app/Makefile
+patch -p1 < $CWD/$PRGNAM-$VERSION.patch
+
+# the Doc viewer requires version 1.10.x of webkitgtk
+# which at present (10 June 2013) is not yet available on SlackBuilds.org
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./autogen.sh \
+ --prefix=/usr \
+ --disable-docviewer \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a "Example External Tools/" ChangeLog \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/KKEdit/KKEdit.info b/development/KKEdit/KKEdit.info
new file mode 100644
index 0000000000..5d412cdb03
--- /dev/null
+++ b/development/KKEdit/KKEdit.info
@@ -0,0 +1,10 @@
+PRGNAM="KKEdit"
+VERSION="0.0.16"
+HOMEPAGE="http://keithhedger.hostingsiteforfree.com/pages/kkedit/help.html"
+DOWNLOAD="http://keithhedger.hostingsiteforfree.com/zips/kkedit/KKEdit-0.0.16.tar.gz"
+MD5SUM="18c0189a8d67f355ce07cb32835e9732"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gtksourceview libunique"
+MAINTAINER="Roberto Neri"
+EMAIL="rneri@libero.it"
diff --git a/development/KKEdit/README b/development/KKEdit/README
new file mode 100644
index 0000000000..8e4106c9b8
--- /dev/null
+++ b/development/KKEdit/README
@@ -0,0 +1 @@
+KKEdit is a deceptively simple text editor with syntax colouring.
diff --git a/development/KKEdit/doinst.sh b/development/KKEdit/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/development/KKEdit/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/development/KKEdit/slack-desc b/development/KKEdit/slack-desc
new file mode 100644
index 0000000000..1c4d154491
--- /dev/null
+++ b/development/KKEdit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+KKEdit: KKEdit (a simple text editor)
+KKEdit:
+KKEdit: KKEdit is a deceptively simple text editor with syntax colouring.
+KKEdit:
+KKEdit: Homepage:
+KKEdit: http://keithhedger.hostingsiteforfree.com/pages/kkedit/help.html
+KKEdit:
+KKEdit:
+KKEdit:
+KKEdit:
+KKEdit: