summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Roberto Neri2013-06-20 21:25:48 +0200
committer Niels Horn2013-06-20 21:25:48 +0200
commit2c34eefc1e23a2c12a1067d47fd7dcf4e22ac28b (patch)
tree75a1e01ee8ebaaface7c6592d8a3e7c79775cc06
parent7f4c1410d9c1577e89ca90a34a04c8e1ecba547f (diff)
downloadslackbuilds-2c34eefc1e23a2c12a1067d47fd7dcf4e22ac28b.tar.gz
desktop/menulibre: Added (Menu editor with quicklist support)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--desktop/menulibre/README2
-rw-r--r--desktop/menulibre/doinst.sh4
-rw-r--r--desktop/menulibre/menulibre.SlackBuild86
-rw-r--r--desktop/menulibre/menulibre.info10
-rw-r--r--desktop/menulibre/slack-desc19
5 files changed, 121 insertions, 0 deletions
diff --git a/desktop/menulibre/README b/desktop/menulibre/README
new file mode 100644
index 0000000000..f07bba32c0
--- /dev/null
+++ b/desktop/menulibre/README
@@ -0,0 +1,2 @@
+MenuLibre is an advanced menu editor that provides modern features and
+full quicklist support, suitable for various desktop environments.
diff --git a/desktop/menulibre/doinst.sh b/desktop/menulibre/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/desktop/menulibre/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/desktop/menulibre/menulibre.SlackBuild b/desktop/menulibre/menulibre.SlackBuild
new file mode 100644
index 0000000000..93807fc7f7
--- /dev/null
+++ b/desktop/menulibre/menulibre.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for menulibre
+
+# Copyright 2013 Roberto Neri, Palermo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=menulibre
+VERSION=${VERSION:-13.04.12}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_$VERSION.tar.gz
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cd trunk
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/menulibre/menulibre.info b/desktop/menulibre/menulibre.info
new file mode 100644
index 0000000000..f447826b25
--- /dev/null
+++ b/desktop/menulibre/menulibre.info
@@ -0,0 +1,10 @@
+PRGNAM="menulibre"
+VERSION="13.04.12"
+HOMEPAGE="http://www.smdavis.us/projects/menulibre/"
+DOWNLOAD="https://launchpad.net/menulibre/trunk/13.04.12/+download/menulibre_13.04.12.tar.gz"
+MD5SUM="3fc22b8b326f0bc1fbfd429a5109db9d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gtksourceview3 pygobject3 python-distutils-extra pyxdg"
+MAINTAINER="Roberto Neri"
+EMAIL="rneri@libero.it"
diff --git a/desktop/menulibre/slack-desc b/desktop/menulibre/slack-desc
new file mode 100644
index 0000000000..f5e8b5dfb2
--- /dev/null
+++ b/desktop/menulibre/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+menulibre: menulibre (Advanced menu editor with quicklist support)
+menulibre:
+menulibre: An advanced menu editor that provides modern features and full
+menulibre: quicklist support, suitable for various desktop environments.
+menulibre:
+menulibre: Homepage: http://www.smdavis.us/projects/menulibre/
+menulibre:
+menulibre:
+menulibre:
+menulibre:
+menulibre: