summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Reichelt2012-06-28 22:57:52 +0200
committer dsomero2012-06-28 22:57:52 +0200
commit344022d9c3550b4a266713fe1b5987f9dac85e9b (patch)
tree9fae55dde3ff92d8531b5882f589dfe39f27f6d7
parent2c661fa148d1f7274ff1d5590cef02eb3194df01 (diff)
downloadslackbuilds-344022d9c3550b4a266713fe1b5987f9dac85e9b.tar.gz
python/foolscap: Updated for version 0.6.4, moved from libraries.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/foolscap/README (renamed from libraries/foolscap/README)0
-rw-r--r--python/foolscap/foolscap.SlackBuild (renamed from libraries/foolscap/foolscap.SlackBuild)23
-rw-r--r--python/foolscap/foolscap.info (renamed from libraries/foolscap/foolscap.info)6
-rw-r--r--python/foolscap/slack-desc (renamed from libraries/foolscap/slack-desc)4
4 files changed, 18 insertions, 15 deletions
diff --git a/libraries/foolscap/README b/python/foolscap/README
index 1a59cf9780..1a59cf9780 100644
--- a/libraries/foolscap/README
+++ b/python/foolscap/README
diff --git a/libraries/foolscap/foolscap.SlackBuild b/python/foolscap/foolscap.SlackBuild
index 9fc65a1b60..302f336563 100644
--- a/libraries/foolscap/foolscap.SlackBuild
+++ b/python/foolscap/foolscap.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for foolscap.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# Copyright 2012 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,16 +27,14 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=foolscap
-VERSION=${VERSION:-0.6.3}
+VERSION=${VERSION:-0.6.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -45,14 +44,18 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="LICENSE README"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -70,15 +73,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
+cp -a \
+ ChangeLog NEWS LICENSE README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/foolscap/foolscap.info b/python/foolscap/foolscap.info
index 8f04e54966..058211b1bd 100644
--- a/libraries/foolscap/foolscap.info
+++ b/python/foolscap/foolscap.info
@@ -1,8 +1,8 @@
PRGNAM="foolscap"
-VERSION="0.6.3"
+VERSION="0.6.4"
HOMEPAGE="http://foolscap.lothar.com/trac"
-DOWNLOAD="http://foolscap.lothar.com/releases/foolscap-0.6.3.tar.gz"
-MD5SUM="38782e3b64d3a0beea1ae03dd9ca137f"
+DOWNLOAD="http://foolscap.lothar.com/releases/foolscap-0.6.4.tar.gz"
+MD5SUM="0aedae62a0be50da4f89d80b5b30c8a2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Markus Reichelt"
diff --git a/libraries/foolscap/slack-desc b/python/foolscap/slack-desc
index 4ccde7bbc0..7311ee50ca 100644
--- a/libraries/foolscap/slack-desc
+++ b/python/foolscap/slack-desc
@@ -3,9 +3,9 @@
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler----------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
foolscap: foolscap (RPC protocol for Python+Twisted)
foolscap:
foolscap: Foolscap is an RPC protocol for Python+Twisted, providing a