summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2012-05-13 15:09:25 +0200
committer dsomero2012-05-13 15:09:25 +0200
commitdf58a6966ae98a47f3ccfd2399daa91593c4fbc6 (patch)
treeb04983f7e7e7863d4f0386bbdb0dcf21468efed2
parent5f16d5268af69fcdab8d3e08991502deafd7f431 (diff)
downloadslackbuilds-df58a6966ae98a47f3ccfd2399daa91593c4fbc6.tar.gz
python/boto: Added (Interface to Amazon Web Services)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/boto/README3
-rw-r--r--python/boto/README.boto26
-rw-r--r--python/boto/boto-2.2.2-no-install-tests.patch16
-rw-r--r--python/boto/boto.SlackBuild57
-rw-r--r--python/boto/boto.info10
-rw-r--r--python/boto/slack-desc19
6 files changed, 131 insertions, 0 deletions
diff --git a/python/boto/README b/python/boto/README
new file mode 100644
index 0000000000..4ef06af8b5
--- /dev/null
+++ b/python/boto/README
@@ -0,0 +1,3 @@
+Boto is a Python package that provides interfaces to Amazon Web Services.
+
+Boto requires filechunkio and distribute.
diff --git a/python/boto/README.boto b/python/boto/README.boto
new file mode 100644
index 0000000000..8eb3041c15
--- /dev/null
+++ b/python/boto/README.boto
@@ -0,0 +1,26 @@
+In order for boto to access an s3 resource it must be able to get the
+access key and secret key for an s3 account. The 3 ways that boto can
+obtain the keys are in the following order of precedence.
+
+1) Credentials passed into Connection class constructor
+2) Credentials specified by environment variables
+3) Credentials specified as options in a config file
+
+The easiest way for boto to read proper s3 credentials are from a
+global config file in /etc/boto.cfg or on a user basis in
+~/.boto.
+
+An example config file looks like the following:
+
+[Credentials]
+aws_access_key_id = <your access key>
+aws_secret_access_key = <your secret key>
+
+[Boto]
+debug = 0
+num_retries = 10
+
+proxy = myproxy.com
+proxy_port = 8080
+proxy_user = foo
+proxy_pass = bar
diff --git a/python/boto/boto-2.2.2-no-install-tests.patch b/python/boto/boto-2.2.2-no-install-tests.patch
new file mode 100644
index 0000000000..bf9cc3a242
--- /dev/null
+++ b/python/boto/boto-2.2.2-no-install-tests.patch
@@ -0,0 +1,16 @@
+diff -Naur boto-2.2.2.orig/setup.py boto-2.2.2/setup.py
+--- boto-2.2.2.orig/setup.py 2012-02-15 03:17:52.000000000 +0000
++++ boto-2.2.2/setup.py 2012-05-07 02:23:28.885052767 +0000
+@@ -59,11 +59,7 @@
+ "boto.mturk", "boto.mturk.test", "boto.pyami",
+ "boto.pyami.installers", "boto.pyami.installers.ubuntu",
+ "boto.mashups", "boto.contrib", "boto.manage",
+- "tests", "tests.autoscale", "tests.cloudfront",
+- "tests.devpay", "tests.db", "tests.dynamodb",
+- "tests.ec2", "tests.ec2.cloudwatch", "tests.ec2.elb",
+- "tests.s3", "tests.sdb", "tests.sqs", "tests.sts",
+- "tests.utils", "boto.services", "boto.cloudfront",
++ "boto.services", "boto.cloudfront",
+ "boto.roboto", "boto.rds", "boto.vpc", "boto.fps",
+ "boto.fps.test", "boto.emr", "boto.emr.tests", "boto.sns",
+ "boto.ecs", "boto.iam", "boto.route53", "boto.ses",
diff --git a/python/boto/boto.SlackBuild b/python/boto/boto.SlackBuild
new file mode 100644
index 0000000000..b97e3a5388
--- /dev/null
+++ b/python/boto/boto.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Slackware build script for boto
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=boto
+VERSION=${VERSION:-2.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Don't install test files.
+patch -p1 < $CWD/boto-2.2.2-no-install-tests.patch
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changelog.rst PKG-INFO README.markdown $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README.$PRGNAM > $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/boto/boto.info b/python/boto/boto.info
new file mode 100644
index 0000000000..41c552c7f9
--- /dev/null
+++ b/python/boto/boto.info
@@ -0,0 +1,10 @@
+PRGNAM="boto"
+VERSION="2.2.2"
+HOMEPAGE="https://github.com/boto/boto"
+DOWNLOAD="http://pypi.python.org/packages/source/b/boto/boto-2.2.2.tar.gz"
+MD5SUM="b23b9137abd7286615236ed03929d282"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/python/boto/slack-desc b/python/boto/slack-desc
new file mode 100644
index 0000000000..1817331948
--- /dev/null
+++ b/python/boto/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+boto: boto (Interface to Amazon Web Services)
+boto:
+boto: Boto is a Python package that provides interfaces to Amazon Web
+boto: Services.
+boto:
+boto: Homepage: https://github.com/boto/boto
+boto:
+boto:
+boto:
+boto:
+boto: