summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman2012-05-11 17:40:56 +0200
committer Erik Hanson2012-05-14 20:13:58 +0200
commitdeaf02228bd43019564c1b35c534c2c43058e1c9 (patch)
tree8fe22d9313cb0642dc5b77f3cd5825a8f519294f
parent612fd0840acaf2daf9a943fbb6a9f56ba1b9513a (diff)
downloadslackbuilds-deaf02228bd43019564c1b35c534c2c43058e1c9.tar.gz
desktop/icewm: Included a couple of build fix patches
These are only needed for -current, but they don't hurt anything for 13.37 and they reduce the workload later when getting all of the repo ready for slackware-next. Thanks to Morten Langlo for the fontconfig patch. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--desktop/icewm/icewm.SlackBuild9
-rw-r--r--desktop/icewm/patches/explicitly-link-fontconfig.diff12
-rw-r--r--desktop/icewm/patches/icewm-1.3.7-fix_html_docdir.diff (renamed from desktop/icewm/icewm-1.3.7-fix_html_docdir.diff)0
-rw-r--r--desktop/icewm/patches/use_ICEWM_deprecated.patch21
4 files changed, 41 insertions, 1 deletions
diff --git a/desktop/icewm/icewm.SlackBuild b/desktop/icewm/icewm.SlackBuild
index 7000c9f1ba..cee6037256 100644
--- a/desktop/icewm/icewm.SlackBuild
+++ b/desktop/icewm/icewm.SlackBuild
@@ -69,8 +69,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Explicitly link fontconfig - this isn't needed on 13.37, but it also doesn't
+# hurt anything, so we'll included it since it's needed for -current
+patch -p1 < $CWD/patches/explicitly-link-fontconfig.diff
+
+# Here's another -current only patch that's harmless on 13.37:
+patch -p1 < $CWD/patches/use_ICEWM_deprecated.patch
+
# Since we put the html files in $docdir/html/, let's fix the integrated help:
-patch -p1 < $CWD/icewm-1.3.7-fix_html_docdir.diff
+patch -p1 < $CWD/patches/icewm-1.3.7-fix_html_docdir.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/icewm/patches/explicitly-link-fontconfig.diff b/desktop/icewm/patches/explicitly-link-fontconfig.diff
new file mode 100644
index 0000000000..36dab59d32
--- /dev/null
+++ b/desktop/icewm/patches/explicitly-link-fontconfig.diff
@@ -0,0 +1,12 @@
+diff -Nur icewm-1.3.7.orig/src/Makefile.in icewm-1.3.7/src/Makefile.in
+--- icewm-1.3.7.orig/src/Makefile.in 2010-10-31 09:09:36.000000000 -0500
++++ icewm-1.3.7/src/Makefile.in 2012-05-11 10:29:55.356344991 -0500
+@@ -37,7 +37,7 @@
+ CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
+ @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
+ LFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs`
++LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 fontconfig --libs`
+
+ CORE_LIBS = @CORE_LIBS@ # `fc-config --libs`
+ IMAGE_LIBS = @IMAGE_LIBS@
diff --git a/desktop/icewm/icewm-1.3.7-fix_html_docdir.diff b/desktop/icewm/patches/icewm-1.3.7-fix_html_docdir.diff
index b3818625fe..b3818625fe 100644
--- a/desktop/icewm/icewm-1.3.7-fix_html_docdir.diff
+++ b/desktop/icewm/patches/icewm-1.3.7-fix_html_docdir.diff
diff --git a/desktop/icewm/patches/use_ICEWM_deprecated.patch b/desktop/icewm/patches/use_ICEWM_deprecated.patch
new file mode 100644
index 0000000000..3533d31e34
--- /dev/null
+++ b/desktop/icewm/patches/use_ICEWM_deprecated.patch
@@ -0,0 +1,21 @@
+Description: Don't use "deprecated" as identifier, will FTBFS if another
+ library defines functions as deprecated.
+Author: Andreas Moog <amoog@ubuntu.com>
+Bug: https://sourceforge.net/tracker/?func=detail&aid=3494034&group_id=31&atid=100031
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/935179
+Forwarded: Yes
+
+--- icewm-1.3.7.orig/src/base.h
++++ icewm-1.3.7/src/base.h
+@@ -2,9 +2,9 @@
+ #define __BASE_H
+
+ #if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
+-#define deprecated __attribute__((deprecated))
++#define ICEWM_deprecated __attribute__((deprecated))
+ #else
+-#define deprecated
++#define ICEWM_deprecated
+ #endif
+
+ /*** Atomar Data Types ********************************************************/