summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2012-05-13 15:10:06 +0200
committer dsomero2012-05-13 15:10:06 +0200
commitade5ee96ae8ee923a461d347864e35e1bf4f2cbe (patch)
tree6f4e18187a8f2490f82b5a71e889c1edbb38452c
parent3d34f836d0088c055c74b67c5b9af81e9db8c9b2 (diff)
downloadslackbuilds-ade5ee96ae8ee923a461d347864e35e1bf4f2cbe.tar.gz
python/s3cmd: Added (Amazon S3 command line tool)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--python/s3cmd/README9
-rw-r--r--python/s3cmd/s3cmd.SlackBuild57
-rw-r--r--python/s3cmd/s3cmd.info10
-rw-r--r--python/s3cmd/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/python/s3cmd/README b/python/s3cmd/README
new file mode 100644
index 0000000000..5ca7c1be8c
--- /dev/null
+++ b/python/s3cmd/README
@@ -0,0 +1,9 @@
+S3cmd is a command line tool for uploading, retrieving and managing data in
+Amazon S3. It is best suited for power users who don't fear command line. It is
+also ideal for scripts, automated backups triggered from cron, etc.
+
+S3cmd has an optional dependency for python-magic for mime-type indentification.
+
+Before s3cmd can be used it must first be set up. Run 's3cmd --configure' and
+enter in you access key and your secret key and follow the instructions. After
+this there will be a ~/.s3cfg file with your s3 credentials.
diff --git a/python/s3cmd/s3cmd.SlackBuild b/python/s3cmd/s3cmd.SlackBuild
new file mode 100644
index 0000000000..1899a56c40
--- /dev/null
+++ b/python/s3cmd/s3cmd.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Slackware build script for s3cmd
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=s3cmd
+VERSION=${VERSION:-1.1.0_beta3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${VERSION/_/-}
+tar xvf $CWD/$PRGNAM-${VERSION/_/-}.tar.gz
+cd $PRGNAM-${VERSION/_/-}
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i 's|\(doc_path\)+"/s3cmd"|\1|' setup.py
+
+S3CMD_INSTPATH_DOC="/usr/doc/$PRGNAM-$VERSION" \
+S3CMD_INSTPATH_MAN="/usr/man" \
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/s3cmd/s3cmd.info b/python/s3cmd/s3cmd.info
new file mode 100644
index 0000000000..b1b6f20dca
--- /dev/null
+++ b/python/s3cmd/s3cmd.info
@@ -0,0 +1,10 @@
+PRGNAM="s3cmd"
+VERSION="1.1.0_beta3"
+HOMEPAGE="http://s3tools.org/s3cmd"
+DOWNLOAD="http://downloads.sourceforge.net/s3tools/s3cmd-1.1.0-beta3.tar.gz"
+MD5SUM="b27d9a5d5b5e32798947a3661e67e537"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/python/s3cmd/slack-desc b/python/s3cmd/slack-desc
new file mode 100644
index 0000000000..23ef985a87
--- /dev/null
+++ b/python/s3cmd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+s3cmd: s3cmd (Amazon S3 command line tool)
+s3cmd:
+s3cmd: S3cmd is a command line tool for uploading, retrieving and managing
+s3cmd: data in Amazon S3. It is best suited for power users who don't fear
+s3cmd: command line. It is also ideal for scripts, automated backups
+s3cmd: triggered from cron, etc.
+s3cmd:
+s3cmd: Homepage: http://s3tools.org/s3cmd
+s3cmd:
+s3cmd:
+s3cmd: