summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author ponce2012-04-30 02:52:45 +0200
committer Erik Hanson2012-04-30 07:40:06 +0200
commit5496784ac9b321dbadd1f49356d9a6c6c958f0ae (patch)
treeb3dcefdb62671017554822c0ca7913f9fcb58657
parent267173c5d3af152374a9f37b5ca96651b7b669bf (diff)
downloadslackbuilds-5496784ac9b321dbadd1f49356d9a6c6c958f0ae.tar.gz
libraries/lua52: Added (embeddable scripting language)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--libraries/lua52/README7
-rw-r--r--libraries/lua52/lua.pc31
-rw-r--r--libraries/lua52/lua52.SlackBuild104
-rw-r--r--libraries/lua52/lua52.info10
-rw-r--r--libraries/lua52/slack-desc19
5 files changed, 171 insertions, 0 deletions
diff --git a/libraries/lua52/README b/libraries/lua52/README
new file mode 100644
index 0000000000..320bc9bca2
--- /dev/null
+++ b/libraries/lua52/README
@@ -0,0 +1,7 @@
+Lua is a free software light-weight programming language designed
+for extending applications. Lua is also frequently used as a
+general-purpose, stand-alone scripting language.
+
+This package is for the slackware users needing the 5.2.x
+version: it is not compatible with the 5.1.x one (install
+just one version of the two).
diff --git a/libraries/lua52/lua.pc b/libraries/lua52/lua.pc
new file mode 100644
index 0000000000..7d8a1abf40
--- /dev/null
+++ b/libraries/lua52/lua.pc
@@ -0,0 +1,31 @@
+# lua.pc -- pkg-config data for Lua
+
+# vars from install Makefile
+
+# grep '^V=' ../Makefile
+V= 5.2
+# grep '^R=' ../Makefile
+R= 5.2.0
+
+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+prefix= /usr
+INSTALL_BIN= ${prefix}/bin
+INSTALL_INC= ${prefix}/include
+INSTALL_LIB= ${prefix}/lib
+INSTALL_MAN= ${prefix}/man/man1
+INSTALL_LMOD= ${prefix}/share/lua/${V}
+INSTALL_CMOD= ${prefix}/lib/lua/${V}
+
+# canonical vars
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua -lm
+Cflags: -I${includedir}
+
+# (end of lua.pc)
diff --git a/libraries/lua52/lua52.SlackBuild b/libraries/lua52/lua52.SlackBuild
new file mode 100644
index 0000000000..23521a2e0d
--- /dev/null
+++ b/libraries/lua52/lua52.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for Lua
+
+# Written by Menno Duursma
+# Modified by the SlackBuilds.org project
+# Modified by Aaron W. Hsu
+# Adapted by ponce for version 5.2.x
+
+# This program is free software. It comes without any warranty.
+# Granted WTFPL, Version 2, as published by Sam Hocevar. See
+# http://sam.zoy.org/wtfpl/COPYING for more details.
+
+PRGNAM=lua52
+VERSION=${VERSION:-5.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=lua
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+
+# Fix up a to-be-installed header
+sed -i "s|/usr/local|/usr|" src/luaconf.h
+sed -i "s|lib/lua|lib$LIBDIRSUFFIX/lua|" src/luaconf.h
+
+make linux \
+ CFLAGS="$SLKCFLAGS \$(MYCFLAGS)" \
+ INSTALL_TOP=/usr \
+ INSTALL_LIB=/usr/lib${LIBDIRSUFFIX} \
+ INSTALL_CMOD=/usr/lib${LIBDIRSUFFIX}/lua/5.2
+
+make linux install \
+ CFLAGS="$SLKCFLAGS \$(MYCFLAGS)" \
+ INSTALL_TOP=$PKG/usr \
+ INSTALL_LIB=$PKG/usr/lib${LIBDIRSUFFIX} \
+ INSTALL_CMOD=/usr/lib${LIBDIRSUFFIX}/lua/5.2
+
+# Now let's build the shared library
+mkdir -p shared
+cd shared
+ ar -x $PKG/usr/lib${LIBDIRSUFFIX}/liblua.a
+ gcc -ldl -lreadline -lhistory -lncurses -lm -shared *.o -o liblua.so.5.2.0
+ cp -a liblua.so.5.2.0 $PKG/usr/lib${LIBDIRSUFFIX}
+ ( cd $PKG/usr/lib${LIBDIRSUFFIX}
+ ln -s liblua.so.5.2.0 liblua.so.5.2
+ ln -s liblua.so.5.2.0 liblua.so.5
+ ln -s liblua.so.5.2.0 liblua.so
+ )
+cd ..
+
+# and install the pkgconfig file
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
+cat $CWD/lua.pc | sed "s|prefix}/lib|prefix}/lib${LIBDIRSUFFIX}|g" \
+ > $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/lua.pc
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/*.html doc/logo.gif doc/lua.css $PKG/usr/doc/$PRGNAM-$VERSION/html
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lua52/lua52.info b/libraries/lua52/lua52.info
new file mode 100644
index 0000000000..0e30eea138
--- /dev/null
+++ b/libraries/lua52/lua52.info
@@ -0,0 +1,10 @@
+PRGNAM="lua52"
+VERSION="5.2.0"
+HOMEPAGE="http://www.lua.org"
+DOWNLOAD="http://www.lua.org/ftp/lua-5.2.0.tar.gz"
+MD5SUM="f1ea831f397214bae8a265995ab1a93e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/lua52/slack-desc b/libraries/lua52/slack-desc
new file mode 100644
index 0000000000..e7dd3a9c3d
--- /dev/null
+++ b/libraries/lua52/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+lua52: Lua (a powerful, fast, light-weight, embeddable scripting language)
+lua52:
+lua52: Lua combines simple procedural syntax with powerful data description
+lua52: constructs based on associative arrays and extensible semantics.
+lua52: Lua is dynamically typed, runs by interpreting bytecode for a
+lua52: register-based virtual machine, and has automatic memory management
+lua52: with incremental garbage collection, making it ideal for
+lua52: configuration, scripting, and rapid prototyping.
+lua52:
+lua52: This package installs the 5.2.x version.
+lua52: