summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2012-04-15 17:46:27 +0200
committer Erik Hanson2012-04-16 12:35:58 +0200
commitd81a3eaf5e10527528591f269d996ac882864758 (patch)
treea7d269fc2aa4299c9b04eb343e1c5c15d2cb75e5
parenta44964fb50a7badfab78b9b112c96fbd8f0826ad (diff)
downloadslackbuilds-d81a3eaf5e10527528591f269d996ac882864758.tar.gz
office/zathura-ps: Added (zathura plugin for PostScript support)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--office/zathura-ps/README3
-rw-r--r--office/zathura-ps/slack-desc19
-rw-r--r--office/zathura-ps/zathura-ps.SlackBuild68
-rw-r--r--office/zathura-ps/zathura-ps.info10
4 files changed, 100 insertions, 0 deletions
diff --git a/office/zathura-ps/README b/office/zathura-ps/README
new file mode 100644
index 0000000000..adc37b24ad
--- /dev/null
+++ b/office/zathura-ps/README
@@ -0,0 +1,3 @@
+zathura-ps (zathura plugin, provides PostScript support)
+
+This requires zathura and libspectre.
diff --git a/office/zathura-ps/slack-desc b/office/zathura-ps/slack-desc
new file mode 100644
index 0000000000..c70953cfb8
--- /dev/null
+++ b/office/zathura-ps/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zathura-ps: zathura-ps (zathura plugin, provides PostScript support)
+zathura-ps:
+zathura-ps: This requires zathura and libspectre.
+zathura-ps:
+zathura-ps:
+zathura-ps:
+zathura-ps:
+zathura-ps:
+zathura-ps:
+zathura-ps:
+zathura-ps:
diff --git a/office/zathura-ps/zathura-ps.SlackBuild b/office/zathura-ps/zathura-ps.SlackBuild
new file mode 100644
index 0000000000..84f307db0b
--- /dev/null
+++ b/office/zathura-ps/zathura-ps.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for zathura-ps
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=zathura-ps
+VERSION=${VERSION:-0.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i "s,-fPIC,$SLKCFLAGS," config.mk
+
+make
+strip *.so
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/zathura-ps/zathura-ps.info b/office/zathura-ps/zathura-ps.info
new file mode 100644
index 0000000000..2442b6042b
--- /dev/null
+++ b/office/zathura-ps/zathura-ps.info
@@ -0,0 +1,10 @@
+PRGNAM="zathura-ps"
+VERSION="0.1.0"
+HOMEPAGE="https://pwmt.org/projects/zathura/plugins/zathura-ps/"
+DOWNLOAD="https://pwmt.org/projects/zathura/plugins/download/zathura-ps-0.1.0.tar.gz"
+MD5SUM="103d2e25529492cdba702484aab643f5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="dsomero"