summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2012-04-16 04:29:52 +0200
committer Erik Hanson2012-04-16 12:36:00 +0200
commit99ef8dc25e5a1f1b3d5fa4d63a4b7975d210a0d5 (patch)
treea24fdc64295d256af93fca3785a6e23c43b19a11
parent572a82357732dafa909e7cd3c2de25bc29006033 (diff)
downloadslackbuilds-99ef8dc25e5a1f1b3d5fa4d63a4b7975d210a0d5.tar.gz
office/zathura: Updated for version 0.1.1 new maintainer.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--office/zathura/README13
-rw-r--r--office/zathura/doinst.sh3
-rw-r--r--office/zathura/zathura.1.gzbin0 -> 1569 bytes
-rw-r--r--office/zathura/zathura.SlackBuild78
-rw-r--r--office/zathura/zathura.info14
-rw-r--r--office/zathura/zathura.pngbin0 -> 643 bytes
-rw-r--r--office/zathura/zathurarc.5.gzbin0 -> 572 bytes
7 files changed, 88 insertions, 20 deletions
diff --git a/office/zathura/README b/office/zathura/README
index 3f09a675aa..544450cf53 100644
--- a/office/zathura/README
+++ b/office/zathura/README
@@ -1,6 +1,9 @@
-zathura is a highly customizable and functional PDF viewer based on
-the poppler rendering library and the gtk+ toolkit. The idea behind
-zathura is an application that provides a minimalistic and space
-saving interface as well as an easy usage that mainly focuses on
-keyboard interaction.
+zathura is a highly customizable and functional PDF viewer based on the
+poppler rendering library and the gtk+ toolkit. The idea behind zathura
+is an application that provides a minimalistic and space saving interface
+as well as an easy usage that mainly focuses on keyboard interaction.
+This package includes the zathura core and the zathura-pdf-poppler plugin.
+If you need PostScript support, see the zathura-ps package.
+
+This requires girara.
diff --git a/office/zathura/doinst.sh b/office/zathura/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/office/zathura/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/zathura/zathura.1.gz b/office/zathura/zathura.1.gz
new file mode 100644
index 0000000000..ad9a4b29b9
--- /dev/null
+++ b/office/zathura/zathura.1.gz
Binary files differ
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index ab5033bb57..e084440cb5 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -22,8 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Updated 20120312 by B. Watson <yalhcru@gmail.com>:
+# - Updated for v0.1.1, including poppler plugin
+# - Restore missing .desktop file and AUTHORS doc
+# - Add an icon
+# - Include generated man pages
+# - fix homepage URL
+
PRGNAM=zathura
-VERSION=${VERSION:-0.0.8.3}
+VERSION=${VERSION:-0.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,8 +47,28 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -eu
+# zathura no longer includes PDF support in the core. Instead it uses
+# plugins. This build includes the default PDF plugin, without which zathura
+# completely useless.
+PLUGIN=$PRGNAM-pdf-poppler
+PLUGINVER=${PLUGINVER:-$VERSION}
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -55,22 +82,55 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-make
-make install DESTDIR=$PKG
+# zathura uses rst2man from docutils to generate its man pages. Rather than
+# require docutils (1.5MB download) as a dep, just include the man pages (5KB)
+# with the SlackBuild archive.
+mkdir -p $PKG/usr/man/man1 $PKG/usr/man/man5
+cp $CWD/*.1.gz $PKG/usr/man/man1/
+cp $CWD/*.5.gz $PKG/usr/man/man5/
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
-mv $PKG/usr/share/man $PKG/usr
-rm -rf $PKG/usr/share
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+make LIBDIR=/usr/lib$LIBDIRSUFFIX
+make install LIBDIR=/usr/lib$LIBDIRSUFFIX DESTDIR=$PKG RSTTOMAN=""
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Now build the plugin.
+cd $TMP
+# Hack, lets #include <zathura/document.h> in pdf.h work with an uninstalled
+# copy of zathura by saying "-I.."
+rm -f $PRGNAM
+ln -s $PRGNAM-$VERSION $PRGNAM
+
+rm -rf $PLUGIN-$PLUGINVER
+tar xvf $CWD/$PLUGIN-$PLUGINVER.tar.gz
+cd $PLUGIN-$PLUGINVER
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i "s/-fPIC/$SLKCFLAGS/" config.mk
+make install \
+ ZATHURA_INC=-I.. \
+ PLUGINDIR=/usr/lib$LIBDIRSUFFIX/$PRGNAM \
+ DESTDIR=$PKG \
+ ZATHURA_VERSION_CHECK=0
+strip $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/*.so
+
+# icon converted from https://pwmt.org/img/fav.ico
+mkdir -p $PKG/usr/share/pixmaps
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+echo "Icon=$PRGNAM" >> $PKG/usr/share/applications/$PRGNAM.desktop
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/zathura/zathura.info b/office/zathura/zathura.info
index ac1cd3c3b2..696d19417b 100644
--- a/office/zathura/zathura.info
+++ b/office/zathura/zathura.info
@@ -1,10 +1,12 @@
PRGNAM="zathura"
-VERSION="0.0.8.3"
-HOMEPAGE="http://zathura.pwmt.org/projects/zathura"
-DOWNLOAD="https://pwmt.org/download/zathura-0.0.8.3.tar.gz"
-MD5SUM="95b1d02593e7055f08da3825ad54954d"
+VERSION="0.1.1"
+HOMEPAGE="http://www.pwmt.org/projects/zathura"
+DOWNLOAD="https://pwmt.org/projects/zathura/download/zathura-0.1.1.tar.gz \
+ https://pwmt.org/projects/zathura/plugins/download/zathura-pdf-poppler-0.1.1.tar.gz"
+MD5SUM="1379dfb1657b323da3b521ed251bb87a \
+ a43db96a893e0b37c446f23202b930d2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Binh Nguyen"
-EMAIL="binhnguyen@fastmail.fm"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
APPROVED="dsomero"
diff --git a/office/zathura/zathura.png b/office/zathura/zathura.png
new file mode 100644
index 0000000000..e17c493b4b
--- /dev/null
+++ b/office/zathura/zathura.png
Binary files differ
diff --git a/office/zathura/zathurarc.5.gz b/office/zathura/zathurarc.5.gz
new file mode 100644
index 0000000000..283dbeed41
--- /dev/null
+++ b/office/zathura/zathurarc.5.gz
Binary files differ