summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Brice Lopez2012-02-12 20:59:14 +0100
committer Niels Horn2012-02-18 12:12:29 +0100
commite17d162371df1091e40937c2f4fdaf5ed28baa0f (patch)
tree9d105f5fc6da0af325744245ace8035de51c1532
parent06a7b9a7bcbf8dd3379a46c597bbfcb10ffeab9a (diff)
downloadslackbuilds-e17d162371df1091e40937c2f4fdaf5ed28baa0f.tar.gz
network/weboob: Added (applications to interact with websites)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--network/weboob/README5
-rw-r--r--network/weboob/doinst.sh9
-rw-r--r--network/weboob/slack-desc19
-rw-r--r--network/weboob/weboob.Slackbuild70
-rw-r--r--network/weboob/weboob.info10
5 files changed, 113 insertions, 0 deletions
diff --git a/network/weboob/README b/network/weboob/README
new file mode 100644
index 0000000000..8a41d4feb0
--- /dev/null
+++ b/network/weboob/README
@@ -0,0 +1,5 @@
+weboob (Web Out Of Browsers) provides several applications to
+interact with a lot of websites.
+
+This requires pysetuptools, mechanize, python-dateutil, html2text,
+nose, feedparser, lxml, rtmpdump, and PyYAML.
diff --git a/network/weboob/doinst.sh b/network/weboob/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/network/weboob/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/network/weboob/slack-desc b/network/weboob/slack-desc
new file mode 100644
index 0000000000..005a109d0f
--- /dev/null
+++ b/network/weboob/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+weboob: weboob (applications to interact with websites)
+weboob:
+weboob: weboob (Web Out Of Browsers) provides several applications to
+weboob: interact with a lot of websites.
+weboob:
+weboob: Homepage: http://symlink.me/projects/weboob
+weboob:
+weboob:
+weboob:
+weboob:
+weboob:
diff --git a/network/weboob/weboob.Slackbuild b/network/weboob/weboob.Slackbuild
new file mode 100644
index 0000000000..5b6c0c8b3d
--- /dev/null
+++ b/network/weboob/weboob.Slackbuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for weboob
+
+# Copyright (C) 2011, Brice Lopez <brice@lopez.banh-bao.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=weboob
+VERSION=${VERSION:-0.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog INSTALL MANIFEST.in README $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/weboob/weboob.info b/network/weboob/weboob.info
new file mode 100644
index 0000000000..bfeef27dbf
--- /dev/null
+++ b/network/weboob/weboob.info
@@ -0,0 +1,10 @@
+PRGNAM="weboob"
+VERSION="0.9.1"
+HOMEPAGE="http://weboob.org/"
+DOWNLOAD="http://symlink.me/attachments/download/146/weboob-0.9.1.tar.gz"
+MD5SUM="be4fd2e008ce197a5214c73bb2f8e9ab"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Brice Lopez"
+EMAIL="brice.lopez@banh-bao.fr"
+APPROVED="rworkman"