summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author ponce2012-02-19 19:18:14 +0100
committer Robby Workman2012-02-20 19:20:30 +0100
commit0727a42a137b82fbe500109cf04c5e9fcff912a4 (patch)
treeb639f58329a6a36e55a2a4d6309f702f898a3ca6
parent1d8c21adb98fa929cf47c08c6e01f2e735c3f066 (diff)
downloadslackbuilds-0727a42a137b82fbe500109cf04c5e9fcff912a4.tar.gz
python/babel: Added (python internationalization tools)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--python/babel/README8
-rw-r--r--python/babel/babel.SlackBuild69
-rw-r--r--python/babel/babel.info10
-rw-r--r--python/babel/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/babel/README b/python/babel/README
new file mode 100644
index 0000000000..eba89f2670
--- /dev/null
+++ b/python/babel/README
@@ -0,0 +1,8 @@
+babel (python internationalization tools)
+
+Babel is a collection of tools for internationalizing Python apps.
+It's composed of two major parts:
+- tools to build and work with gettext message catalogs;
+- a Python interface to the CLDR (Common Locale Data Repository),
+ providing access to various locale display names, localized number
+ and date formatting, etc.
diff --git a/python/babel/babel.SlackBuild b/python/babel/babel.SlackBuild
new file mode 100644
index 0000000000..dd33c5c534
--- /dev/null
+++ b/python/babel/babel.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for babel
+
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=babel
+SRCNAM=Babel
+VERSION=${VERSION:-0.9.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a COPYING ChangeLog README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION/html
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/babel/babel.info b/python/babel/babel.info
new file mode 100644
index 0000000000..8ec8c3df5d
--- /dev/null
+++ b/python/babel/babel.info
@@ -0,0 +1,10 @@
+PRGNAM="babel"
+VERSION="0.9.6"
+HOMEPAGE="http://babel.edgewall.org/"
+DOWNLOAD="http://ftp.edgewall.com/pub/babel/Babel-0.9.6.tar.gz"
+MD5SUM="f0edcad03dfdb5505f337ef1a7690325"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/python/babel/slack-desc b/python/babel/slack-desc
new file mode 100644
index 0000000000..7165a5b745
--- /dev/null
+++ b/python/babel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+babel: babel (python internationalization tools)
+babel:
+babel: Babel is a collection of tools for internationalizing Python apps.
+babel: It's composed of two major parts:
+babel: - tools to build and work with gettext message catalogs;
+babel: - a Python interface to the CLDR (Common Locale Data Repository),
+babel: providing access to various locale display names, localized number
+babel: and date formatting, etc.
+babel:
+babel: homepage: http://babel.edgewall.org/
+babel: