summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author LukenShiro2011-12-16 06:16:31 +0100
committer Niels Horn2011-12-18 03:07:51 +0100
commitb15dc64c5a5d7c273f6b611928ee24e079b228c0 (patch)
treee12271a7630f09dd88a8fcc9bfc931e0b10c0654
parentb54cd749f781ee166d7ff1c50befc8679b01ca06 (diff)
downloadslackbuilds-b15dc64c5a5d7c273f6b611928ee24e079b228c0.tar.gz
development/easygui: Updated for version 0.96.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--development/easygui/README19
-rw-r--r--development/easygui/easygui.SlackBuild13
-rw-r--r--development/easygui/easygui.info8
-rw-r--r--development/easygui/slack-desc8
4 files changed, 19 insertions, 29 deletions
diff --git a/development/easygui/README b/development/easygui/README
index 23da851bb9..b3192eb373 100644
--- a/development/easygui/README
+++ b/development/easygui/README
@@ -1,22 +1,15 @@
-easygui is a module for very simple, very easy GUI programming
-in Python.
+easygui is a module for very simple, very easy GUI programming in Python.
Experienced Pythonistas need support for quick and dirty GUI features.
New Python programmers need GUI capabilities that don't require any
knowledge of Tkinter, frames, widgets, callbacks or lambda. This is
-what easygui provides. Using it, all GUI interactions are invoked
+what easygui provides. Using it, all GUI interactions are invoked
by simple function calls.
easygui is different from other GUIs in that it is NOT event-driven.
It allows you to program in a traditional linear fashion, and to put up
-dialogs for simple input and output when you need to. If you have not yet
-learned the event-driven paradigm for GUI programming, easygui will
-allow you to be productive with very basic tasks immediately. Later, if you
+dialogs for simple input and output when you need to do so. If you have
+not yet learned the event-driven paradigm for GUI programming, easygui will
+allow you to be productive with very basic tasks immediately. If you later
wish to make the transition to an event-driven GUI paradigm, you can move
to an event-driven style with a more powerful GUI package such as anygui,
-PythonCard, Tkinter, wxPython, etc.
-easygui is there just to do very basic stuff. More elaborate stuff should
-be done with more powerful tools. easygui is built on top of Tkinter.
-
-A tutorial and more complete documentation can be found on easygui homepage.
-
-It can display all image-file formats supported by Python Imaging Library.
+PythonCard, Tkinter, wxPython, etcetera.
diff --git a/development/easygui/easygui.SlackBuild b/development/easygui/easygui.SlackBuild
index a38ba416aa..68d266800b 100644
--- a/development/easygui/easygui.SlackBuild
+++ b/development/easygui/easygui.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for easygui
-# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2011 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=easygui
-VERSION=${VERSION:-0.95}
+VERSION=${VERSION:-0.96}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -40,7 +40,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-SRC_VERSION=v$VERSION
+SRC_VERSION=version_${VERSION}_docs
if [ "$ARCH" = "i486" ]; then
LIBDIRSUFFIX=""
@@ -55,8 +55,7 @@ fi
# directory for python packages
PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
-SAMPLEFILE="python_and_check_logo.gif"
-DOCFILES="*.txt *.html"
+DOCFILES="cookbook faq epydoc pydoc tutorial"
set -e # Exit on most errors
@@ -76,12 +75,10 @@ find . \
# install .py source file and sample file
python ./setup.py build install --root=$PKG
-mkdir -p $PKG/$PYTHONDIR
-cp -a $SAMPLEFILE $PKG/$PYTHONDIR
# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+for docdir in $DOCFILES ; do mv $docdir $PKG/usr/doc/$PRGNAM-$VERSION/ ; done
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/easygui/easygui.info b/development/easygui/easygui.info
index 13c3729c29..b14808fea3 100644
--- a/development/easygui/easygui.info
+++ b/development/easygui/easygui.info
@@ -1,10 +1,10 @@
PRGNAM="easygui"
-VERSION="0.95"
+VERSION="0.96"
HOMEPAGE="http://easygui.sourceforge.net/"
-DOWNLOAD="http://easygui.sourceforge.net/download/version0.95/easygui_v0.95.tar.gz"
-MD5SUM="45aac917f91d1378b4e74027dbf21b75"
+DOWNLOAD="http://easygui.sourceforge.net/download/version_0.96/easygui_version_0.96_docs.tar.gz"
+MD5SUM="2b97ebdee114e8723e84ef542506ddf2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
-APPROVED="dsomero"
+APPROVED="rworkman"
diff --git a/development/easygui/slack-desc b/development/easygui/slack-desc
index 282bd5ccd1..ba472cedfe 100644
--- a/development/easygui/slack-desc
+++ b/development/easygui/slack-desc
@@ -7,13 +7,13 @@
|-----handy-ruler-------------------------------------------------------|
easygui: easygui (very easy GUI programming in python on top of Tkinter)
-easygui:
+easygui:
easygui: It provides an easy-to-use interface for simple GUI interaction with
easygui: a user. It does not require the programmer to know anything about
easygui: tkinter, frames, widgets, callbacks or lambda.
easygui: All GUI interactions are invoked by simple function calls that return
easygui: results. It is written by Stephen Ferg.
-easygui:
-easygui:
+easygui:
easygui: Homepage: http://easygui.sourceforge.net
-easygui:
+easygui:
+easygui: