summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov2011-09-03 03:16:21 +0200
committer Niels Horn2011-09-03 03:16:21 +0200
commiteb9abaad731ae9bc3f0d30a94fb117f00f41d822 (patch)
tree64771a4dfcc6d37f21d88929347983d8d6f32641
parent34ea59f9a15c468cef83c81ac23a3d850c1c04aa (diff)
downloadslackbuilds-eb9abaad731ae9bc3f0d30a94fb117f00f41d822.tar.gz
academic/PhyML: Added (Phylogeny software)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--academic/PhyML/PhyML.SlackBuild94
-rw-r--r--academic/PhyML/PhyML.info10
-rw-r--r--academic/PhyML/README10
-rw-r--r--academic/PhyML/References6
-rw-r--r--academic/PhyML/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
new file mode 100644
index 0000000000..5fb6ce9fcf
--- /dev/null
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for PhyML
+# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
+# hereby submitted to the public domain
+
+# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
+# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
+# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+
+PRGNAM=PhyML
+VERSION=${VERSION:-3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
+SRCVER=2010023
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/${SRCNAM}_$SRCVER.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+aclocal
+autoconf -f
+automake -f
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+#Use our CFLAGS
+sed -i "/^AM_CFLAGS/s/=/+=/" src/Makefile
+
+AM_CFLAGS="$SLKCFLAGS" \
+ make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog COPYING INSTALL \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/PhyML/PhyML.info b/academic/PhyML/PhyML.info
new file mode 100644
index 0000000000..8008d1b6ba
--- /dev/null
+++ b/academic/PhyML/PhyML.info
@@ -0,0 +1,10 @@
+PRGNAM="PhyML"
+VERSION="3.0"
+HOMEPAGE="http://www.atgc-montpellier.fr/phyml/"
+DOWNLOAD="http://phyml.googlecode.com/files/phyml_2010023.tar.gz"
+MD5SUM="80a4e936a17b25ba0175e29d64285b05"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
+APPROVED="Niels Horn"
diff --git a/academic/PhyML/README b/academic/PhyML/README
new file mode 100644
index 0000000000..f86217a2ad
--- /dev/null
+++ b/academic/PhyML/README
@@ -0,0 +1,10 @@
+PhyML is a phylogeny software based on the maximum-likelihood
+principle. Early PhyML versions used a fast algorithm to perform
+Nearest Neighbor Interchanges (NNIs), in order to improve a
+reasonable starting tree topology.
+
+For details and citation
+New Algorithms and Methods to Estimate Maximum-Likelihood
+Phylogenies: Assessing the Performance of PhyML 3.0. Guindon S.,
+Dufayard J.F., Lefort V., Anisimova M., Hordijk W., Gascuel O.
+Systematic Biology, 59(3):307-21, 2010. \ No newline at end of file
diff --git a/academic/PhyML/References b/academic/PhyML/References
new file mode 100644
index 0000000000..0d69b95fe4
--- /dev/null
+++ b/academic/PhyML/References
@@ -0,0 +1,6 @@
+References
+
+New Algorithms and Methods to Estimate Maximum-Likelihood Phylogenies:
+Assessing the Performance of PhyML 3.0. Guindon S., Dufayard J.F.,
+Lefort V., Anisimova M., Hordijk W., Gascuel O. Systematic Biology,
+59(3):307-21, 2010.
diff --git a/academic/PhyML/slack-desc b/academic/PhyML/slack-desc
new file mode 100644
index 0000000000..00859ef7ab
--- /dev/null
+++ b/academic/PhyML/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+PhyML: PhyML (Phylogeny software)
+PhyML:
+PhyML: PhyML is a phylogeny software based on the maximum-likelihood
+PhyML: principle. Early PhyML versions used a fast algorithm to perform
+PhyML: Nearest Neighbor Interchanges (NNIs), in order to improve a
+PhyML: reasonable starting tree topology.
+PhyML:
+PhyML:
+PhyML:
+PhyML: References: /usr/doc/PhyML-$VERSION/References
+PhyML: Home: http://www.atgc-montpellier.fr/phyml/