summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Kyle Guinn2011-03-03 07:10:21 +0100
committer Robby Workman2011-03-04 17:12:45 +0100
commit28091409e585946c0a51f27aea51cfccbcc5f3a2 (patch)
tree4510b70b3d9c104c4c3a7ab0b09bf7e4df67365a
parent3ea4389ecf732f917e4069a0142c28f497e4ad0e (diff)
downloadslackbuilds-28091409e585946c0a51f27aea51cfccbcc5f3a2.tar.gz
audio/TiMidity++: Misc tweaks including +jack +speex -arts
For clarity's sake, this commit adds jack and speex support, removes artsd support, and has various other minor cleanups. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--audio/TiMidity++/README10
-rw-r--r--audio/TiMidity++/TiMidity++.SlackBuild24
-rw-r--r--audio/TiMidity++/TiMidity++.info2
-rw-r--r--audio/TiMidity++/patches/speex.diff38
4 files changed, 65 insertions, 9 deletions
diff --git a/audio/TiMidity++/README b/audio/TiMidity++/README
index 266ea30bd6..305dc68822 100644
--- a/audio/TiMidity++/README
+++ b/audio/TiMidity++/README
@@ -1,11 +1,17 @@
TiMidity++ is a software synthesizer. It can play MIDI files by converting
them into PCM waveform data or other various audio file formats.
+To add JACK support, install jack-audio-connection-kit and build with:
+JACK=yes ./TiMidity++.SlackBuild
+
+To add speex support, install speex and build with:
+SPEEX=yes ./TiMidity++.SlackBuild
+
TiMidity++ can also be run as an ALSA sequencer client. To do this, make
/etc/rc.d/rc.timidity executable and add this line to /etc/rc.d/rc.local:
/etc/rc.d/rc.timidity start
You will need a set of instrument patch files for TiMidity++ to be of any
-use. The freepats and eawpats packages, also available at SlackBuilds.org,
-both provide a set of patch files.
+use. The freepats and eawpats packages both provide a set of patch files,
+so one of those will be needed.
diff --git a/audio/TiMidity++/TiMidity++.SlackBuild b/audio/TiMidity++/TiMidity++.SlackBuild
index a1ba1aa60a..e8a00e4474 100644
--- a/audio/TiMidity++/TiMidity++.SlackBuild
+++ b/audio/TiMidity++/TiMidity++.SlackBuild
@@ -2,21 +2,18 @@
# Slackware build script for TiMidity++
# Written by Kyle Guinn <elyk03@gmail.com>
-
# Changes for Slackware 12.1 by Richard Hoyle <hoyle.richard@gmail.com>
# Modified by Michiel van Wessem. <michiel.van.wessem@gmail.com>
PRGNAM="TiMidity++"
VERSION="2.13.2"
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-5}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -27,6 +24,21 @@ PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
DOCS="AUTHORS COPYING ChangeLog* INSTALL* NEWS README* TODO doc/C/README* doc/C/FAQ doc/C/CHANGES.02i"
+ENABLE_AUDIO="alsa,oss,esd,ao,vorbis,flac"
+ENABLE_DYNAMIC="gtk,ncurses,motif,tcltk,emacs,vt100"
+
+# Support JACK. Requires JACK, of course.
+# Disabled by default for those who don't want to install/configure it.
+JACK=${JACK:-no}
+if [ "$JACK" = "yes" ]; then
+ ENABLE_AUDIO="$ENABLE_AUDIO,jack"
+fi
+
+# Support speex. Also disabled by default.
+SPEEX=${SPEEX:-no}
+if [ "$SPEEX" = "yes" ]; then
+ ENABLE_AUDIO="$ENABLE_AUDIO,speex"
+fi
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -78,8 +90,8 @@ EXTRACFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--with-module-dir=/usr/lib${LIBDIRSUFFIX}/timidity \
- --enable-audio=alsa,oss,arts,esd,ao,vorbis,flac \
- --enable-dynamic=gtk,ncurses,motif,tcltk,emacs,vt100 \
+ --enable-audio=${ENABLE_AUDIO} \
+ --enable-dynamic=${ENABLE_DYNAMIC} \
--enable-alsaseq \
--enable-server \
--enable-network \
diff --git a/audio/TiMidity++/TiMidity++.info b/audio/TiMidity++/TiMidity++.info
index c99708a334..e513d82171 100644
--- a/audio/TiMidity++/TiMidity++.info
+++ b/audio/TiMidity++/TiMidity++.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"
-APPROVED="Erik Hanson"
+APPROVED="rworkman"
diff --git a/audio/TiMidity++/patches/speex.diff b/audio/TiMidity++/patches/speex.diff
new file mode 100644
index 0000000000..c0f71b1190
--- /dev/null
+++ b/audio/TiMidity++/patches/speex.diff
@@ -0,0 +1,38 @@
+diff --git a/configure b/configure
+--- a/configure
++++ b/configure
+@@ -14785,7 +14785,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+
+- #include <speex.h>
++ #include <speex/speex.h>
+ #include <ogg/ogg.h>
+
+ int
+diff --git a/configure.in b/configure.in
+--- a/configure.in
++++ b/configure.in
+@@ -1230,7 +1230,7 @@
+ if test "x$au_enable_speex" = xyes; then
+ AC_CACHE_VAL(have_speex,
+ [AC_TRY_LINK([
+- #include <speex.h>
++ #include <speex/speex.h>
+ #include <ogg/ogg.h>
+ ],
+ [
+diff --git a/timidity/speex_a.c b/timidity/speex_a.c
+--- a/timidity/speex_a.c
++++ b/timidity/speex_a.c
+@@ -33,8 +33,8 @@
+ #include <fcntl.h>
+ #endif
+
+-#include <speex.h>
+-#include <speex_header.h>
++#include <speex/speex.h>
++#include <speex/speex_header.h>
+ #include <ogg/ogg.h>
+
+ #include "timidity.h"