summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Zbigniew Baniewski2011-01-06 21:42:14 +0100
committer Robby Workman2011-01-10 22:04:23 +0100
commit958abc1de3644ebe3dc4316748f28aeb2423f91e (patch)
treeeccd567a378373f392f8cb1471df8bd97dffb0fb
parentd9fa4977912e6a91a00306fc826f1634bb8019ae (diff)
downloadslackbuilds-958abc1de3644ebe3dc4316748f28aeb2423f91e.tar.gz
development/gforth: Added (GNU Forth interpreter)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--development/gforth/README8
-rw-r--r--development/gforth/gforth.SlackBuild88
-rw-r--r--development/gforth/gforth.info10
-rw-r--r--development/gforth/slack-desc20
4 files changed, 126 insertions, 0 deletions
diff --git a/development/gforth/README b/development/gforth/README
new file mode 100644
index 0000000000..c31ed6a30b
--- /dev/null
+++ b/development/gforth/README
@@ -0,0 +1,8 @@
+GNU Forth interpreter that is ANSI compliant.
+
+NOTE: If you Compile or otherwise install the Ffcall package, GForth will
+also have the ability to call libraries of C software. Ffcall must be
+installed first in order for GForth to detect this, however.
+However, GForth can run on its own without Ffcall. For this reason, Ffcall
+is not listed as a dependency.
+
diff --git a/development/gforth/gforth.SlackBuild b/development/gforth/gforth.SlackBuild
new file mode 100644
index 0000000000..e192f33df1
--- /dev/null
+++ b/development/gforth/gforth.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for gforth
+
+# Written by Zbigniew Baniewski, zb@ispid.com.pl
+
+PRGNAM=gforth
+VERSION=0.7.0
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix old-style flag
+sed -i "s/-m486/-mtune=i486/g" configure.in
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+rm -f $PKG/usr/info/dir
+gzip -9 $PKG/usr/info/*.info*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ doc/gforth.ps AUTHORS BUGS COPYING* ChangeLog NEWS* README* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gforth/gforth.info b/development/gforth/gforth.info
new file mode 100644
index 0000000000..da4a7734af
--- /dev/null
+++ b/development/gforth/gforth.info
@@ -0,0 +1,10 @@
+PRGNAM="gforth"
+VERSION="0.7.0"
+HOMEPAGE="http://www.gnu.org/software/gforth/"
+DOWNLOAD="http://mirrors.kernel.org/gnu/gforth/gforth-0.7.0.tar.gz"
+MD5SUM="2979ae86ede73ce2b3576dae957f4098"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Zbigniew Baniewski"
+EMAIL="zb@ispid.com.pl"
+APPROVED="Niels Horn"
diff --git a/development/gforth/slack-desc b/development/gforth/slack-desc
new file mode 100644
index 0000000000..ea76fa7bfb
--- /dev/null
+++ b/development/gforth/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gforth: gforth (GNU Forth interpreter)
+gforth:
+gforth: GNU Forth interpreter that is ANSI compliant.
+gforth:
+gforth: http://www.gnu.org/software/gforth/
+gforth:
+gforth:
+gforth:
+gforth:
+gforth:
+gforth:
+