summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2010-10-20 08:24:18 +0200
committer Erik Hanson2010-10-20 17:50:47 +0200
commitb30abf75a50233c0c8d9ab393b08aa68e0198ad7 (patch)
tree8f4c05099a9c520a928431ee05e36148bb1f5dbd
parentf2581bfdace3a7a4e6eeb2be804f202fb8ba1487 (diff)
downloadslackbuilds-b30abf75a50233c0c8d9ab393b08aa68e0198ad7.tar.gz
graphics/exact-image: Updated for version 0.8.2.
-rw-r--r--graphics/exact-image/README9
-rw-r--r--graphics/exact-image/exact-image.SlackBuild6
-rw-r--r--graphics/exact-image/exact-image.info8
-rw-r--r--graphics/exact-image/fixup-perl_paths.diff12
-rw-r--r--graphics/exact-image/fixup-python_and_perl_paths.diff22
-rw-r--r--graphics/exact-image/png.cc-libpng14.diff6
6 files changed, 27 insertions, 36 deletions
diff --git a/graphics/exact-image/README b/graphics/exact-image/README
index 50317b273d..c22626293b 100644
--- a/graphics/exact-image/README
+++ b/graphics/exact-image/README
@@ -1,9 +1,10 @@
ExactImage is an image processing library which reimplements ImageMagick
functions with a significant speed improvement. The library also provides
several new algorithms: lossless JPEG transforms and creation of searchable
-PDFs from hOCR annotated HTML. There are bindings for PHP, Lua, Perl, and
-Python. See /usr/doc/exact-image-*/examples/ for information on using
+PDFs from hOCR annotated HTML created with an OCR program such as Tesseract or
+Cuneiform (available at Slackbuilds.org). There are bindings for PHP, Lua, Perl,
+and Python. See /usr/doc/exact-image-*/examples/ for information on using
exactimage with Perl, Python, PHP and Lua.
-This requires agg. lua and evas are optional dependencies, as is bardecode,
-but bardecode is not available from SlackBuilds.org.
+ExactImage requires agg. Lua and evas are optional dependencies available at
+Slackbuilds.org, while bardecode is optional but not available.
diff --git a/graphics/exact-image/exact-image.SlackBuild b/graphics/exact-image/exact-image.SlackBuild
index d99176051a..af5bcabc21 100644
--- a/graphics/exact-image/exact-image.SlackBuild
+++ b/graphics/exact-image/exact-image.SlackBuild
@@ -3,7 +3,7 @@
# Written by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
PRGNAM=exact-image
-VERSION=${VERSION:-0.8.1}
+VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,9 +52,9 @@ find . \
# Patch to fix libpng linkage
patch -p1 --verbose < $CWD/png.cc-libpng14.diff
-# Patch to fix python and perl paths
+# Patch to fix perl path
eval $(perl -V:vendorlib)
-sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-python_and_perl_paths.diff | patch -p1
+sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-perl_paths.diff | patch -p1
./configure \
--bindir=/usr/bin \
diff --git a/graphics/exact-image/exact-image.info b/graphics/exact-image/exact-image.info
index 738aa895a9..f7165783cf 100644
--- a/graphics/exact-image/exact-image.info
+++ b/graphics/exact-image/exact-image.info
@@ -1,10 +1,10 @@
PRGNAM="exact-image"
-VERSION="0.8.1"
+VERSION="0.8.2"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
-DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.1.tar.bz2"
-MD5SUM="f6c5a068a21a90c314ba557f0a601352"
+DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.2.tar.bz2"
+MD5SUM="57df19be487307df1579b1f370c28e83"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="bosth@alumni.sfu.ca"
-APPROVED="rworkman"
+APPROVED="Erik Hanson"
diff --git a/graphics/exact-image/fixup-perl_paths.diff b/graphics/exact-image/fixup-perl_paths.diff
new file mode 100644
index 0000000000..9f463c6e97
--- /dev/null
+++ b/graphics/exact-image/fixup-perl_paths.diff
@@ -0,0 +1,12 @@
+diff -Nur exact-image-0.8.2.orig//api/perl/Makefile exact-image-0.8.2/api/perl/Makefile
+--- exact-image-0.8.2.orig//api/perl/Makefile 2008-12-09 03:42:19.000000000 -0600
++++ exact-image-0.8.2/api/perl/Makefile 2010-06-23 08:57:13.015010261 -0500
+@@ -20,5 +20,6 @@
+ all:: $($(X_MODULE)_BINARY)
+ install:: $($(X_MODULE)_BINARY)
+ $(Q)echo "INSTALL PERL module $^"
+- $(Q)mkdir -p $(DESTDIR)$(libdir)/perl5/site_perl/
+- $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)$(libdir)/perl5/site_perl/
++ eval `perl -V:vendorlib`
++ $(Q)mkdir -p $(DESTDIR)@vendorlib@
++ $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)@vendorlib@
diff --git a/graphics/exact-image/fixup-python_and_perl_paths.diff b/graphics/exact-image/fixup-python_and_perl_paths.diff
deleted file mode 100644
index 2620628c13..0000000000
--- a/graphics/exact-image/fixup-python_and_perl_paths.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Nur exact-image-0.8.1.orig//api/perl/Makefile exact-image-0.8.1/api/perl/Makefile
---- exact-image-0.8.1.orig//api/perl/Makefile 2008-12-09 03:42:19.000000000 -0600
-+++ exact-image-0.8.1/api/perl/Makefile 2010-06-23 08:57:13.015010261 -0500
-@@ -20,5 +20,6 @@
- all:: $($(X_MODULE)_BINARY)
- install:: $($(X_MODULE)_BINARY)
- $(Q)echo "INSTALL PERL module $^"
-- $(Q)mkdir -p $(DESTDIR)$(libdir)/perl5/site_perl/
-- $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)$(libdir)/perl5/site_perl/
-+ eval `perl -V:vendorlib`
-+ $(Q)mkdir -p $(DESTDIR)@vendorlib@
-+ $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)@vendorlib@
-diff -Nur exact-image-0.8.1.orig//api/python/Makefile exact-image-0.8.1/api/python/Makefile
---- exact-image-0.8.1.orig//api/python/Makefile 2010-04-05 10:28:40.000000000 -0500
-+++ exact-image-0.8.1/api/python/Makefile 2010-06-23 08:58:08.206169868 -0500
-@@ -20,5 +20,5 @@
- all:: $($(X_MODULE)_BINARY)
- install:: $($(X_MODULE)_BINARY)
- $(Q)echo "INSTALL PYTHON module $^"
-- $(Q)mkdir -p $(DESTDIR)$(libdir)/python2.5/site-packages/
-+ $(Q)mkdir -p $(DESTDIR)$(shell python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')
- $(Q)install $(dir $^)/ExactImage.py $^ $(DESTDIR)$(shell python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')/
diff --git a/graphics/exact-image/png.cc-libpng14.diff b/graphics/exact-image/png.cc-libpng14.diff
index d6f639ff4a..5084f4fce6 100644
--- a/graphics/exact-image/png.cc-libpng14.diff
+++ b/graphics/exact-image/png.cc-libpng14.diff
@@ -1,6 +1,6 @@
-diff -Naur exact-image-0.8.1-old/codecs/png.cc exact-image-0.8.1/codecs/png.cc
---- exact-image-0.8.1-old/codecs/png.cc 2010-06-16 02:46:40.349543689 +0300
-+++ exact-image-0.8.1/codecs/png.cc 2010-06-16 02:57:50.156542917 +0300
+diff -Naur exact-image-0.8.2-old/codecs/png.cc exact-image-0.8.2/codecs/png.cc
+--- exact-image-0.8.2-old/codecs/png.cc 2010-06-16 02:46:40.349543689 +0300
++++ exact-image-0.8.2/codecs/png.cc 2010-06-16 02:57:50.156542917 +0300
@@ -71,7 +71,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);