summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pablo Santamaria2010-08-16 00:24:18 +0200
committer Erik Hanson2010-08-16 03:53:42 +0200
commitd4cf7aab1008d68eed440a262541745f71f0ef41 (patch)
tree476f997984ca7b35ab284369ab94598c6846c25d
parent0b8bbbe4a63ad9555891079e860d09504acc252c (diff)
downloadslackbuilds-d4cf7aab1008d68eed440a262541745f71f0ef41.tar.gz
network/gmapcatcher: Added (An offline map viewer)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--network/gmapcatcher/README9
-rw-r--r--network/gmapcatcher/gmapcatcher.SlackBuild85
-rw-r--r--network/gmapcatcher/gmapcatcher.info10
-rw-r--r--network/gmapcatcher/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/network/gmapcatcher/README b/network/gmapcatcher/README
new file mode 100644
index 0000000000..773aed0c6a
--- /dev/null
+++ b/network/gmapcatcher/README
@@ -0,0 +1,9 @@
+GMapCatcher is an offline maps viewer. It downloads tiles automatically
+from many providers such as: CloudMade, OpenStreetMap, Yahoo Maps,
+Google Map. It displays them using a custom GUI. User can view the
+maps while offline. GMapCatcher doesn't depend on google-map's java
+scripts so it should work even if google changes them. It also provides
+a downloading tool.
+
+GMapCatcher is written in Python 2.6, can run on Linux, Windows and
+Mac OSX.
diff --git a/network/gmapcatcher/gmapcatcher.SlackBuild b/network/gmapcatcher/gmapcatcher.SlackBuild
new file mode 100644
index 0000000000..2ca203da7c
--- /dev/null
+++ b/network/gmapcatcher/gmapcatcher.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for gmapcatcher
+
+# Written by Pablo Santamaria (pablosantamaria)
+
+PRGNAM=gmapcatcher
+VERSION=${VERSION:-0.7.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf GMapCatcher-$VERSION
+tar xvf $CWD/GMapCatcher-$VERSION.tar.gz
+cd GMapCatcher-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Prepare files for install
+rm -rf WindowsMobile
+mv maps.py mapcatcher
+mv download.py mapdownloader
+mv Changelog changelog
+gzip -9 man/mapcatcher.1
+gzip -9 man/mapdownloader.1
+cp images/map.png images/mapcatcher.png
+chmod a-x gmapcatcher.desktop
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Relocate man pages
+mv $PKG/usr/share/man $PKG/usr
+
+# Relocate docs
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/mapcatcher $PKG/usr/doc/$PRGNAM-$VERSION
+rmdir $PKG/usr/share/doc
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/gmapcatcher/gmapcatcher.info b/network/gmapcatcher/gmapcatcher.info
new file mode 100644
index 0000000000..b8602349ee
--- /dev/null
+++ b/network/gmapcatcher/gmapcatcher.info
@@ -0,0 +1,10 @@
+PRGNAM="gmapcatcher"
+VERSION="0.7.2.0"
+HOMEPAGE="http://code.google.com/p/gmapcatcher/"
+DOWNLOAD="http://gmapcatcher.googlecode.com/files/GMapCatcher-0.7.2.0.tar.gz"
+MD5SUM="406aa0a2bd0f515f9131fdd9269eca1a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Pablo Santamaria"
+EMAIL="pablosantamaria@gmail.com"
+APPROVED="dsomero"
diff --git a/network/gmapcatcher/slack-desc b/network/gmapcatcher/slack-desc
new file mode 100644
index 0000000000..eba8d77b01
--- /dev/null
+++ b/network/gmapcatcher/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gmapcatcher: gmapcatcher (An offline map viewer)
+gmapcatcher:
+gmapcatcher: GMapCatcher is an offline maps viewer. It downloads tiles
+gmapcatcher: automatically from many providers such as: CloudMade, OpenStreetMap,
+gmapcatcher: Yahoo Maps, Google Map. It displays them using a custom GUI. User can
+gmapcatcher: view the maps while offline. GMapCatcher doesn't depend on
+gmapcatcher: google-map's java scripts so it should work even if google changes
+gmapcatcher: them. It also provides a downloading tool.
+gmapcatcher:
+gmapcatcher:
+gmapcatcher: