summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Binh Nguyen2010-08-16 06:58:30 +0200
committer Erik Hanson2010-08-18 21:01:18 +0200
commit27f192616fa3814b3d284d07cf94901e60b58a1a (patch)
treeacd616887e205f9e1365f7c33dbd627a65705575
parent948e28d905b425d56430e2810df4384fa8d8c0f0 (diff)
downloadslackbuilds-27f192616fa3814b3d284d07cf94901e60b58a1a.tar.gz
graphics/mirage: Added (fast and simple GTK+ image viewer)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--graphics/mirage/README3
-rw-r--r--graphics/mirage/doinst.sh4
-rw-r--r--graphics/mirage/mirage.SlackBuild71
-rw-r--r--graphics/mirage/mirage.info10
-rw-r--r--graphics/mirage/slack-desc19
5 files changed, 107 insertions, 0 deletions
diff --git a/graphics/mirage/README b/graphics/mirage/README
new file mode 100644
index 0000000000..0c47e1ac94
--- /dev/null
+++ b/graphics/mirage/README
@@ -0,0 +1,3 @@
+Mirage is a fast and simple GTK+ image viewer. Because it depends only on
+PyGTK, Mirage is ideal for users who wish to keep their computers lean while
+still having a clean image viewer.
diff --git a/graphics/mirage/doinst.sh b/graphics/mirage/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/graphics/mirage/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/graphics/mirage/mirage.SlackBuild b/graphics/mirage/mirage.SlackBuild
new file mode 100644
index 0000000000..37763cbba8
--- /dev/null
+++ b/graphics/mirage/mirage.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for Mirage
+
+# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Copyright 2010 Binh Nguyen <binhnguyen@fastmail.fm>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mirage
+VERSION=${VERSION:-0.9.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+for i in CHANGELOG COPYING README TODO TRANSLATORS ; do
+ ln -s /usr/share/mirage/$i $PKG/usr/doc/$PRGNAM-$VERSION/$i ;
+done
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/mirage/mirage.info b/graphics/mirage/mirage.info
new file mode 100644
index 0000000000..90cbcd41c3
--- /dev/null
+++ b/graphics/mirage/mirage.info
@@ -0,0 +1,10 @@
+PRGNAM="mirage"
+VERSION="0.9.5.1"
+HOMEPAGE="http://mirageiv.berlios.de/"
+DOWNLOAD="http://download.berlios.de/mirageiv/mirage-0.9.5.1.tar.bz2"
+MD5SUM="1ccb7f9ce8d98630b7d94ca65f1a8005"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Binh Nguyen"
+EMAIL="binhnguyen@fastmail.fm"
+APPROVED="rworkman"
diff --git a/graphics/mirage/slack-desc b/graphics/mirage/slack-desc
new file mode 100644
index 0000000000..0ed149c011
--- /dev/null
+++ b/graphics/mirage/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mirage: Mirage (GTK+ Image Viewer)
+mirage:
+mirage: Mirage is a fast and simple GTK+ image viewer. Because it depends only
+mirage: on PyGTK, Mirage is ideal for users who wish to keep their computers
+mirage: lean while still having a clean image viewer.
+mirage:
+mirage: Homepage: http://mirageiv.berlios.de/
+mirage:
+mirage:
+mirage:
+mirage: