summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mikko Värri2010-08-16 00:23:23 +0200
committer Erik Hanson2010-08-16 03:53:42 +0200
commit0b8bbbe4a63ad9555891079e860d09504acc252c (patch)
tree6d4b5cb9cd93405d55d36f941063cb0c6f0be7f4
parentcfc489b45520367915c4dd97516a54bab6569aac (diff)
downloadslackbuilds-0b8bbbe4a63ad9555891079e860d09504acc252c.tar.gz
network/canto: Added (An ncurses RSS aggregator)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--network/canto/README10
-rw-r--r--network/canto/canto.SlackBuild61
-rw-r--r--network/canto/canto.info10
-rw-r--r--network/canto/slack-desc19
4 files changed, 100 insertions, 0 deletions
diff --git a/network/canto/README b/network/canto/README
new file mode 100644
index 0000000000..3e91d67cfa
--- /dev/null
+++ b/network/canto/README
@@ -0,0 +1,10 @@
+canto (An ncurses RSS aggregator)
+
+Canto is an Atom/RSS feed reader for the console that is meant to be
+quick, concise, and colorful. It is meant to allow you to crank
+through feeds like you've never cranked before by providing a
+minimal, yet information packed interface. An interface with almost
+infinite customization and extensibility using the excellent Python
+programming language.
+
+This requires python2-chardet.
diff --git a/network/canto/canto.SlackBuild b/network/canto/canto.SlackBuild
new file mode 100644
index 0000000000..cb1713803c
--- /dev/null
+++ b/network/canto/canto.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for canto
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=canto
+VERSION=${VERSION:-0.7.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir $PKG/usr/share
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog INSTALL README doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/canto/canto.info b/network/canto/canto.info
new file mode 100644
index 0000000000..c788418696
--- /dev/null
+++ b/network/canto/canto.info
@@ -0,0 +1,10 @@
+PRGNAM="canto"
+VERSION="0.7.10"
+HOMEPAGE="http://codezen.org/canto/"
+DOWNLOAD="http://codezen.org/static/canto-0.7.10.tar.gz"
+MD5SUM="541d1770496866a5d513305e118b2ab5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="dsomero"
diff --git a/network/canto/slack-desc b/network/canto/slack-desc
new file mode 100644
index 0000000000..afba919f7f
--- /dev/null
+++ b/network/canto/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+canto: canto (An ncurses RSS aggregator)
+canto:
+canto: Canto is an Atom/RSS feed reader for the console that is meant to be
+canto: quick, concise, and colorful. It is meant to allow you to crank
+canto: through feeds like you've never cranked before by providing a
+canto: minimal, yet information packed interface. An interface with almost
+canto: infinite customization and extensibility using the excellent Python
+canto: programming language.
+canto:
+canto: Homepage: http://codezen.org/canto/
+canto: