summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mikko Värri2010-08-14 22:50:30 +0200
committer Erik Hanson2010-08-15 02:04:53 +0200
commit392e0a05e356e65d70b4c16acd16a7002996e9cc (patch)
tree3fc5d167df924063bd8b7781a8e7d6d7a8b344cc
parent5dd644b4254988619c1aae500a6dd64a9ecd27cb (diff)
downloadslackbuilds-392e0a05e356e65d70b4c16acd16a7002996e9cc.tar.gz
libraries/ZODB3: Added (Zope Object Database)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--libraries/ZODB3/README12
-rw-r--r--libraries/ZODB3/ZODB3.SlackBuild54
-rw-r--r--libraries/ZODB3/ZODB3.info10
-rw-r--r--libraries/ZODB3/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/libraries/ZODB3/README b/libraries/ZODB3/README
new file mode 100644
index 0000000000..d44aa923bc
--- /dev/null
+++ b/libraries/ZODB3/README
@@ -0,0 +1,12 @@
+ZODB3 (Zope Object Database)
+
+The Zope Object Database provides an object-oriented database for
+Python that provides a high-degree of transparency. Applications
+can take advantage of object database features with few, if any,
+changes to application logic. ZODB includes features such as a
+plugable storage interface, rich transaction support, and undo.
+
+This requires zope.event, python-transaction, zc.lockfile, ZConfig,
+zdaemon, zope.interface and zope.proxy.
+
+To build, this requires pysetuptools.
diff --git a/libraries/ZODB3/ZODB3.SlackBuild b/libraries/ZODB3/ZODB3.SlackBuild
new file mode 100644
index 0000000000..ea60fa1e00
--- /dev/null
+++ b/libraries/ZODB3/ZODB3.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for ZODB3
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=ZODB3
+VERSION=${VERSION:-3.9.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING COPYRIGHT.txt HISTORY.txt LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ZODB3/ZODB3.info b/libraries/ZODB3/ZODB3.info
new file mode 100644
index 0000000000..30f4db1624
--- /dev/null
+++ b/libraries/ZODB3/ZODB3.info
@@ -0,0 +1,10 @@
+PRGNAM="ZODB3"
+VERSION="3.9.5"
+HOMEPAGE="http://pypi.python.org/pypi/ZODB3/"
+DOWNLOAD="http://pypi.python.org/packages/source/Z/ZODB3/ZODB3-3.9.5.tar.gz"
+MD5SUM="66b76f30c4cee72f5dbd749a7611e83e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"
diff --git a/libraries/ZODB3/slack-desc b/libraries/ZODB3/slack-desc
new file mode 100644
index 0000000000..f7e713eac2
--- /dev/null
+++ b/libraries/ZODB3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+ZODB3: ZODB3 (Zope Object Database)
+ZODB3:
+ZODB3: The Zope Object Database provides an object-oriented database for
+ZODB3: Python that provides a high-degree of transparency. Applications
+ZODB3: can take advantage of object database features with few, if any,
+ZODB3: changes to application logic. ZODB includes features such as a
+ZODB3: plugable storage interface, rich transaction support, and undo.
+ZODB3:
+ZODB3:
+ZODB3:
+ZODB3: