summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Joey Trungale2010-07-08 10:25:45 +0200
committer Robby Workman2010-07-08 10:25:45 +0200
commitd2b6b528430f2feb9fb87d514dc46289ae3a4961 (patch)
tree77a7aa2ece7be4979f0723777b9e320cdbe05604
parent55dfd427fe2e932ba9c7cb9ca9d99a73e496d762 (diff)
downloadslackbuilds-d2b6b528430f2feb9fb87d514dc46289ae3a4961.tar.gz
libraries/pycontrol: Added (Python library for the F5 iControl API)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/pycontrol/README7
-rw-r--r--libraries/pycontrol/pycontrol.SlackBuild58
-rw-r--r--libraries/pycontrol/pycontrol.info10
-rw-r--r--libraries/pycontrol/slack-desc19
4 files changed, 94 insertions, 0 deletions
diff --git a/libraries/pycontrol/README b/libraries/pycontrol/README
new file mode 100644
index 0000000000..699197a4de
--- /dev/null
+++ b/libraries/pycontrol/README
@@ -0,0 +1,7 @@
+pyControl is a Python-based library that integrates with F5's BIG-IP
+iControl management API.
+
+The source at the F5 site requires a free registraton and login.
+For simplicity, I have the source available at my personal site.
+
+This requires python-suds.
diff --git a/libraries/pycontrol/pycontrol.SlackBuild b/libraries/pycontrol/pycontrol.SlackBuild
new file mode 100644
index 0000000000..5c5e2dc19c
--- /dev/null
+++ b/libraries/pycontrol/pycontrol.SlackBuild
@@ -0,0 +1,58 @@
+#!/bin/sh
+
+# Slackware build script for pycontrol
+# Written by Joey Trungale <joey@trungale.net>
+
+PRGNAM=pycontrol
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf trunk
+tar xvf $CWD/$PRGNAM.tar.gz
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Remove SVN directories
+rm -rf trunk/pycontrol/.svn
+rm -rf trunk/pycontrol/samples/.svn
+rm -rf trunk/.svn
+
+cd trunk
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar $PRGNAM/README $PRGNAM/samples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pycontrol/pycontrol.info b/libraries/pycontrol/pycontrol.info
new file mode 100644
index 0000000000..c2c1a83522
--- /dev/null
+++ b/libraries/pycontrol/pycontrol.info
@@ -0,0 +1,10 @@
+PRGNAM="pycontrol"
+VERSION="2.0"
+HOMEPAGE="http://devcentral.f5.com/Community/GroupDetails/tabid/1082223/asg/4/Default.aspx"
+DOWNLOAD="http://trungale.net/pycontrol.tar.gz"
+MD5SUM="e9e11c5fdf05bf877522b89b28e94ed1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Joey Trungale"
+EMAIL="joey@trungale.net"
+APPROVED="rworkman"
diff --git a/libraries/pycontrol/slack-desc b/libraries/pycontrol/slack-desc
new file mode 100644
index 0000000000..006208353d
--- /dev/null
+++ b/libraries/pycontrol/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+pycontrol: pycontrol (Python library for the F5 iControl API)
+pycontrol:
+pycontrol: pyControl is a Python-based library that integrates with F5's BIG-IP
+pycontrol: iControl management API.
+pycontrol:
+pycontrol:
+pycontrol:
+pycontrol:
+pycontrol:
+pycontrol:
+pycontrol: