summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Joey Trungale2010-07-08 10:24:28 +0200
committer Robby Workman2010-07-08 10:24:28 +0200
commit55dfd427fe2e932ba9c7cb9ca9d99a73e496d762 (patch)
tree6cc04553937323183afff974a8dbb8bdf99156e2
parent4e53f7787d3107ad65e464366987eeb917d75154 (diff)
downloadslackbuilds-55dfd427fe2e932ba9c7cb9ca9d99a73e496d762.tar.gz
network/python-suds: Added (lightweight SOAP python client)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--network/python-suds/README3
-rw-r--r--network/python-suds/python-suds.SlackBuild55
-rw-r--r--network/python-suds/python-suds.info10
-rw-r--r--network/python-suds/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/network/python-suds/README b/network/python-suds/README
new file mode 100644
index 0000000000..14650e2966
--- /dev/null
+++ b/network/python-suds/README
@@ -0,0 +1,3 @@
+Suds is a lightweight SOAP python client for consuming Web Services.
+
+This requires pysetuptools.
diff --git a/network/python-suds/python-suds.SlackBuild b/network/python-suds/python-suds.SlackBuild
new file mode 100644
index 0000000000..fb097c17f0
--- /dev/null
+++ b/network/python-suds/python-suds.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for python-suds
+# Written by Joey Trungale <joey@trungale.net>
+
+PRGNAM=python-suds
+VERSION=${VERSION:-0.3.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-suds/python-suds.info b/network/python-suds/python-suds.info
new file mode 100644
index 0000000000..eaf0704eb8
--- /dev/null
+++ b/network/python-suds/python-suds.info
@@ -0,0 +1,10 @@
+PRGNAM="python-suds"
+VERSION="0.3.9"
+HOMEPAGE="https://fedorahosted.org/suds/"
+DOWNLOAD="https://fedorahosted.org/releases/s/u/suds/python-suds-0.3.9.tar.gz"
+MD5SUM="420ac4b6ba788e43631b74719a470bf7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Joey Trungale"
+EMAIL="joey@trungale.net"
+APPROVED="rworkman"
diff --git a/network/python-suds/slack-desc b/network/python-suds/slack-desc
new file mode 100644
index 0000000000..ca8b6eb117
--- /dev/null
+++ b/network/python-suds/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-suds: python-suds (Python SOAP client)
+python-suds:
+python-suds: Suds is a lightweight SOAP python client for consuming Web Services.
+python-suds:
+python-suds: https://fedorahosted.com/suds
+python-suds:
+python-suds:
+python-suds:
+python-suds:
+python-suds:
+python-suds: