summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Šime Ramov2010-07-07 09:50:46 +0200
committer Robby Workman2010-07-08 07:13:25 +0200
commit9119593f4ddf54234f36d6081638d3d2f83979dc (patch)
tree87e4ee3a675d646eab2f531d5a9d57dac913b538
parent63b183341939c4aff7abd001d5760f22c54cf113 (diff)
downloadslackbuilds-9119593f4ddf54234f36d6081638d3d2f83979dc.tar.gz
libraries/html5lib: Added (HTML parser based on the HTML5 spec)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/html5lib/README10
-rw-r--r--libraries/html5lib/html5lib.SlackBuild49
-rw-r--r--libraries/html5lib/html5lib.info10
-rw-r--r--libraries/html5lib/slack-desc19
4 files changed, 88 insertions, 0 deletions
diff --git a/libraries/html5lib/README b/libraries/html5lib/README
new file mode 100644
index 0000000000..b27413631a
--- /dev/null
+++ b/libraries/html5lib/README
@@ -0,0 +1,10 @@
+html5lib (HTML parser based on the HTML5 specification)
+
+HTML parser designed to follow the HTML5 specification. The parser is
+designed to handle all flavours of HTML and parses invalid documents
+using well-defined error handling rules compatible with the behaviour of
+major desktop web browsers.
+
+Output is to a tree structure; the current release supports output
+to DOM, ElementTree and lxml tree formats as well as a simple
+custom format.
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
new file mode 100644
index 0000000000..0baa02adae
--- /dev/null
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# Slackware build script for html5lib
+# Written by Šime Ramov <s@ramov.com>
+
+PRGNAM=html5lib
+VERSION=${VERSION:-0.90}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/html5lib/html5lib.info b/libraries/html5lib/html5lib.info
new file mode 100644
index 0000000000..4c6082ff5c
--- /dev/null
+++ b/libraries/html5lib/html5lib.info
@@ -0,0 +1,10 @@
+PRGNAM="html5lib"
+VERSION="0.90"
+HOMEPAGE="http://code.google.com/p/html5lib/"
+DOWNLOAD="http://html5lib.googlecode.com/files/html5lib-0.90.zip"
+MD5SUM="691e6b9ebe15b333a28280974b2ce432"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Šime Ramov"
+EMAIL="s@ramov.com"
+APPROVED="rworkman"
diff --git a/libraries/html5lib/slack-desc b/libraries/html5lib/slack-desc
new file mode 100644
index 0000000000..df8c6ce9f5
--- /dev/null
+++ b/libraries/html5lib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+html5lib: html5lib (HTML parser based on the HTML5 specification)
+html5lib:
+html5lib: HTML parser designed to follow the HTML5 specification. The parser
+html5lib: is designed to handle all flavours of HTML and parses invalid
+html5lib: documents using well-defined error handling rules compatible with
+html5lib: the behaviour of major desktop web browsers.
+html5lib:
+html5lib: Output is to a tree structure; the current release supports output
+html5lib: to DOM, ElementTree and lxml tree formats as well as a simple
+html5lib: custom format.
+html5lib: