summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author crocket2010-06-17 16:58:33 +0200
committer Robby Workman2010-06-17 21:45:57 +0200
commitfc25dd0879f742e0f9cdba374af0066ec4511eee (patch)
treee5bd4855a18300ed28b8f7fa6763f48b6f6ae740
parente40126f657c45b8c1ed49ec57ef431aed7b77109 (diff)
downloadslackbuilds-fc25dd0879f742e0f9cdba374af0066ec4511eee.tar.gz
network/smuxi: Added (an IRC client written C#)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--network/smuxi/README6
-rw-r--r--network/smuxi/doinst.sh4
-rw-r--r--network/smuxi/slack-desc19
-rw-r--r--network/smuxi/smuxi.SlackBuild93
-rw-r--r--network/smuxi/smuxi.info10
-rw-r--r--network/smuxi/xbuild_on_mono2_6.patch13
6 files changed, 145 insertions, 0 deletions
diff --git a/network/smuxi/README b/network/smuxi/README
new file mode 100644
index 0000000000..3bb56a1039
--- /dev/null
+++ b/network/smuxi/README
@@ -0,0 +1,6 @@
+Smuxi (user-friendly and cross-platform IRC for GNOME/GTK#)
+
+Smuxi is an irssi-inspired, flexible, user-friendly and cross-platform
+IRC client for sophisticated users, targeting the GNOME desktop.
+
+This requires log4net, smartirc4net, nini, and gtk-sharp.
diff --git a/network/smuxi/doinst.sh b/network/smuxi/doinst.sh
new file mode 100644
index 0000000000..99fe936e34
--- /dev/null
+++ b/network/smuxi/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q /usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/network/smuxi/slack-desc b/network/smuxi/slack-desc
new file mode 100644
index 0000000000..14ed50440d
--- /dev/null
+++ b/network/smuxi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+smuxi: Smuxi (user-friendly and cross-platform IRC for GNOME/GTK#)
+smuxi:
+smuxi: Smuxi is an irssi-inspired, flexible, user-friendly and
+smuxi: cross-platform IRC client for sophisticated users, targeting the
+smuxi: GNOME desktop.
+smuxi:
+smuxi: The website for smuxi is http://www.smuxi.org
+smuxi:
+smuxi:
+smuxi:
+smuxi:
diff --git a/network/smuxi/smuxi.SlackBuild b/network/smuxi/smuxi.SlackBuild
new file mode 100644
index 0000000000..3f94f14026
--- /dev/null
+++ b/network/smuxi/smuxi.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for smuxi
+
+# Written by crocket (crockabiscuit@yahoo.com)
+
+PRGNAM=smuxi
+VERSION=${VERSION:-0.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p1 < $CWD/xbuild_on_mono2_6.patch
+autoreconf
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Create the png image from svg since KDE menus don't support SVG well.
+PIXMAP=$PKG/usr/share/pixmaps
+convert -transparent white $PKG/usr/share/pixmaps/smuxi-frontend-gnome.svg \
+ $PKG/usr/share/pixmaps/smuxi-frontend-gnome.png
+# Adjust the Desktop setting
+sed -i "s|.svg|.png|g" \
+ $PKG/usr/share/applications/smuxi-frontend-gnome.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ BUGS CREDITS FEATURES LICENSE PROFILING README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/smuxi/smuxi.info b/network/smuxi/smuxi.info
new file mode 100644
index 0000000000..c439d4d935
--- /dev/null
+++ b/network/smuxi/smuxi.info
@@ -0,0 +1,10 @@
+PRGNAM="smuxi"
+VERSION="0.7.1"
+HOMEPAGE="http://www.smuxi.org/"
+DOWNLOAD="http://www.smuxi.org/jaws/data/files/smuxi-0.7.1.tar.gz"
+MD5SUM="02f7b0789a18f09157c5207c19525844"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="crocket"
+EMAIL="crockabiscuit@yahoo.com"
+APPROVED="rworkman"
diff --git a/network/smuxi/xbuild_on_mono2_6.patch b/network/smuxi/xbuild_on_mono2_6.patch
new file mode 100644
index 0000000000..d72ac9c5ab
--- /dev/null
+++ b/network/smuxi/xbuild_on_mono2_6.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/Twitterizer.Framework/Makefile.am b/lib/Twitterizer.Framework/Makefile.am
+index 8de6969..1116489 100644
+--- a/lib/Twitterizer.Framework/Makefile.am
++++ b/lib/Twitterizer.Framework/Makefile.am
+@@ -6,7 +6,7 @@ ASSEMBLY_NAME = Twitterizer.Framework.dll
+ ASSEMBLY_TARGET = $(OUTPUT_DIR)/$(ASSEMBLY_NAME)
+ KEY_FILE = $(srcdir)/Twitterizer.Framework.snk
+ BUILD_FILE = $(srcdir)/Twitterizer.Framework.vs2008.csproj
+-XBUILD_FLAGS = /p:Configuration=Debug /p:NoWarn=CS0168 /p:OutputPath=$(abspath $(OUTPUT_DIR)) /p:BaseIntermediateOutputPath=$(abspath $(OBJECT_DIR))/
++XBUILD_FLAGS = /p:Configuration=Debug /p:NoWarn=0168 /p:OutputPath=$(abspath $(OUTPUT_DIR)) /p:BaseIntermediateOutputPath=$(abspath $(OBJECT_DIR))/
+
+ # magic automake variables
+ if ENABLE_ENGINE_TWITTER