summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Luis Henrique2010-06-17 13:43:40 +0200
committer Robby Workman2010-06-17 21:42:41 +0200
commit266f6ae785152bcecc491c7e5e369860d7eddddf (patch)
tree5add19f7c887355c15ed77dbf5f1620ffb17f23a
parente637744f18d9127646c27f77d19e7f628a6d9652 (diff)
downloadslackbuilds-266f6ae785152bcecc491c7e5e369860d7eddddf.tar.gz
graphics/fbida: Added (image viewer)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--graphics/fbida/README7
-rw-r--r--graphics/fbida/fbida.SlackBuild100
-rw-r--r--graphics/fbida/fbida.info10
-rw-r--r--graphics/fbida/read-png.c.patch11
-rw-r--r--graphics/fbida/slack-desc19
5 files changed, 147 insertions, 0 deletions
diff --git a/graphics/fbida/README b/graphics/fbida/README
new file mode 100644
index 0000000000..0d4be6d168
--- /dev/null
+++ b/graphics/fbida/README
@@ -0,0 +1,7 @@
+fbida (image viewer)
+
+The fbida project contains a few applications for viewing and
+editing images, with the main focus being photos.
+
+ida (a Motif based image viewer for X11) is not included on purpose,
+as it needs Open Motif.
diff --git a/graphics/fbida/fbida.SlackBuild b/graphics/fbida/fbida.SlackBuild
new file mode 100644
index 0000000000..3650067367
--- /dev/null
+++ b/graphics/fbida/fbida.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+
+# Slackware build script for fbida
+# Modified by Luis Henrique <lmello.009@gmail.com>
+
+# (C) 2007 Michael Wagner <lapinours@web.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fbida
+VERSION=2.07
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING Changes INSTALL README TODO"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# "Patch" GNUmakefile and mk/Autoconf.mk
+for i in GNUmakefile mk/Autoconf.mk; do
+ sed -i s,/X11R6,, $i || exit 1
+done
+
+# Fix rd/read-png.c (obsolete libpng declaration)
+patch -p0 < $CWD/read-png.c.patch
+
+CFLAGS="$SLKCFLAGS" make HAVE_MOTIF=no
+prefix=/usr make install DESTDIR=$PKG HAVE_MOTIF=no
+
+mv $PKG/usr/share/man $PKG/usr && rm -rf $PKG/usr/share
+gzip -9 $PKG/usr/man/man1/* 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/fbida/fbida.info b/graphics/fbida/fbida.info
new file mode 100644
index 0000000000..fa313d26ca
--- /dev/null
+++ b/graphics/fbida/fbida.info
@@ -0,0 +1,10 @@
+PRGNAM="fbida"
+VERSION="2.07"
+HOMEPAGE="http://linux.bytesex.org/fbida/"
+DOWNLOAD="http://dl.bytesex.org/releases/fbida/fbida-2.07.tar.gz"
+MD5SUM="3e05910fb7c1d9b2bd3e272d96db069c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Luis Henrique"
+EMAIL="lmello.009@gmail.com"
+APPROVED="rworkman"
diff --git a/graphics/fbida/read-png.c.patch b/graphics/fbida/read-png.c.patch
new file mode 100644
index 0000000000..5e4bfb6ffe
--- /dev/null
+++ b/graphics/fbida/read-png.c.patch
@@ -0,0 +1,11 @@
+--- rd/read-png.c.orig 2010-05-27 17:30:21.883639928 -0300
++++ rd/read-png.c 2010-05-27 17:33:27.385641448 -0300
+@@ -69,7 +69,7 @@
+ if (h->color_type == PNG_COLOR_TYPE_PALETTE)
+ png_set_palette_to_rgb(h->png);
+ if (h->color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+- png_set_gray_1_2_4_to_8(h->png);
++ png_set_expand_gray_1_2_4_to_8(h->png);
+
+ if (png_get_bKGD(h->png, h->info, &file_bg)) {
+ png_set_background(h->png,file_bg,PNG_BACKGROUND_GAMMA_FILE,1,1.0);
diff --git a/graphics/fbida/slack-desc b/graphics/fbida/slack-desc
new file mode 100644
index 0000000000..cce9250d47
--- /dev/null
+++ b/graphics/fbida/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fbida: fbida (image viewer)
+fbida:
+fbida: The fbida project contains a few applications for viewing and
+fbida: editing images, with the main focus being photos.
+fbida:
+fbida: Homepage: http://linux.bytesex.org/fbida/
+fbida:
+fbida:
+fbida:
+fbida:
+fbida: