summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Grissiom2010-05-11 06:06:36 +0200
committer Robby Workman2010-05-17 05:24:20 +0200
commit27c8ec834168fe35cd49d854dd11eb1915799b1d (patch)
tree7ca365eeadbdf883c41c2b83ba2b8d11e9072256
parent6ffe33dc12d04d6187bc1a2e1c5d9ee06ace7ed4 (diff)
downloadslackbuilds-27c8ec834168fe35cd49d854dd11eb1915799b1d.tar.gz
system/pyserial: Added (python module for serial port access)
-rw-r--r--system/pyserial/README1
-rwxr-xr-xsystem/pyserial/pyserial.SlackBuild45
-rw-r--r--system/pyserial/pyserial.info10
-rw-r--r--system/pyserial/slack-desc19
4 files changed, 75 insertions, 0 deletions
diff --git a/system/pyserial/README b/system/pyserial/README
new file mode 100644
index 0000000000..bc6ddf9364
--- /dev/null
+++ b/system/pyserial/README
@@ -0,0 +1 @@
+pyserial is a python module that encapsulates access to a serial port.
diff --git a/system/pyserial/pyserial.SlackBuild b/system/pyserial/pyserial.SlackBuild
new file mode 100755
index 0000000000..8fbd9ffe8b
--- /dev/null
+++ b/system/pyserial/pyserial.SlackBuild
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+# Slackware build script for pyserial
+
+# Written by Grissiom <chaos.proton@gmail.com>
+
+PRGNAM=pyserial
+VERSION=${VERSION:-2.4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=/$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt LICENSE.txt README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/pyserial/pyserial.info b/system/pyserial/pyserial.info
new file mode 100644
index 0000000000..44eba17ddb
--- /dev/null
+++ b/system/pyserial/pyserial.info
@@ -0,0 +1,10 @@
+PRGNAM="pyserial"
+VERSION="2.4"
+HOMEPAGE="http://pyserial.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyserial/pyserial-2.4.tar.gz"
+MD5SUM="eec19df59fd75ba5a136992897f8e468"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="rworkman"
diff --git a/system/pyserial/slack-desc b/system/pyserial/slack-desc
new file mode 100644
index 0000000000..95859372c1
--- /dev/null
+++ b/system/pyserial/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyserial: pyserial (python module for accessing the serial port)
+pyserial:
+pyserial: This module encapsulates the access for the serial port. It provides
+pyserial: backends for Python running on Windows, Linux, BSD (possibly any POSIX
+pyserial: compliant system), Jython and IronPython (.NET and Mono).
+pyserial:
+pyserial: Homepage: http://pyserial.sourceforge.net
+pyserial:
+pyserial:
+pyserial:
+pyserial: