summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2010-03-22 08:38:35 +0100
committer Erik Hanson2010-05-13 14:27:17 +0200
commit9d295ae5e207d4a4acea7bbeafdba8353c793417 (patch)
treeb7229f9f0fe758f93e6a885f633e62cede881780
parent63138397d0d5327e8a7885e792c000fd099f8b53 (diff)
downloadslackbuilds-9d295ae5e207d4a4acea7bbeafdba8353c793417.tar.gz
libraries/simplejson: Updated for version 2.1.0.
-rw-r--r--libraries/simplejson/README10
-rw-r--r--libraries/simplejson/simplejson.SlackBuild19
-rw-r--r--libraries/simplejson/simplejson.info8
3 files changed, 14 insertions, 23 deletions
diff --git a/libraries/simplejson/README b/libraries/simplejson/README
index b8737dfcde..76e0696fda 100644
--- a/libraries/simplejson/README
+++ b/libraries/simplejson/README
@@ -1,5 +1,7 @@
-simplejson is a simple, fast, complete, correct and extensible JSON
-encoder and decoder for Python. It is pure Python code but includes
-an optional C extension for a serious speed boost.
+Simple, fast, extensible JSON encoder/decoder for Python.
+simplejson is a simple, fast, complete, correct and extensible
+JSON <http://json.org> encoder and decoder for Python 2.4+.
+It is pure Python code, but includes an optional C extension
+for a serious speed boost.
-This requires pysetuptools.
+Requires pysetuptools.
diff --git a/libraries/simplejson/simplejson.SlackBuild b/libraries/simplejson/simplejson.SlackBuild
index b1898373a0..f21b4324d7 100644
--- a/libraries/simplejson/simplejson.SlackBuild
+++ b/libraries/simplejson/simplejson.SlackBuild
@@ -3,7 +3,7 @@
# Written by Larry Hajali <larryhaja[at]gail[dot]com>
PRGNAM=simplejson
-VERSION=${VERSION:-2.0.9}
+VERSION=${VERSION:-2.1.0}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -13,17 +13,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
set -e
rm -rf $PKG
@@ -39,8 +28,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Lets use the system setup tools rather then ez_setup.
-patch -p1 < $CWD/setup.py.patch
+# Lets use the system setuptools rather then ez_setup.
+rm -f ez_setup.py
python setup.py install --root=$PKG
@@ -53,7 +42,7 @@ python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
cp -a LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cp -aR docs/* $PKG/usr/doc/$PRGNAM-$VERSION/html/
+cp -ar docs/* $PKG/usr/doc/$PRGNAM-$VERSION/html/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/simplejson/simplejson.info b/libraries/simplejson/simplejson.info
index dc559dea62..fbca7b1f54 100644
--- a/libraries/simplejson/simplejson.info
+++ b/libraries/simplejson/simplejson.info
@@ -1,10 +1,10 @@
PRGNAM="simplejson"
-VERSION="2.0.9"
+VERSION="2.1.0"
HOMEPAGE="http://undefined.org/python/#simplejson"
-DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-2.0.9.tar.gz"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-2.1.0.tar.gz"
+MD5SUM="3ea565fd1216462162c6929b264cf365"
DOWNLOAD_x86_64=""
-MD5SUM="af5e67a39ca3408563411d357e6d5e47"
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="dsomero"
+APPROVED="Erik Hanson"