summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2010-05-13 01:00:32 +0200
committer Erik Hanson2010-05-13 01:00:32 +0200
commit441f146c49a0a855825165ed3a4761eb132907bf (patch)
tree3e8fa7ca7a7e5f310b1e35b15cc945935bb339b9
parent8edae9b6135bc1e4e25bbcedbdead1a296d08b55 (diff)
downloadslackbuilds-441f146c49a0a855825165ed3a4761eb132907bf.tar.gz
office/grisbi: Added to 13.0 repository
-rw-r--r--office/grisbi/README7
-rw-r--r--office/grisbi/doinst.sh7
-rw-r--r--office/grisbi/grisbi.SlackBuild91
-rw-r--r--office/grisbi/grisbi.desktop10
-rw-r--r--office/grisbi/grisbi.info10
-rw-r--r--office/grisbi/help-menu.patch72
-rw-r--r--office/grisbi/slack-desc19
7 files changed, 216 insertions, 0 deletions
diff --git a/office/grisbi/README b/office/grisbi/README
new file mode 100644
index 0000000000..9a31e5baea
--- /dev/null
+++ b/office/grisbi/README
@@ -0,0 +1,7 @@
+Grisbi is a personnal accounting application running under
+GNU/Linux and Windows, released under the GPL licence. It's
+aim is to provide you with the most simple and intuitive
+software for basic use, and still very powerful if you spend
+a little time on the setup.
+
+Grisbi has an optional dependency for libofx.
diff --git a/office/grisbi/doinst.sh b/office/grisbi/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/office/grisbi/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/office/grisbi/grisbi.SlackBuild b/office/grisbi/grisbi.SlackBuild
new file mode 100644
index 0000000000..1404e0ff49
--- /dev/null
+++ b/office/grisbi/grisbi.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for grisbi
+
+# Written by Larry Hajali
+
+PRGNAM=grisbi
+VERSION=${VERSION:-0.6.0b2}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-1.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix the HELP_PATH so that the help menu looks in /usr/doc/$PRGNAM-$VERSION.
+patch -p1 < $CWD/help-menu.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --with-plugins \
+ --enable-threads=posix \
+ --enable-static=no \
+ --with-balance-estimate \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+# Grisbi comes with a desktop menu item but we're going to overwrite it.
+mkdir -p $PKG/usr/share/applications
+install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ABOUT-NLS AUTHORS COPYING INSTALL NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/grisbi/grisbi.desktop b/office/grisbi/grisbi.desktop
new file mode 100644
index 0000000000..8473625e9c
--- /dev/null
+++ b/office/grisbi/grisbi.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Grisbi
+Comment=A personnal account manager
+Exec=grisbi
+Icon=grisbi/grisbi.png
+Terminal=false
+StartupNotify=false
+Type=Application
+MimeType=application/x-grisbi;
+Categories=Office;
diff --git a/office/grisbi/grisbi.info b/office/grisbi/grisbi.info
new file mode 100644
index 0000000000..a701e22ee2
--- /dev/null
+++ b/office/grisbi/grisbi.info
@@ -0,0 +1,10 @@
+PRGNAM="grisbi"
+VERSION="0.6.0b2"
+HOMEPAGE="http://www.grisbi.org/"
+DOWNLOAD="http://downloads.sourceforge.net/grisbi/grisbi-0.6.0b2-1.tar.bz2"
+MD5SUM="f0c05d42c90a33b1b43840dbe32a507b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="Erik Hanson"
diff --git a/office/grisbi/help-menu.patch b/office/grisbi/help-menu.patch
new file mode 100644
index 0000000000..08a8d3045f
--- /dev/null
+++ b/office/grisbi/help-menu.patch
@@ -0,0 +1,72 @@
+diff -Naur grisbi-0.6.0b1.orig/help/C/Makefile.in grisbi-0.6.0b1/help/C/Makefile.in
+--- grisbi-0.6.0b1.orig/help/C/Makefile.in 2009-09-19 09:41:04.000000000 +0000
++++ grisbi-0.6.0b1/help/C/Makefile.in 2009-09-20 16:20:32.000000000 +0000
+@@ -230,7 +230,7 @@
+ quickstart.html \
+ translation.html
+
+-grisbi_helpdir = $(datadir)/doc/grisbi/C
++grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/C
+ grisbi_help_DATA = \
+ topic.dat \
+ contents_motif.gif \
+diff -Naur grisbi-0.6.0b1.orig/help/de/Makefile.in grisbi-0.6.0b1/help/de/Makefile.in
+--- grisbi-0.6.0b1.orig/help/de/Makefile.in 2009-09-19 09:41:04.000000000 +0000
++++ grisbi-0.6.0b1/help/de/Makefile.in 2009-09-20 16:21:10.000000000 +0000
+@@ -230,7 +230,7 @@
+ quickstart.html \
+ translation.html
+
+-grisbi_helpdir = $(datadir)/doc/grisbi/de
++grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/de
+ grisbi_help_DATA = \
+ topic.dat \
+ contents_motif.gif \
+diff -Naur grisbi-0.6.0b1.orig/help/en/Makefile.in grisbi-0.6.0b1/help/en/Makefile.in
+--- grisbi-0.6.0b1.orig/help/en/Makefile.in 2009-09-19 09:41:04.000000000 +0000
++++ grisbi-0.6.0b1/help/en/Makefile.in 2009-09-20 16:21:47.000000000 +0000
+@@ -230,7 +230,7 @@
+ quickstart.html \
+ translation.html
+
+-grisbi_helpdir = $(datadir)/doc/grisbi/en
++grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/en
+ grisbi_help_DATA = \
+ topic.dat \
+ contents_motif.gif \
+diff -Naur grisbi-0.6.0b1.orig/help/fr/Makefile.in grisbi-0.6.0b1/help/fr/Makefile.in
+--- grisbi-0.6.0b1.orig/help/fr/Makefile.in 2009-09-19 09:41:04.000000000 +0000
++++ grisbi-0.6.0b1/help/fr/Makefile.in 2009-09-20 16:22:19.000000000 +0000
+@@ -230,7 +230,7 @@
+ quickstart.html \
+ translation.html
+
+-grisbi_helpdir = $(datadir)/doc/grisbi/fr
++grisbi_helpdir = $(prefix)/doc/@PACKAGE@-@VERSION@/fr
+ grisbi_help_DATA = \
+ topic.dat \
+ contents_motif.gif \
+diff -Naur grisbi-0.6.0b1.orig/src/Makefile.am grisbi-0.6.0b1/src/Makefile.am
+--- grisbi-0.6.0b1.orig/src/Makefile.am 2009-07-14 19:33:32.000000000 +0000
++++ grisbi-0.6.0b1/src/Makefile.am 2009-09-20 16:07:36.000000000 +0000
+@@ -1,7 +1,7 @@
+ # Process this file with automake to produce Makefile.in
+
+ localedir = $(datadir)/locale
+-INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
++INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(prefix)/doc/@PACKAGE@-@VERSION@\"" -Wall
+ bin_PROGRAMS = grisbi
+
+ # TODO: This manual setting of -Wl is a hack, I cannot get it from
+diff -Naur grisbi-0.6.0b1.orig/src/Makefile.in grisbi-0.6.0b1/src/Makefile.in
+--- grisbi-0.6.0b1.orig/src/Makefile.in 2009-09-19 09:41:05.000000000 +0000
++++ grisbi-0.6.0b1/src/Makefile.in 2009-09-20 16:06:26.000000000 +0000
+@@ -379,7 +379,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
++INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(prefix)/lib/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(prefix)/doc/@PACKAGE@-@VERSION@\"" -Wall
+
+ # TODO: This manual setting of -Wl is a hack, I cannot get it from
+ # configure right now because of no doc.
diff --git a/office/grisbi/slack-desc b/office/grisbi/slack-desc
new file mode 100644
index 0000000000..51d03cc49e
--- /dev/null
+++ b/office/grisbi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+grisbi: grisbi (Financial accounting software)
+grisbi:
+grisbi: Grisbi is a personnal accounting application running under GNU/Linux
+grisbi: and Windows. Grisbi can manage multiple accounts, currencies and
+grisbi: users. It manages third party, expenditure and receipt categories, as
+grisbi: well as budgetary lines, financial years, and other informations that
+grisbi: makes it quite adapted for associations (except those that require
+grisbi: double entry accounting).
+grisbi:
+grisbi: Homepage: http://www.grisbi.org/
+grisbi: