summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Johannes Schoepfer2019-12-01 02:35:11 +0100
committer Willy Sudiarto Raharjo2019-12-01 02:35:11 +0100
commit69a4bb0fa8180976590677e4e5d3f097a36dcd27 (patch)
tree553fba9f98baf189949cbdfac63d947d4c9c63c7
parent8d6c07800b07c044e096e046b8f3eb4532738317 (diff)
downloadslackbuilds-69a4bb0fa8180976590677e4e5d3f097a36dcd27.tar.gz
audio/DPF-Plugins: Added (Collection of DPF-based plugins).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/DPF-Plugins/DPF-Plugins.SlackBuild108
-rw-r--r--audio/DPF-Plugins/DPF-Plugins.info10
-rw-r--r--audio/DPF-Plugins/README18
-rw-r--r--audio/DPF-Plugins/slack-desc19
4 files changed, 155 insertions, 0 deletions
diff --git a/audio/DPF-Plugins/DPF-Plugins.SlackBuild b/audio/DPF-Plugins/DPF-Plugins.SlackBuild
new file mode 100644
index 0000000000..0bbfcc68c4
--- /dev/null
+++ b/audio/DPF-Plugins/DPF-Plugins.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for DPF-Plugins
+
+# Copyright 2019 Johannes Schoepfer, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=DPF-Plugins
+VERSION=${VERSION:-1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i \
+ -e "s/-std=gnu99/-std=gnu11/" \
+ -e "s/-std=gnu++0x/-std=gnu++11/" \
+ dpf/Makefile.base.mk
+
+# disable dssi if not installed
+pkg-config dssi || sed -i "/dssi/d" Makefile
+
+if [ "${LV2_ONLY:-no}" = "yes" ]; then
+ sed -i "/dssi/d" Makefile
+ sed -i "/vst/d" Makefile
+ sed -i "/ladspa/d" Makefile
+ sed -i "s/^HAVE_JACK.*/HAVE_JACK = false/g" dpf/Makefile.base.mk
+fi
+
+sed -i "s/lib\//lib$LIBDIRSUFFIX\//g" Makefile
+
+make NOOPT=true
+make DESTDIR=$PKG PREFIX=/usr install
+
+# only needed if compiled with jack or dssi
+rmdir --ignore-fail-on-non-empty $PKG/usr/bin
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/DPF-Plugins/DPF-Plugins.info b/audio/DPF-Plugins/DPF-Plugins.info
new file mode 100644
index 0000000000..e99848c570
--- /dev/null
+++ b/audio/DPF-Plugins/DPF-Plugins.info
@@ -0,0 +1,10 @@
+PRGNAM="DPF-Plugins"
+VERSION="1.3"
+HOMEPAGE="https://distrho.sourceforge.io/plugins"
+DOWNLOAD="https://github.com/DISTRHO/DPF-Plugins/archive/v1.3/DPF-Plugins-1.3.tar.gz"
+MD5SUM="d58518b21f7b24f5fd860c42e1244021"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Johannes Schoepfer"
+EMAIL="slackbuilds@schoepfer.info"
diff --git a/audio/DPF-Plugins/README b/audio/DPF-Plugins/README
new file mode 100644
index 0000000000..3f1131660b
--- /dev/null
+++ b/audio/DPF-Plugins/README
@@ -0,0 +1,18 @@
+Collection of DPF-based plugins from DISTRHO.
+
+These come in LADSPA, DSSI, LV2 and VST2 formats, namely
+ glBars
+ Kars
+ Max-Gen examples (MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift)
+ Mini-Series (3BandEQ. 3BandSplitter, PingPongPan)
+ ndc-Plugs (Amplitude Imposer, Cycle Shifter, Soul Force)
+ MVerb
+ Nekobi
+ ProM
+
+LV2_ONLY=yes may be set to ommit building ladspa, dssi and vst plugins.
+
+Optional dependencies: jack,dssi,projectM
+
+This build conflicts with "distrho-mini-series" from SBo, as that build
+is a subset of DPF-Plugins.
diff --git a/audio/DPF-Plugins/slack-desc b/audio/DPF-Plugins/slack-desc
new file mode 100644
index 0000000000..3bf7f2e729
--- /dev/null
+++ b/audio/DPF-Plugins/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DPF-Plugins: DPF-Plugins (Collection of DPF-based plugins from DISTRHO)
+DPF-Plugins:
+DPF-Plugins: These come in LADSPA, DSSI, LV2 and VST2 formats, namely
+DPF-Plugins: glBars
+DPF-Plugins: Kars
+DPF-Plugins: Max-Gen examples (MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift)
+DPF-Plugins: Mini-Series (3BandEQ. 3BandSplitter, PingPongPan)
+DPF-Plugins: ndc-Plugs (Amplitude Imposer, Cycle Shifter, Soul Force)
+DPF-Plugins: MVerb
+DPF-Plugins: Nekobi
+DPF-Plugins: ProM