summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/broadcom-sta/broadcom-sta.SlackBuild5
-rw-r--r--network/broadcom-sta/wl_linux.c-semaphore.patch12
-rw-r--r--network/cherokee/ChangeLog.txt3
-rw-r--r--network/cherokee/README3
-rw-r--r--network/cherokee/cherokee.SlackBuild33
-rw-r--r--network/cherokee/cherokee.info8
-rw-r--r--network/darkstat/darkstat.SlackBuild6
-rw-r--r--network/ettercap-NG/ettercap-NG.SlackBuild17
-rw-r--r--network/ettercap-NG/ettercap-NG.info2
-rw-r--r--network/ettercap-NG/patches/ettercap-NG-0.7.3-resolv.patch38
-rw-r--r--network/ettercap-NG/patches/ettercap-NG-0.7.3-sedbug.patch11
-rw-r--r--network/gtknetcat/gtknetcat.SlackBuild5
-rw-r--r--network/hping3/hping3.SlackBuild6
-rw-r--r--network/hylafax/hylafax-gcc45.patch25
-rw-r--r--network/hylafax/hylafax.SlackBuild6
-rw-r--r--network/hylafax/hylafax.info8
-rw-r--r--network/lighttpd/08-ssl-retval-fix.patch12
-rw-r--r--network/lighttpd/lighttpd.SlackBuild4
-rw-r--r--network/lighttpd/lighttpd.info8
-rw-r--r--network/perl-Net-SMTP-SSL/README5
-rw-r--r--network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.SlackBuild82
-rw-r--r--network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.info10
-rw-r--r--network/perl-Net-SMTP-SSL/slack-desc19
-rw-r--r--network/python-twisted/python-twisted.SlackBuild8
-rw-r--r--network/python-twisted/python-twisted.info6
-rw-r--r--network/rekonq/rekonq-CVE-2010-2536-fix.patch16
-rw-r--r--network/rekonq/rekonq.SlackBuild5
-rw-r--r--network/rekonq/rekonq.info8
-rw-r--r--network/rtorrent/rtorrent-0.8.7-canvas-patch-fix-for-ncurses-5-8.patch10
-rw-r--r--network/rtorrent/rtorrent.SlackBuild4
-rw-r--r--network/rtorrent/rtorrent.info2
31 files changed, 301 insertions, 86 deletions
diff --git a/network/broadcom-sta/broadcom-sta.SlackBuild b/network/broadcom-sta/broadcom-sta.SlackBuild
index f9fc7e57d9..c6e96516b5 100644
--- a/network/broadcom-sta/broadcom-sta.SlackBuild
+++ b/network/broadcom-sta/broadcom-sta.SlackBuild
@@ -5,7 +5,7 @@
PRGNAM=broadcom-sta
VERSION=5.100.82.38
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
KERNEL=${KERNEL:-$(uname -r)}
@@ -42,6 +42,9 @@ mkdir -p $TMP $WORKDIR $PKG $OUTPUT
cd $WORKDIR
tar xvf $CWD/hybrid-portsrc_${MY_ARCH}-v$(printf $VERSION|tr . _).tar.gz
+# Fix API change in newer kernels
+patch -p1 < $CWD/wl_linux.c-semaphore.patch
+
# Build the module
make -C /lib/modules/$KERNEL/build M=$WORKDIR clean
make -C /lib/modules/$KERNEL/build M=$WORKDIR
diff --git a/network/broadcom-sta/wl_linux.c-semaphore.patch b/network/broadcom-sta/wl_linux.c-semaphore.patch
new file mode 100644
index 0000000000..8cdd7306f4
--- /dev/null
+++ b/network/broadcom-sta/wl_linux.c-semaphore.patch
@@ -0,0 +1,12 @@
+diff -Nur orig//src/wl/sys/wl_linux.c fixed/src/wl/sys/wl_linux.c
+--- orig//src/wl/sys/wl_linux.c 2010-12-14 19:58:07.000000000 -0600
++++ fixed/src/wl/sys/wl_linux.c 2011-03-09 12:32:47.236260917 -0600
+@@ -482,7 +482,7 @@
+ #ifdef WL_ALL_PASSIVE
+ spin_lock_init(&wl->txq_lock);
+ #endif
+- init_MUTEX(&wl->sem);
++ sema_init(&wl->sem,1);
+ }
+
+ if (!(wl->wlc = wlc_attach((void *) wl, vendor, device, unit, wl->piomode,
diff --git a/network/cherokee/ChangeLog.txt b/network/cherokee/ChangeLog.txt
index 94c24d33a9..b6d60f2ec1 100644
--- a/network/cherokee/ChangeLog.txt
+++ b/network/cherokee/ChangeLog.txt
@@ -1,3 +1,6 @@
+Mon 13 Dec 2010 - ponce (matteo.bernardini@gmail.com)
+- SlackBuild script for Cherokee 1.0.13
+
Mon 07 Sep 2009 - Pablo Hernan Saro (pablosaro@gmail.com)
- SlackBuild script for Cherokee 0.99.24
- Cherokee rc script updated
diff --git a/network/cherokee/README b/network/cherokee/README
index c0424311d2..1ab127e40a 100644
--- a/network/cherokee/README
+++ b/network/cherokee/README
@@ -26,6 +26,9 @@ Notes about using this SlackBuild
WWWROOT=/var/www ./cherokee.SlackBuild
+ in a similar way you can pass the variables WWWUSER (defining
+ the default user cherokee will run as) and WWWGROUP (the default
+ group): the value of those two variables defaults to "apache".
2) If you want to enable IPv6 support, pass IPV6=yes to the script.
3) If you want to disable the Cherokee-admin installation, pass
ADMIN=no to the script.
diff --git a/network/cherokee/cherokee.SlackBuild b/network/cherokee/cherokee.SlackBuild
index caff2d9f11..539dfe1866 100644
--- a/network/cherokee/cherokee.SlackBuild
+++ b/network/cherokee/cherokee.SlackBuild
@@ -3,13 +3,23 @@
# Slackware build script for cherokee
# Written by Pablo Hernan Saro (pablosaro@gmail.com)
+# modified to use user apache by default and updated by ponce <matteo.bernardini@gmail.com>
PRGNAM=cherokee
-VERSION=${VERSION:-0.99.24}
-ARCH=${ARCH:-i686}
+VERSION=${VERSION:-1.0.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -24,11 +34,20 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
# Set the WWW root directory
WWWROOT=${WWWROOT:-/var/www}
+# Set the WWW user - use apache by default
+WWWUSER=${WWWUSER:-apache}
+
+# Set the WWW group - use apache by default
+WWWGROUP=${WWWGROUP:-apache}
+
# Enable/Disable IPv6 support
IPV6=${IPV6:-no}
@@ -67,9 +86,12 @@ CXXFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux \
--with-wwwroot=$WWWROOT \
+ --with-wwwuser=$WWWUSER \
+ --with-wwwgroup=$WWWGROUP \
--with-mysql=$MYSQL \
--enable-ipv6=$IPV6 \
--enable-admin=$ADMIN \
+ --disable-pam \
--enable-trace=$TRACE
make
@@ -78,10 +100,8 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
@@ -99,4 +119,3 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/network/cherokee/cherokee.info b/network/cherokee/cherokee.info
index 427929e9cc..390a05a51a 100644
--- a/network/cherokee/cherokee.info
+++ b/network/cherokee/cherokee.info
@@ -1,10 +1,10 @@
PRGNAM="cherokee"
-VERSION="0.99.24"
+VERSION="1.0.13"
HOMEPAGE="http://www.cherokee-project.com"
-DOWNLOAD="http://www.cherokee-project.com/download/0.99/0.99.24/cherokee-0.99.24.tar.gz"
-MD5SUM="5afed8bdd6020dc5bf0ba9ec83b947f1"
+DOWNLOAD="http://www.cherokee-project.com/download/1.0/1.0.13/cherokee-1.0.13.tar.gz"
+MD5SUM="aafaaab9f2528f1ef7f8461d608ce775"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Pablo Hernan Saro"
EMAIL="pablosaro@gmail.com"
-APPROVED="dsomero"
+APPROVED=""
diff --git a/network/darkstat/darkstat.SlackBuild b/network/darkstat/darkstat.SlackBuild
index 3b585e000a..62508a77ef 100644
--- a/network/darkstat/darkstat.SlackBuild
+++ b/network/darkstat/darkstat.SlackBuild
@@ -70,10 +70,8 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/network/ettercap-NG/ettercap-NG.SlackBuild b/network/ettercap-NG/ettercap-NG.SlackBuild
index dbdead289e..7a9dafba75 100644
--- a/network/ettercap-NG/ettercap-NG.SlackBuild
+++ b/network/ettercap-NG/ettercap-NG.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# slightly fixed to build on -current by ponce <matteo.bernardini@gmail.com>
+
PRGNAM=ettercap-NG
VERSION=${VERSION:-0.7.3}
BUILD=${BUILD:-1}
@@ -67,6 +69,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r,a-s .
+# https://bugzilla.redhat.com/show_bug.cgi?id=646162
+# fix passive DNS support
+patch -p0 < $CWD/patches/ettercap-NG-0.7.3-resolv.patch
+# fix a bug for sed
+patch -p0 < $CWD/patches/ettercap-NG-0.7.3-sedbug.patch
+autoconf
+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -88,10 +97,10 @@ mv $PKG/etc/etter.conf $PKG/etc/etter.conf.new
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+# move the man pages in the correct place
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CHANGELOG INSTALL LICENSE README* THANKS TODO* doc/* \
diff --git a/network/ettercap-NG/ettercap-NG.info b/network/ettercap-NG/ettercap-NG.info
index 05158eeddb..048b765451 100644
--- a/network/ettercap-NG/ettercap-NG.info
+++ b/network/ettercap-NG/ettercap-NG.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="meckafett"
EMAIL="tom.bradish@gmail.com"
-APPROVED="Michiel"
+APPROVED=""
diff --git a/network/ettercap-NG/patches/ettercap-NG-0.7.3-resolv.patch b/network/ettercap-NG/patches/ettercap-NG-0.7.3-resolv.patch
new file mode 100644
index 0000000000..eb9248cc17
--- /dev/null
+++ b/network/ettercap-NG/patches/ettercap-NG-0.7.3-resolv.patch
@@ -0,0 +1,38 @@
+--- acinclude.m4 2004-09-17 21:38:34.000000000 +0200
++++ acinclude.m4 2010-10-24 16:12:08.873511475 +0200
+@@ -228,8 +228,33 @@ AC_DEFUN([EC_RESOLVE_CHECK],
+ )
+ AM_CONDITIONAL(HAVE_DN_EXPAND, true) ac_ec_dns=yes
+ ],
+- [AM_CONDITIONAL(HAVE_DN_EXPAND, false) ac_ec_dns=no])
+-
++ [
++ AC_SEARCH_LIBS(__dn_expand, resolv c,
++ [
++ AC_MSG_CHECKING(for additional -lresolv needed by dn_expand)
++ AC_TRY_LINK([
++ #include <sys/types.h>
++ #include <netinet/in.h>
++ #include <arpa/nameser.h>
++ #include <resolv.h>
++ ],
++ [
++ int main(int argc, char **argv)
++ {
++ char *q;
++ char p[NS_MAXDNAME];
++
++ dn_expand(q, q, q, p, sizeof(p));
++ }
++ ],
++ [AC_MSG_RESULT(not needed)],
++ [AC_MSG_RESULT(needed)
++ LIBS="$LIBS -lresolv"]
++ )
++ AM_CONDITIONAL(HAVE_DN_EXPAND, true) ac_ec_dns=yes
++ ],
++ [AM_CONDITIONAL(HAVE_DN_EXPAND, false) ac_ec_dns=no])
++ ])
+ ])
+
+ dnl
diff --git a/network/ettercap-NG/patches/ettercap-NG-0.7.3-sedbug.patch b/network/ettercap-NG/patches/ettercap-NG-0.7.3-sedbug.patch
new file mode 100644
index 0000000000..cef1c7c953
--- /dev/null
+++ b/network/ettercap-NG/patches/ettercap-NG-0.7.3-sedbug.patch
@@ -0,0 +1,11 @@
+--- ./aclocal.m4 2010-10-28 16:59:35.718177488 +0200
++++ ./aclocal.m4 2010-10-28 17:00:00.118180979 +0200
+@@ -246,7 +246,7 @@ if test -z "$ltmain"; then
+ exit 1
+ fi
+ gentoo_lt_version="1.5.18"
+-gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
++gentoo_ltmain_version=`grep '^.*VERSION=' $ltmain | sed -e 's|^.*VERSION=||'`
+ if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
+ AC_MSG_RESULT(no)
+ echo
diff --git a/network/gtknetcat/gtknetcat.SlackBuild b/network/gtknetcat/gtknetcat.SlackBuild
index 58acc719b3..0e04c83105 100644
--- a/network/gtknetcat/gtknetcat.SlackBuild
+++ b/network/gtknetcat/gtknetcat.SlackBuild
@@ -74,16 +74,15 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS /usr/share/automake-1.11/COPYING ChangeLog NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION || true
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/hping3/hping3.SlackBuild b/network/hping3/hping3.SlackBuild
index a80574dfec..71c8ec4ec4 100644
--- a/network/hping3/hping3.SlackBuild
+++ b/network/hping3/hping3.SlackBuild
@@ -108,10 +108,8 @@ install -m 0644 docs/hping3.8 $PKG/usr/man/man8/
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
( cd docs ; cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION )
diff --git a/network/hylafax/hylafax-gcc45.patch b/network/hylafax/hylafax-gcc45.patch
new file mode 100644
index 0000000000..c6dea04e1c
--- /dev/null
+++ b/network/hylafax/hylafax-gcc45.patch
@@ -0,0 +1,25 @@
+From: Patrice Fournier <pfournier@ifax.com>
+Date: Tue, 12 Oct 2010 15:35:25 +0000 (-0400)
+Subject: Re-order library files in fchmod() configure check
+X-Git-Url: http://git.hylafax.org/HylaFAX?a=commitdiff_plain;h=b0d873c950a72aa568d2fcfe7dbc8bb6e981c129
+
+Re-order library files in fchmod() configure check
+
+Newer gcc -E stops it's output on the first missing include file so we must
+make sure that a possibly missing file in the list of headers to check is at
+the end.
+---
+
+diff --git a/configure b/configure
+index e49c08f..c6976fd 100755
+--- a/configure
++++ b/configure
+@@ -2882,7 +2882,7 @@ BuildPortDotH()
+ echo '#define HAS_FCHMOD 1'
+ Note "... configure use of fchmod"
+ CheckFuncDecl fchmod 'extern int fchmod(int, mode_t);' \
+- unistd.h libc.h $OSFCNH sys/stat.h
++ unistd.h $OSFCNH sys/stat.h libc.h
+ }
+ CheckFuncDecl mknod 'extern int mknod(const char*, mode_t, dev_t);' \
+ unistd.h sys/stat.h
diff --git a/network/hylafax/hylafax.SlackBuild b/network/hylafax/hylafax.SlackBuild
index d7bfcba0db..b1d4c2f5c3 100644
--- a/network/hylafax/hylafax.SlackBuild
+++ b/network/hylafax/hylafax.SlackBuild
@@ -27,7 +27,7 @@
# General script clean-up and minor improvements
PRGNAM=hylafax
-VERSION=${VERSION:-6.0.4}
+VERSION=${VERSION:-6.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -75,6 +75,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# http://git.hylafax.org/HylaFAX?a=commit;h=b0d873c950a72aa568d2fcfe7dbc8bb6e981c129
+# add a patch for gcc 4.5
+patch -p1 < $CWD/hylafax-gcc45.patch
+
# Copy our source for the correct configuration
sed "s|@LIBDIRSUFFIX@|${LIBDIRSUFFIX}|g" \
< $CWD/config.local.in \
diff --git a/network/hylafax/hylafax.info b/network/hylafax/hylafax.info
index 095d1eb22a..8ed853e363 100644
--- a/network/hylafax/hylafax.info
+++ b/network/hylafax/hylafax.info
@@ -1,10 +1,10 @@
PRGNAM="hylafax"
-VERSION="6.0.4"
+VERSION="6.0.5"
HOMEPAGE="http://www.hylafax.org"
-DOWNLOAD="ftp://ftp.hylafax.org/source/hylafax-6.0.4.tar.gz"
-MD5SUM="6ba4bc3a47c9d2634de1b14f4ab34c80"
+DOWNLOAD="ftp://ftp.hylafax.org/source/hylafax-6.0.5.tar.gz"
+MD5SUM="eb9ac942354ad708e20e4583cec6615f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Somero"
EMAIL="dsomero@hotmail.com"
-APPROVED="Erik Hanson"
+APPROVED=""
diff --git a/network/lighttpd/08-ssl-retval-fix.patch b/network/lighttpd/08-ssl-retval-fix.patch
deleted file mode 100644
index 712f158a23..0000000000
--- a/network/lighttpd/08-ssl-retval-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -purN orig/src/network.c lighttpd-1.4.25/src/network.c
---- orig/src/network.c 2010-01-28 10:43:33.829209750 -0500
-+++ lighttpd-1.4.25/src/network.c 2010-01-28 10:44:22.639208732 -0500
-@@ -525,7 +525,7 @@ int network_init(server *srv) {
-
- if (!s->ssl_use_sslv2) {
- /* disable SSLv2 */
-- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
-+ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
- log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
- ERR_error_string(ERR_get_error(), NULL));
- return -1;
diff --git a/network/lighttpd/lighttpd.SlackBuild b/network/lighttpd/lighttpd.SlackBuild
index 7b796c48a0..f45ac8d1ee 100644
--- a/network/lighttpd/lighttpd.SlackBuild
+++ b/network/lighttpd/lighttpd.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lighttpd
-VERSION=1.4.26
+VERSION=1.4.28
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -88,7 +88,7 @@ chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# apply ssl related bug fix (rm in 1.4.27)
-patch -p1 < ${CWD}/08-ssl-retval-fix.patch
+#patch -p1 < ${CWD}/08-ssl-retval-fix.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/network/lighttpd/lighttpd.info b/network/lighttpd/lighttpd.info
index 1cdfe69b0e..3bdbc10d93 100644
--- a/network/lighttpd/lighttpd.info
+++ b/network/lighttpd/lighttpd.info
@@ -1,10 +1,10 @@
PRGNAM="lighttpd"
-VERSION="1.4.26"
+VERSION="1.4.28"
HOMEPAGE="http://www.lighttpd.net/"
-DOWNLOAD="http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-1.4.26.tar.bz2"
-MD5SUM="a682c8efce47a2f4263a247ba0813c9b"
+DOWNLOAD="http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-1.4.28.tar.bz2"
+MD5SUM="586eb535d31ac299652495b058dd87c4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="paul wisehart"
EMAIL="wise@lupulin.net"
-APPROVED="Erik Hanson"
+APPROVED=""
diff --git a/network/perl-Net-SMTP-SSL/README b/network/perl-Net-SMTP-SSL/README
new file mode 100644
index 0000000000..2d440c0465
--- /dev/null
+++ b/network/perl-Net-SMTP-SSL/README
@@ -0,0 +1,5 @@
+perl-Net-SMTP-SSL (SSL support for Net::SMTP)
+
+perl-Net-SMTP-SSL is a perl module that implements the same API as Net::SMTP, but uses IO::Socket::SSL for its network operations.
+
+it requires perl-IO-Socket-SSL, available at slackbuilds.org.
diff --git a/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.SlackBuild b/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.SlackBuild
new file mode 100644
index 0000000000..1f2278928b
--- /dev/null
+++ b/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for perl-Net-SMTP-SSL
+# Written by ponce <matteo.bernardini@gmail.com>
+
+SRCNAM=Net-SMTP-SSL
+PRGNAM=perl-$SRCNAM
+VERSION=${VERSION:-1.01}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="Changes MANIFEST README"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+perl Makefile.PL \
+ PREFIX=/usr \
+ INSTALLDIRS=vendor \
+ INSTALLVENDORMAN3DIR=/usr/man/man3
+make
+make test
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.info b/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.info
new file mode 100644
index 0000000000..0cf826e59a
--- /dev/null
+++ b/network/perl-Net-SMTP-SSL/perl-Net-SMTP-SSL.info
@@ -0,0 +1,10 @@
+PRGNAM="perl-Net-SMTP-SSL"
+VERSION="1.01"
+HOMEPAGE="http://search.cpan.org/~cwest/Net-SMTP-SSL-1.01/"
+DOWNLOAD="http://search.cpan.org/CPAN/authors/id/C/CW/CWEST/Net-SMTP-SSL-1.01.tar.gz"
+MD5SUM="ba039288ebf7a343feecacd374da8c1a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED=""
diff --git a/network/perl-Net-SMTP-SSL/slack-desc b/network/perl-Net-SMTP-SSL/slack-desc
new file mode 100644
index 0000000000..922cb66e73
--- /dev/null
+++ b/network/perl-Net-SMTP-SSL/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+perl-Net-SMTP-SSL: perl-Net-SMTP-SSL (SSL support for Net::SMTP)
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL: perl-Net-SMTP-SSL is a perl module that implements the same API as
+perl-Net-SMTP-SSL: Net::SMTP, but uses IO::Socket::SSL for its network operations.
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL:
+perl-Net-SMTP-SSL: homepage: http://search.cpan.org/~cwest/Net-SMTP-SSL-1.01/
+perl-Net-SMTP-SSL:
diff --git a/network/python-twisted/python-twisted.SlackBuild b/network/python-twisted/python-twisted.SlackBuild
index 5e70ceeea6..f729a7f589 100644
--- a/network/python-twisted/python-twisted.SlackBuild
+++ b/network/python-twisted/python-twisted.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-twisted
SRCNAM=Twisted
-VERSION=${VERSION:-8.2.0}
+VERSION=${VERSION:-10.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -77,12 +77,6 @@ python setup.py install --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
diff --git a/network/python-twisted/python-twisted.info b/network/python-twisted/python-twisted.info
index 7443cd969b..59c39943a9 100644
--- a/network/python-twisted/python-twisted.info
+++ b/network/python-twisted/python-twisted.info
@@ -1,8 +1,8 @@
PRGNAM="python-twisted"
-VERSION="8.2.0"
+VERSION="10.1.0"
HOMEPAGE="http://twistedmatrix.com/"
-DOWNLOAD="http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-8.2.0.tar.bz2"
-MD5SUM="c85f151999df3ecf04c49a781b4438d2"
+DOWNLOAD="http://tmrc.mit.edu/mirror/twisted/Twisted/10.1/Twisted-10.1.0.tar.bz2"
+MD5SUM="04cca97506e830074cffc1965297da3f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Marco Bonetti"
diff --git a/network/rekonq/rekonq-CVE-2010-2536-fix.patch b/network/rekonq/rekonq-CVE-2010-2536-fix.patch
deleted file mode 100644
index c9dce8e357..0000000000
--- a/network/rekonq/rekonq-CVE-2010-2536-fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/webpage.cpp b/src/webpage.cpp
-index a63940b..ea2add6 100644
---- a/src/webpage.cpp
-+++ b/src/webpage.cpp
-@@ -577,8 +577,8 @@ QString WebPage::errorPage(QNetworkReply *reply)
- return QString("Couldn't open the rekonqinfo.html file");
- }
-
-- QString title = i18n("Error loading: %1", reply->url().toString());
-- QString urlString = reply->url().toString(QUrl::RemoveUserInfo | QUrl::RemoveQuery);
-+ QString title = i18n("There was a problem while loading the page");
-+ QString urlString = reply->url().toString(QUrl::RemoveUserInfo | QUrl::RemoveQuery | QUrl::RemovePath);
-
- QString iconPath = QString("file://") + KIconLoader::global()->iconPath("dialog-warning" , KIconLoader::Small);
- iconPath.replace(QL1S("16"), QL1S("128"));
-
diff --git a/network/rekonq/rekonq.SlackBuild b/network/rekonq/rekonq.SlackBuild
index f5435663b0..5c776f1471 100644
--- a/network/rekonq/rekonq.SlackBuild
+++ b/network/rekonq/rekonq.SlackBuild
@@ -5,7 +5,7 @@
# Written by Branko Grubic <branko.grubic@gmail.com>
PRGNAM=rekonq
-VERSION=${VERSION:-0.5.0}
+VERSION=${VERSION:-0.6.80}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
@@ -51,9 +51,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-## patch to fix Multiple cross-site scripting (XSS) vulnerabilities (CVE-2010-2536)
-patch -p1 <$CWD/rekonq-CVE-2010-2536-fix.patch
-
mkdir -p build
cd build
cmake .. \
diff --git a/network/rekonq/rekonq.info b/network/rekonq/rekonq.info
index 2629986a3d..147a1ba826 100644
--- a/network/rekonq/rekonq.info
+++ b/network/rekonq/rekonq.info
@@ -1,10 +1,10 @@
PRGNAM="rekonq"
-VERSION="0.5.0"
+VERSION="0.6.80"
HOMEPAGE="http://rekonq.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/rekonq/rekonq-0.5.0.tar.bz2"
-MD5SUM="ffa227236b9e4aa6cca6851cc05855fb"
+DOWNLOAD="http://downloads.sourceforge.net/rekonq/rekonq-0.6.80.tar.bz2"
+MD5SUM="e3f39c225a1fdb1894b94156f337c1f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Branko Grubic"
EMAIL="branko.grubic@gmail.com"
-APPROVED="dsomero"
+APPROVED=""
diff --git a/network/rtorrent/rtorrent-0.8.7-canvas-patch-fix-for-ncurses-5-8.patch b/network/rtorrent/rtorrent-0.8.7-canvas-patch-fix-for-ncurses-5-8.patch
new file mode 100644
index 0000000000..b9a09d47bf
--- /dev/null
+++ b/network/rtorrent/rtorrent-0.8.7-canvas-patch-fix-for-ncurses-5-8.patch
@@ -0,0 +1,10 @@
+--- rtorrent-0.8.7/src/display/canvas.h 2011-03-01 14:56:25.000000000 +0800
++++ rtorrent-0.8.7/src/display/canvas.h 2011-03-01 14:56:10.000000000 +0800
+@@ -48,7 +48,7 @@ class Canvas {
+ public:
+ typedef std::vector<Attributes> attributes_list;
+
+- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
++ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
+ m_window(newwin(height, width, y, x)) {}
+ ~Canvas() { delwin(m_window); }
diff --git a/network/rtorrent/rtorrent.SlackBuild b/network/rtorrent/rtorrent.SlackBuild
index 7b3fc0df2e..6a5e117ee0 100644
--- a/network/rtorrent/rtorrent.SlackBuild
+++ b/network/rtorrent/rtorrent.SlackBuild
@@ -49,6 +49,10 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# thanks to andrew@andrews-corner.org and ankursinha@fedoraproject.org
+# patch for ncurses in current - http://libtorrent.rakshasa.no/ticket/2518
+patch -p1 < $CWD/rtorrent-0.8.7-canvas-patch-fix-for-ncurses-5-8.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/network/rtorrent/rtorrent.info b/network/rtorrent/rtorrent.info
index b80a281abb..50de19ada7 100644
--- a/network/rtorrent/rtorrent.info
+++ b/network/rtorrent/rtorrent.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Brian Kysela"
EMAIL="brian.kysela@gmail.com"
-APPROVED="Erik Hanson"
+APPROVED=""