summaryrefslogtreecommitdiffstats
path: root/multimedia/miro/miro.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/miro/miro.SlackBuild')
-rw-r--r--multimedia/miro/miro.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/multimedia/miro/miro.SlackBuild b/multimedia/miro/miro.SlackBuild
index c96dcdc8dc..b429fa83da 100644
--- a/multimedia/miro/miro.SlackBuild
+++ b/multimedia/miro/miro.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Miro
-# Copyright 2009-2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=miro
-VERSION=${VERSION:-5.0.4}
+VERSION=${VERSION:-6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,8 +71,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch to build against ffmpeg 0.11.x
-patch -p1 < $CWD/ffmpeg-0.11.patch
# Patch to fix the gdb call from miro.
patch -p1 < $CWD/miro-gdb-fix.patch
# Fix .destkop item.
@@ -81,7 +79,7 @@ sed -i \
-e 's|ogg$|ogg;|' linux/miro.desktop
cd linux
- sed -i 's|share/man|man|' setup.py
+ sed -i -e 's|share/man|man|' -e '/miro.test/d' setup.py
CFLAGS="$SLKCFLAGS" python setup.py install --root=$PKG
cd -
@@ -89,8 +87,6 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Remove unneeded files.
-PYVER=$(python -c 'import sys; print sys.version[:3]')
-rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/python${PYVER}/site-packages/miro/test
rm -rf $PKG/usr/share/${PRGNAM}/resources/testdata
if [ "$ARCH" == "x86_64" ]; then
rm -f $PKG/usr/bin/codegen.Linux-i686