summaryrefslogtreecommitdiffstats
path: root/multimedia/LiVES
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/LiVES')
-rw-r--r--multimedia/LiVES/LiVES.SlackBuild21
-rw-r--r--multimedia/LiVES/LiVES.info8
-rw-r--r--multimedia/LiVES/patches/drop_py3_multiencoder.patch29
-rw-r--r--multimedia/LiVES/patches/weed_palettes.patch14
4 files changed, 67 insertions, 5 deletions
diff --git a/multimedia/LiVES/LiVES.SlackBuild b/multimedia/LiVES/LiVES.SlackBuild
index 15326cda85..6272ff7477 100644
--- a/multimedia/LiVES/LiVES.SlackBuild
+++ b/multimedia/LiVES/LiVES.SlackBuild
@@ -8,7 +8,7 @@
# at slackbuilds.org
PRGNAM=LiVES
-VERSION=1.3.4
+VERSION=${VERSION:-1.4.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,6 +51,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,g-w+r,o-w+r .
+# https://sf.net/tracker/index.php?func=detail&aid=3460799&group_id=64341&atid=507139
+patch -p1 < $CWD/patches/weed_palettes.patch
+
+# Drop Python3 version of multiencoder plugin
+patch -p1 < $CWD/patches/drop_py3_multiencoder.patch
+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -58,17 +64,30 @@ CFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--program-prefix="" \
+ --disable-static \
--build=$ARCH-slackware-linux
make docdir=/usr/doc/$PRGNAM-$VERSION
make install-strip docdir=/usr/doc/$PRGNAM-$VERSION DESTDIR=$PKG
+# fix link to lives exec
+( cd $PKG/usr/bin ; rm lives ; ln -s lives-exe lives )
+
+# remove static stuff
+find $PKG/usr -name '*.la' -exec rm -f {} +
+rm -f $PKG/usr/lib*/libweed-*.a
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING INSTALL NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat <<EOF > $PKG/install/doinst.sh
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+EOF
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/LiVES/LiVES.info b/multimedia/LiVES/LiVES.info
index 94f1dde9be..011dea5fab 100644
--- a/multimedia/LiVES/LiVES.info
+++ b/multimedia/LiVES/LiVES.info
@@ -1,10 +1,10 @@
PRGNAM="LiVES"
-VERSION="1.3.4"
+VERSION="1.4.9"
HOMEPAGE="http://lives.sourceforge.net"
-DOWNLOAD="http://www.xs4all.nl/%7Esalsaman/lives/current/LiVES-1.3.4.tar.bz2"
-MD5SUM="aeedd75386aa64004ad0831fdbf29cee"
+DOWNLOAD="http://www.xs4all.nl/~salsaman/lives/current/LiVES-1.4.9.tar.bz2"
+MD5SUM="4664a50abf0efc12b536a2830a43dc72"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="klaatu"
EMAIL="klaatu@hackerpublicradio.org"
-APPROVED="rworkman"
+APPROVED=""
diff --git a/multimedia/LiVES/patches/drop_py3_multiencoder.patch b/multimedia/LiVES/patches/drop_py3_multiencoder.patch
new file mode 100644
index 0000000000..9a01a71905
--- /dev/null
+++ b/multimedia/LiVES/patches/drop_py3_multiencoder.patch
@@ -0,0 +1,29 @@
+Description: Drop Python3 version of multiencoder plugin.
+Author: Alessio Treglia <alessio@debian.org>
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/632833
+Forwarded: not-needed
+---
+ lives-plugins/plugins/encoders/Makefile.am | 1 -
+ lives-plugins/plugins/encoders/Makefile.in | 1 -
+ 2 files changed, 2 deletions(-)
+
+--- lives.orig/lives-plugins/plugins/encoders/Makefile.am
++++ lives/lives-plugins/plugins/encoders/Makefile.am
+@@ -8,7 +8,6 @@ ffmpeg_encoder \
+ mencoder_encoder \
+ mjpegtools_encoder \
+ multi_encoder \
+-multi_encoder3 \
+ qtutils_encoder \
+ sswf_encoder \
+ transcode_encoder \
+--- lives.orig/lives-plugins/plugins/encoders/Makefile.in
++++ lives/lives-plugins/plugins/encoders/Makefile.in
+@@ -333,7 +333,6 @@ ffmpeg_encoder \
+ mencoder_encoder \
+ mjpegtools_encoder \
+ multi_encoder \
+-multi_encoder3 \
+ qtutils_encoder \
+ sswf_encoder \
+ transcode_encoder \
diff --git a/multimedia/LiVES/patches/weed_palettes.patch b/multimedia/LiVES/patches/weed_palettes.patch
new file mode 100644
index 0000000000..cbbe55222f
--- /dev/null
+++ b/multimedia/LiVES/patches/weed_palettes.patch
@@ -0,0 +1,14 @@
+diff -Naur lives-1.4.9.orig/lives-plugins/plugins/decoders/mkv_decoder.c lives-1.4.9/lives-plugins/plugins/decoders/mkv_decoder.c
+--- lives-1.4.9.orig/lives-plugins/plugins/decoders/mkv_decoder.c 2011-12-08 06:33:19.000000000 +0100
++++ lives-1.4.9/lives-plugins/plugins/decoders/mkv_decoder.c 2011-12-23 13:12:12.772897712 +0100
+@@ -50,6 +50,10 @@
+
+ #define HAVE_AVCODEC
+
++#ifndef HAVE_SYSTEM_WEED
++#include "../../../libweed/weed-palettes.h"
++#endif
++
+ #ifdef HAVE_SYSTEM_WEED_COMPAT
+ #include "weed/weed-compat.h"
+ #else