summaryrefslogtreecommitdiffstats
path: root/libraries/libtirpc
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libtirpc')
-rw-r--r--libraries/libtirpc/README5
-rw-r--r--libraries/libtirpc/doinst.sh14
-rw-r--r--libraries/libtirpc/libtirpc.SlackBuild99
-rw-r--r--libraries/libtirpc/libtirpc.info14
-rw-r--r--libraries/libtirpc/no-des_no-nis.patch153
-rw-r--r--libraries/libtirpc/slack-desc19
6 files changed, 304 insertions, 0 deletions
diff --git a/libraries/libtirpc/README b/libraries/libtirpc/README
new file mode 100644
index 0000000000..f235e1b6ec
--- /dev/null
+++ b/libraries/libtirpc/README
@@ -0,0 +1,5 @@
+libtirpc (RPC library implementation)
+
+Libtirpc is a port of Suns Transport-Independent RPC library to Linux.
+It's being developed by the Bull GNU/Linux NFSv4 project.
+It currently lacks DES and NIS support.
diff --git a/libraries/libtirpc/doinst.sh b/libraries/libtirpc/doinst.sh
new file mode 100644
index 0000000000..cc5dc4a387
--- /dev/null
+++ b/libraries/libtirpc/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/netconfig.new
diff --git a/libraries/libtirpc/libtirpc.SlackBuild b/libraries/libtirpc/libtirpc.SlackBuild
new file mode 100644
index 0000000000..4bad33ec4e
--- /dev/null
+++ b/libraries/libtirpc/libtirpc.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# Slackware build script for libtirpc
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=libtirpc
+VERSION=${VERSION:-0.2.2}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO VERSION"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+mkdir src/rpcnis
+tar xvf $CWD/rpcnis-headers.tar.bz2 -C src/rpcnis
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# remove broken des and nis references
+# http://www.mail-archive.com/blfs-support@linuxfromscratch.org/msg13412.html
+patch -p1 < $CWD/no-des_no-nis.patch
+
+CFLAGS="$SLKCFLAGS -I./rpcnis" \
+CXXFLAGS="$SLKCFLAGS -I./rpcnis" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# remove the static libs
+rm $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+# include all the headers, seems make install is too restrictive
+rm -fR $PKG/usr/include/tirpc/*
+cp -R tirpc/* $PKG/usr/include/tirpc/
+
+mv $PKG/etc/netconfig $PKG/etc/netconfig.new
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libtirpc/libtirpc.info b/libraries/libtirpc/libtirpc.info
new file mode 100644
index 0000000000..917e27d8d3
--- /dev/null
+++ b/libraries/libtirpc/libtirpc.info
@@ -0,0 +1,14 @@
+PRGNAM="libtirpc"
+VERSION="0.2.2"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+DOWNLOAD="\
+ http://downloads.sourceforge.net/libtirpc/libtirpc-0.2.2.tar.bz2 \
+ http://ponce.cc/slackware/sources/repo/rpcnis-headers.tar.bz2"
+MD5SUM="\
+ 74c41c15c2909f7d11d9c7bfa7db6273 \
+ 635c7c9b6c962246a50a579ddbdbb95c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED=""
diff --git a/libraries/libtirpc/no-des_no-nis.patch b/libraries/libtirpc/no-des_no-nis.patch
new file mode 100644
index 0000000000..051f1e4ab4
--- /dev/null
+++ b/libraries/libtirpc/no-des_no-nis.patch
@@ -0,0 +1,153 @@
+*** ./src/rpc_soc.c.ORIG Wed Oct 26 18:02:55 2011
+--- ./src/rpc_soc.c Wed Oct 26 18:02:55 2011
+***************
+*** 519,524 ****
+--- 519,525 ----
+ * Create the client des authentication object. Obsoleted by
+ * authdes_seccreate().
+ */
++ #if 0
+ AUTH *
+ authdes_create(servername, window, syncaddr, ckey)
+ char *servername; /* network name of server */
+***************
+*** 546,551 ****
+--- 547,553 ----
+ dummy = authdes_seccreate(servername, window, NULL, ckey);
+ return (dummy);
+ }
++ #endif
+
+ /*
+ * Create a client handle for a unix connection. Obsoleted by clnt_vc_create()
+*** ./src/Makefile.in.ORIG Wed Oct 26 18:02:55 2011
+--- ./src/Makefile.in Wed Oct 26 18:02:55 2011
+***************
+*** 81,88 ****
+ rpc_commondata.c rpc_callmsg.c rpc_generic.c rpc_soc.c \
+ rpcb_clnt.c rpcb_prot.c rpcb_st_xdr.c svc.c svc_auth.c \
+ svc_dg.c svc_auth_unix.c svc_generic.c svc_raw.c svc_run.c \
+! svc_simple.c svc_vc.c getpeereid.c auth_time.c auth_des.c \
+! authdes_prot.c des_crypt.c xdr.c xdr_rec.c xdr_array.c \
+ xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c auth_gss.c \
+ authgss_prot.c svc_auth_gss.c svc_auth_none.c
+ @GSS_TRUE@am__objects_1 = libtirpc_la-auth_gss.lo \
+--- 81,88 ----
+ rpc_commondata.c rpc_callmsg.c rpc_generic.c rpc_soc.c \
+ rpcb_clnt.c rpcb_prot.c rpcb_st_xdr.c svc.c svc_auth.c \
+ svc_dg.c svc_auth_unix.c svc_generic.c svc_raw.c svc_run.c \
+! svc_simple.c svc_vc.c getpeereid.c auth_time.c \
+! xdr.c xdr_rec.c xdr_array.c \
+ xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c auth_gss.c \
+ authgss_prot.c svc_auth_gss.c svc_auth_none.c
+ @GSS_TRUE@am__objects_1 = libtirpc_la-auth_gss.lo \
+***************
+*** 110,117 ****
+ libtirpc_la-svc_generic.lo libtirpc_la-svc_raw.lo \
+ libtirpc_la-svc_run.lo libtirpc_la-svc_simple.lo \
+ libtirpc_la-svc_vc.lo libtirpc_la-getpeereid.lo \
+! libtirpc_la-auth_time.lo libtirpc_la-auth_des.lo \
+! libtirpc_la-authdes_prot.lo libtirpc_la-des_crypt.lo \
+ libtirpc_la-xdr.lo libtirpc_la-xdr_rec.lo \
+ libtirpc_la-xdr_array.lo libtirpc_la-xdr_float.lo \
+ libtirpc_la-xdr_mem.lo libtirpc_la-xdr_reference.lo \
+--- 110,117 ----
+ libtirpc_la-svc_generic.lo libtirpc_la-svc_raw.lo \
+ libtirpc_la-svc_run.lo libtirpc_la-svc_simple.lo \
+ libtirpc_la-svc_vc.lo libtirpc_la-getpeereid.lo \
+! libtirpc_la-auth_time.lo \
+! \
+ libtirpc_la-xdr.lo libtirpc_la-xdr_rec.lo \
+ libtirpc_la-xdr_array.lo libtirpc_la-xdr_float.lo \
+ libtirpc_la-xdr_mem.lo libtirpc_la-xdr_reference.lo \
+***************
+*** 291,297 ****
+ # release number of your package. This is an abuse that only fosters
+ # misunderstanding of the purpose of library versions."
+ #
+! libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:10:0 \
+ $(am__append_2)
+ libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c \
+ bindresvport.c clnt_bcast.c clnt_dg.c clnt_generic.c \
+--- 291,297 ----
+ # release number of your package. This is an abuse that only fosters
+ # misunderstanding of the purpose of library versions."
+ #
+! libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0 \
+ $(am__append_2)
+ libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c \
+ bindresvport.c clnt_bcast.c clnt_dg.c clnt_generic.c \
+***************
+*** 302,309 ****
+ rpc_commondata.c rpc_callmsg.c rpc_generic.c rpc_soc.c \
+ rpcb_clnt.c rpcb_prot.c rpcb_st_xdr.c svc.c svc_auth.c \
+ svc_dg.c svc_auth_unix.c svc_generic.c svc_raw.c svc_run.c \
+! svc_simple.c svc_vc.c getpeereid.c auth_time.c auth_des.c \
+! authdes_prot.c des_crypt.c xdr.c xdr_rec.c xdr_array.c \
+ xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c \
+ $(am__append_1)
+ @GSS_TRUE@libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
+--- 302,309 ----
+ rpc_commondata.c rpc_callmsg.c rpc_generic.c rpc_soc.c \
+ rpcb_clnt.c rpcb_prot.c rpcb_st_xdr.c svc.c svc_auth.c \
+ svc_dg.c svc_auth_unix.c svc_generic.c svc_raw.c svc_run.c \
+! svc_simple.c svc_vc.c getpeereid.c auth_time.c \
+! xdr.c xdr_rec.c xdr_array.c \
+ xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c \
+ $(am__append_1)
+ @GSS_TRUE@libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
+***************
+*** 753,778 ****
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o libtirpc_la-auth_time.lo `test -f 'auth_time.c' || echo '$(srcdir)/'`auth_time.c
+
+! libtirpc_la-auth_des.lo: auth_des.c
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT libtirpc_la-auth_des.lo -MD -MP -MF $(DEPDIR)/libtirpc_la-auth_des.Tpo -c -o libtirpc_la-auth_des.lo `test -f 'auth_des.c' || echo '$(srcdir)/'`auth_des.c
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-auth_des.Tpo $(DEPDIR)/libtirpc_la-auth_des.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='auth_des.c' object='libtirpc_la-auth_des.lo' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o libtirpc_la-auth_des.lo `test -f 'auth_des.c' || echo '$(srcdir)/'`auth_des.c
+
+! libtirpc_la-authdes_prot.lo: authdes_prot.c
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT libtirpc_la-authdes_prot.lo -MD -MP -MF $(DEPDIR)/libtirpc_la-authdes_prot.Tpo -c -o libtirpc_la-authdes_prot.lo `test -f 'authdes_prot.c' || echo '$(srcdir)/'`authdes_prot.c
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-authdes_prot.Tpo $(DEPDIR)/libtirpc_la-authdes_prot.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='authdes_prot.c' object='libtirpc_la-authdes_prot.lo' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o libtirpc_la-authdes_prot.lo `test -f 'authdes_prot.c' || echo '$(srcdir)/'`authdes_prot.c
+
+! libtirpc_la-des_crypt.lo: des_crypt.c
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT libtirpc_la-des_crypt.lo -MD -MP -MF $(DEPDIR)/libtirpc_la-des_crypt.Tpo -c -o libtirpc_la-des_crypt.lo `test -f 'des_crypt.c' || echo '$(srcdir)/'`des_crypt.c
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-des_crypt.Tpo $(DEPDIR)/libtirpc_la-des_crypt.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='des_crypt.c' object='libtirpc_la-des_crypt.lo' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o libtirpc_la-des_crypt.lo `test -f 'des_crypt.c' || echo '$(srcdir)/'`des_crypt.c
+
+ libtirpc_la-xdr.lo: xdr.c
+ @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT libtirpc_la-xdr.lo -MD -MP -MF $(DEPDIR)/libtirpc_la-xdr.Tpo -c -o libtirpc_la-xdr.lo `test -f 'xdr.c' || echo '$(srcdir)/'`xdr.c
+--- 753,778 ----
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o libtirpc_la-auth_time.lo `test -f 'auth_time.c' || echo '$(srcdir)/'`auth_time.c
+
+! :
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT -MD -MP -MF $(DEPDIR)/libtirpc_la-auth_des.Tpo -c -o `test -f '' || echo '$(srcdir)/'`
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-auth_des.Tpo $(DEPDIR)/libtirpc_la-auth_des.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='' object='' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o `test -f '' || echo '$(srcdir)/'`
+
+! :
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT -MD -MP -MF $(DEPDIR)/libtirpc_la-authdes_prot.Tpo -c -o `test -f '' || echo '$(srcdir)/'`
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-authdes_prot.Tpo $(DEPDIR)/libtirpc_la-authdes_prot.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='' object='' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o `test -f '' || echo '$(srcdir)/'`
+
+! :
+! @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT -MD -MP -MF $(DEPDIR)/libtirpc_la-des_crypt.Tpo -c -o `test -f '' || echo '$(srcdir)/'`
+ @am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/libtirpc_la-des_crypt.Tpo $(DEPDIR)/libtirpc_la-des_crypt.Plo
+! @AMDEP_TRUE@@am__fastdepCC_FALSE@ source='' object='' libtool=yes @AMDEPBACKSLASH@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+! @am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -c -o `test -f '' || echo '$(srcdir)/'`
+
+ libtirpc_la-xdr.lo: xdr.c
+ @am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libtirpc_la_CFLAGS) $(CFLAGS) -MT libtirpc_la-xdr.lo -MD -MP -MF $(DEPDIR)/libtirpc_la-xdr.Tpo -c -o libtirpc_la-xdr.lo `test -f 'xdr.c' || echo '$(srcdir)/'`xdr.c
diff --git a/libraries/libtirpc/slack-desc b/libraries/libtirpc/slack-desc
new file mode 100644
index 0000000000..25b8262527
--- /dev/null
+++ b/libraries/libtirpc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libtirpc: libtirpc (RPC library implementation)
+libtirpc:
+libtirpc: Libtirpc is a port of Suns Transport-Independent RPC library to Linux.
+libtirpc: It's being developed by the Bull GNU/Linux NFSv4 project.
+libtirpc: It currently lacks DES and NIS support.
+libtirpc:
+libtirpc: homepage: http://libtirpc.sourceforge.net/
+libtirpc:
+libtirpc:
+libtirpc:
+libtirpc: