summaryrefslogtreecommitdiffstats
path: root/graphics/dia/dia.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dia/dia.SlackBuild')
-rw-r--r--graphics/dia/dia.SlackBuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index 0ac1d62b6b..fb9cab4f01 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -6,8 +6,8 @@
# Currently mantained by Dugan Chen (thedoogster@gmail.com)))
PRGNAM=dia
-VERSION=0.97.2
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-0.97.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -48,16 +48,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix the location of the French manpages.
-sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
-
-# apply patches from upstream
-for i in $CWD/patches/* ; do patch -p1 < $i ; done
-autoreconf -fi
+sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in || exit 1
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \