summaryrefslogtreecommitdiffstats
path: root/development/MySQL-python/patches
diff options
context:
space:
mode:
Diffstat (limited to 'development/MySQL-python/patches')
-rw-r--r--development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch33
-rw-r--r--development/MySQL-python/patches/no_distribute_download.patch12
2 files changed, 45 insertions, 0 deletions
diff --git a/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch b/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch
new file mode 100644
index 0000000000..81d2041f47
--- /dev/null
+++ b/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch
@@ -0,0 +1,33 @@
+diff -Naur MySQL-python-1.2.4.orig/_mysql.c MySQL-python-1.2.4/_mysql.c
+--- MySQL-python-1.2.4.orig/_mysql.c 2013-01-01 17:18:48.000000000 +0100
++++ MySQL-python-1.2.4/_mysql.c 2014-11-07 20:25:20.483927425 +0100
+@@ -26,6 +26,14 @@
+ PERFORMANCE OF THIS SOFTWARE.
+ */
+
++#if defined(MS_WINDOWS)
++#include <config-win.h>
++#else
++#include "my_config.h"
++#endif
++#include "mysql.h"
++#include "mysqld_error.h"
++#include "errmsg.h"
+ #include "Python.h"
+ #if PY_MAJOR_VERSION >= 3
+ #define IS_PY3K
+@@ -38,14 +46,6 @@
+ #endif
+ #include "pymemcompat.h"
+ #include "structmember.h"
+-#if defined(MS_WINDOWS)
+-#include <config-win.h>
+-#else
+-#include "my_config.h"
+-#endif
+-#include "mysql.h"
+-#include "mysqld_error.h"
+-#include "errmsg.h"
+
+ #if PY_VERSION_HEX < 0x02020000
+ # define MyTuple_Resize(t,n,d) _PyTuple_Resize(t, n, d)
diff --git a/development/MySQL-python/patches/no_distribute_download.patch b/development/MySQL-python/patches/no_distribute_download.patch
new file mode 100644
index 0000000000..2a94802373
--- /dev/null
+++ b/development/MySQL-python/patches/no_distribute_download.patch
@@ -0,0 +1,12 @@
+diff -Naur MySQL-python-1.2.4.orig/setup.py MySQL-python-1.2.4/setup.py
+--- MySQL-python-1.2.4.orig/setup.py 2012-10-08 13:46:54.000000000 +0200
++++ MySQL-python-1.2.4/setup.py 2013-12-06 20:34:36.214964072 +0100
+@@ -3,8 +3,6 @@
+ import os
+ import sys
+
+-from distribute_setup import use_setuptools
+-use_setuptools()
+ from setuptools import setup, Extension
+
+ if not hasattr(sys, "hexversion") or sys.hexversion < 0x02040000: