summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Matteo Bernardini2015-11-03 15:31:04 +0100
committer Willy Sudiarto Raharjo2016-01-17 03:40:16 +0100
commit152b81d4b4d96f6f03e000ab18b658e92d491fb3 (patch)
tree6dadf7bca0896105d38c204007979c1606b75898 /python
parent23566c25218804660cb14d8f86e2d99d8ee3be19 (diff)
downloadold.slackbuilds-152b81d4b4d96f6f03e000ab18b658e92d491fb3.tar.gz
python/pygobject3: Removed (added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pygobject3/README7
-rw-r--r--python/pygobject3/pygobject3.SlackBuild104
-rw-r--r--python/pygobject3/pygobject3.info10
-rw-r--r--python/pygobject3/python3.4.patch96
-rw-r--r--python/pygobject3/slack-desc19
5 files changed, 0 insertions, 236 deletions
diff --git a/python/pygobject3/README b/python/pygobject3/README
deleted file mode 100644
index 40f7f4e359..0000000000
--- a/python/pygobject3/README
+++ /dev/null
@@ -1,7 +0,0 @@
-This archive contains bindings for the GObject, to be used in Python.
-It is a fairly complete set of bindings, it's already rather useful,
-and is usable to write moderately complex programs.
-
-Note:
-If you have python3 installed, then you will need an additional
-dependencies: gnome-common and py3cairo
diff --git a/python/pygobject3/pygobject3.SlackBuild b/python/pygobject3/pygobject3.SlackBuild
deleted file mode 100644
index e4a8fff48a..0000000000
--- a/python/pygobject3/pygobject3.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Copyright 2007, 2008 Erik Hanson erik@slackbuilds.org
-# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-PRGNAM=pygobject3
-SRCNAM=pygobject
-VERSION=${VERSION:-3.10.2}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- patch -p1 < $CWD/python3.4.patch
- PYTHON=python3
- ./autogen.sh
-fi
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a INSTALL AUTHORS COPYING* NEWS README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-( cd $PKG/usr/doc/$PRGNAM-$VERSION
- ln -s ../../share/gtk-doc/html/pygobject html
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pygobject3/pygobject3.info b/python/pygobject3/pygobject3.info
deleted file mode 100644
index 0b26e704c2..0000000000
--- a/python/pygobject3/pygobject3.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pygobject3"
-VERSION="3.10.2"
-HOMEPAGE="http://www.pygtk.org/"
-DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.10/pygobject-3.10.2.tar.xz"
-MD5SUM="f311155be8510df6ad8e4edf1cb463d4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Robby Workman"
-EMAIL="rworkman@slackbuilds.org"
diff --git a/python/pygobject3/python3.4.patch b/python/pygobject3/python3.4.patch
deleted file mode 100644
index c71af55b50..0000000000
--- a/python/pygobject3/python3.4.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 2ff095ea0b0c05fbf6cc332eeadf26cfeb9e69f7 Mon Sep 17 00:00:00 2001
-From: Colin Watson <cjwatson@ubuntu.com>
-Date: Tue, 24 Dec 2013 22:19:02 +0000
-Subject: build: Avoid clash between gi/types.py and stdlib
-
-Use non-recursive make for the Python modules in gi/ to work around a
-clash between gi/types.py and the standard library's types module when
-running py-compile.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=721025
-
-Signed-off-by: Martin Pitt <martinpitt@gnome.org>
-
-diff --git a/Makefile.am b/Makefile.am
-index 5051b54..58d720f 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,6 +1,9 @@
- ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
- AUTOMAKE_OPTIONS = 1.7
-
-+# Part of the gi subdirectory is handled with non-recursive make to avoid
-+# py-compile getting confused between gi/types.py and Python's standard
-+# types module.
- SUBDIRS = examples gi tests pygtkcompat
-
- PLATFORM_VERSION = 3.0
-@@ -49,6 +52,27 @@ MAINTAINERCLEANFILES = \
- BUILT_EXTRA_DIST = \
- ChangeLog
-
-+nobase_pyexec_PYTHON = \
-+ gi/__init__.py \
-+ gi/types.py \
-+ gi/module.py \
-+ gi/importer.py \
-+ gi/pygtkcompat.py \
-+ gi/docstring.py
-+
-+# if we build in a separate tree, we need to symlink the *.py files from the
-+# source tree; Python does not accept the extensions and modules in different
-+# paths
-+build_pylinks:
-+ for f in $(nobase_pyexec_PYTHON); do \
-+ [ -e $(builddir)/$$f ] || \
-+ $(LN_S) $(abs_srcdir)/$$f $(builddir)/$$f; \
-+ done
-+
-+all-local: build_pylinks
-+
-+check-local: build_pylinks
-+
- # pkg-config files
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = pygobject-$(PLATFORM_VERSION).pc
-diff --git a/gi/Makefile.am b/gi/Makefile.am
-index fc11ff8..aa91a46 100644
---- a/gi/Makefile.am
-+++ b/gi/Makefile.am
-@@ -26,14 +26,6 @@ endif
-
- pygidir = $(pyexecdir)/gi
-
--pygi_PYTHON = \
-- __init__.py \
-- types.py \
-- module.py \
-- importer.py \
-- pygtkcompat.py \
-- docstring.py
--
- pygi_LTLIBRARIES = _gi.la
-
- _gi_la_SOURCES = \
-@@ -118,16 +110,8 @@ _gi_cairo_la_LDFLAGS = \
- %$(PYTHON_SO): %.la
- $(LN_S) -f .libs/$@ $@
-
--# if we build in a separate tree, we need to symlink the *.py files from the
--# source tree; Python does not accept the extensions and modules in different
--# paths
--build_pylinks:
-- for f in $(pygi_PYTHON); do \
-- [ -e $(builddir)/$$f ] || $(LN_S) $(srcdir)/$$f $(builddir)/$$f; \
-- done
--
--all-local: $(LTLIBRARIES:.la=$(PYTHON_SO)) build_pylinks
-+all-local: $(LTLIBRARIES:.la=$(PYTHON_SO))
-
--check-local: $(LTLIBRARIES:.la=$(PYTHON_SO)) build_pylinks
-+check-local: $(LTLIBRARIES:.la=$(PYTHON_SO))
- clean-local:
- rm -f $(LTLIBRARIES:.la=$(PYTHON_SO))
---
-cgit v0.10.1
-
diff --git a/python/pygobject3/slack-desc b/python/pygobject3/slack-desc
deleted file mode 100644
index b944511f4c..0000000000
--- a/python/pygobject3/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pygobject3: pygobject3 (GObject bindings for Python)
-pygobject3:
-pygobject3: This archive contains bindings for the GObject, to be used in Python.
-pygobject3: It is a fairly complete set of bindings, it's already rather useful,
-pygobject3: and is usable to write moderately complex programs.
-pygobject3:
-pygobject3: pygobject's home page: http://www.pygtk.org/
-pygobject3:
-pygobject3:
-pygobject3:
-pygobject3: