summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author ponce2011-10-25 07:58:56 +0200
committer ponce2011-10-25 07:58:56 +0200
commitdda3176015f2bffe524a41fb876d7fce1e07bc26 (patch)
tree0cf7e111b6805b87410813acf0e8c86b5ecbe641 /python
parent3b1a33551c6717ae80b4635f5654697bc97442b4 (diff)
downloadold.slackbuilds-dda3176015f2bffe524a41fb876d7fce1e07bc26.tar.gz
20111025.1 global branch merge.current-20111025.1
Diffstat (limited to 'python')
-rw-r--r--python/MySQL-python/MySQL-python.SlackBuild69
-rw-r--r--python/MySQL-python/MySQL-python.info10
-rw-r--r--python/MySQL-python/README12
-rw-r--r--python/MySQL-python/docs.patch14
-rw-r--r--python/MySQL-python/slack-desc19
-rw-r--r--python/babel/README6
-rw-r--r--python/babel/babel.SlackBuild69
-rw-r--r--python/babel/babel.info10
-rw-r--r--python/babel/slack-desc19
-rw-r--r--python/gnome-python/gnome-python.SlackBuild6
-rw-r--r--python/gnome-python/gnome-python.info8
11 files changed, 235 insertions, 7 deletions
diff --git a/python/MySQL-python/MySQL-python.SlackBuild b/python/MySQL-python/MySQL-python.SlackBuild
new file mode 100644
index 0000000000..9b2ed4fcb1
--- /dev/null
+++ b/python/MySQL-python/MySQL-python.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for MySQL-python.
+
+# Written by Jick Nan (jick.nan@gmail.com)
+
+PRGNAM=MySQL-python
+VERSION=1.2.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# patch MANIFEST.in
+patch -p1 < $CWD/docs.patch
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a HISTORY PKG-INFO README doc/*.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/MySQL-python/MySQL-python.info b/python/MySQL-python/MySQL-python.info
new file mode 100644
index 0000000000..2f4b2aeafd
--- /dev/null
+++ b/python/MySQL-python/MySQL-python.info
@@ -0,0 +1,10 @@
+PRGNAM="MySQL-python"
+VERSION="1.2.3"
+HOMEPAGE="http://cheeseshop.python.org/pypi/MySQL-python/"
+DOWNLOAD="http://downloads.sourceforge.net/mysql-python/MySQL-python-1.2.3.tar.gz"
+MD5SUM="215eddb6d853f6f4be5b4afc4154292f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Jick Nan"
+EMAIL="jick.nan@gmail.com"
+APPROVED=""
diff --git a/python/MySQL-python/README b/python/MySQL-python/README
new file mode 100644
index 0000000000..545bf819fa
--- /dev/null
+++ b/python/MySQL-python/README
@@ -0,0 +1,12 @@
+MySQL-python (Python interface to MySQL)
+
+MySQLdb is an interface to the popular MySQL database server for Python.
+The design goals are:
+
+ * Compliance with Python database API version 2.0 [PEP-0249]
+ * Thread-safety
+ * Thread-friendliness (threads will not block each other)
+
+MySQL-3.23 through 5.1 and Python-2.3 through 2.6 are currently supported.
+
+This requires the Python setuptools (pysetuptools on SlackBuilds.org).
diff --git a/python/MySQL-python/docs.patch b/python/MySQL-python/docs.patch
new file mode 100644
index 0000000000..9c624b3547
--- /dev/null
+++ b/python/MySQL-python/docs.patch
@@ -0,0 +1,14 @@
+--- MySQL-python-1.2.3/MANIFEST.in.orig 2010-11-20 17:45:00.000000000 +0100
++++ MySQL-python-1.2.3/MANIFEST.in 2010-11-20 17:45:30.000000000 +0100
+@@ -1,10 +1,8 @@
+ recursive-include doc *.txt
+ recursive-include tests *.py
+ include MANIFEST.in
+-include MANIFEST
+-include ChangeLog
+ include HISTORY
+-include GPL
++include README
+ include pymemcompat.h
+ include metadata.cfg
+ include site.cfg
diff --git a/python/MySQL-python/slack-desc b/python/MySQL-python/slack-desc
new file mode 100644
index 0000000000..3bdaf5389e
--- /dev/null
+++ b/python/MySQL-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+MySQL-python: MySQL-python (Python interface to MySQL)
+MySQL-python:
+MySQL-python: MySQLdb is an interface to the popular MySQL database server
+MySQL-python: for Python. The design goals are:
+MySQL-python: * Compliance with Python database API version 2.0 [PEP-0249]
+MySQL-python: * Thread-safety
+MySQL-python: * Thread-friendliness (threads will not block each other)
+MySQL-python:
+MySQL-python: MySQL-3.23 through 5.0 and Python-2.3 through 2.5 are currently
+MySQL-python: supported.
+MySQL-python:
diff --git a/python/babel/README b/python/babel/README
new file mode 100644
index 0000000000..1e8cba91ba
--- /dev/null
+++ b/python/babel/README
@@ -0,0 +1,6 @@
+babel (python internationalization tools)
+
+Babel is a collection of tools for internationalizing Python applications.
+It's composed of two major parts:
+- tools to build and work with gettext message catalogs;
+- a Python interface to the CLDR (Common Locale Data Repository), providing access to various locale display names, localized number and date formatting, etc.
diff --git a/python/babel/babel.SlackBuild b/python/babel/babel.SlackBuild
new file mode 100644
index 0000000000..aab533bd87
--- /dev/null
+++ b/python/babel/babel.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for babel
+
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=babel
+SRCNAM=Babel
+VERSION=${VERSION:-0.9.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a COPYING ChangeLog README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION/html
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/babel/babel.info b/python/babel/babel.info
new file mode 100644
index 0000000000..bb208bf8f5
--- /dev/null
+++ b/python/babel/babel.info
@@ -0,0 +1,10 @@
+PRGNAM="babel"
+VERSION="0.9.5"
+HOMEPAGE="http://babel.edgewall.org/"
+DOWNLOAD="http://ftp.edgewall.com/pub/babel/Babel-0.9.5.tar.gz"
+MD5SUM="05603f058644f81b9b5f75d0161a14dd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED=""
diff --git a/python/babel/slack-desc b/python/babel/slack-desc
new file mode 100644
index 0000000000..7165a5b745
--- /dev/null
+++ b/python/babel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+babel: babel (python internationalization tools)
+babel:
+babel: Babel is a collection of tools for internationalizing Python apps.
+babel: It's composed of two major parts:
+babel: - tools to build and work with gettext message catalogs;
+babel: - a Python interface to the CLDR (Common Locale Data Repository),
+babel: providing access to various locale display names, localized number
+babel: and date formatting, etc.
+babel:
+babel: homepage: http://babel.edgewall.org/
+babel:
diff --git a/python/gnome-python/gnome-python.SlackBuild b/python/gnome-python/gnome-python.SlackBuild
index 2b2aaf0036..34e715479d 100644
--- a/python/gnome-python/gnome-python.SlackBuild
+++ b/python/gnome-python/gnome-python.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gnome-python
-VERSION=2.22.3
+VERSION=2.28.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -77,8 +77,8 @@ CXXFLAGS="$SLKCFLAGS" \
./waf build
./waf install --destdir=$PKG
-find $PKG | xargs file | egrep "ELF.*shared object" | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/install
cp -a AUTHORS COPYING ChangeLog ChangeLog.pre-2-0 INSTALL INSTALL.WAF \
diff --git a/python/gnome-python/gnome-python.info b/python/gnome-python/gnome-python.info
index f128dc30e9..1a70c01461 100644
--- a/python/gnome-python/gnome-python.info
+++ b/python/gnome-python/gnome-python.info
@@ -1,10 +1,10 @@
PRGNAM="gnome-python"
-VERSION="2.22.3"
+VERSION="2.28.1"
HOMEPAGE="http://www.gnome.org/"
-DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.22/gnome-python-2.22.3.tar.bz2"
-MD5SUM="ab12d94954a57de39b25eb7903d8429c"
+DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.28/gnome-python-2.28.1.tar.bz2"
+MD5SUM="a17ad952813ed86f520de8e07194a2bf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Erik Hanson"
EMAIL="erik@slackbuilds.org"
-APPROVED="dsomero"
+APPROVED=""