summaryrefslogtreecommitdiffstats
path: root/python/affine/affine.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-03-18 03:58:57 +0100
committer Willy Sudiarto Raharjo2018-03-24 00:50:35 +0100
commitea7d2f88c83ba42ca7224b394a28c99e4c721026 (patch)
tree107fa8b7d2fe7c6c4ad39bd0d22f4a9f662b2c00 /python/affine/affine.SlackBuild
parent6d514660d2eb881d00982e7e90068b05b0794264 (diff)
downloadold.slackbuilds-ea7d2f88c83ba42ca7224b394a28c99e4c721026.tar.gz
python/affine: Updated for version 2.2.0.
Diffstat (limited to 'python/affine/affine.SlackBuild')
-rw-r--r--python/affine/affine.SlackBuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/python/affine/affine.SlackBuild b/python/affine/affine.SlackBuild
index 6434fc1a45..c54df83fdc 100644
--- a/python/affine/affine.SlackBuild
+++ b/python/affine/affine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for affine
-# Copyright 2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2014-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=affine
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-2.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,12 +70,17 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install