summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author David Spencer2017-08-29 17:38:44 +0200
committer David Spencer2017-09-02 11:19:45 +0200
commite3054535bd923c907ff035dc55c5236029ec7c9e (patch)
tree33ada0cb30ec13a78c985f310a3e425642ef5fec /misc
parentf28aaf84fd0906abf25b1186200daf5ec26b9b74 (diff)
downloadold.slackbuilds-e3054535bd923c907ff035dc55c5236029ec7c9e.tar.gz
misc/gprename: Patched to use DESTDIR.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/gprename/gprename-makefile-fixups.patch49
-rw-r--r--misc/gprename/gprename.SlackBuild3
2 files changed, 52 insertions, 0 deletions
diff --git a/misc/gprename/gprename-makefile-fixups.patch b/misc/gprename/gprename-makefile-fixups.patch
new file mode 100644
index 0000000000..cba26e8a96
--- /dev/null
+++ b/misc/gprename/gprename-makefile-fixups.patch
@@ -0,0 +1,49 @@
+diff -u -r gprename-20160905/Makefile gprename-20160905-patched/Makefile
+--- gprename-20160905/Makefile 2016-09-05 21:13:20.000000000 +0100
++++ gprename-20160905-patched/Makefile 2017-08-29 16:24:44.033333612 +0100
+@@ -45,8 +45,8 @@
+ # Create directories
+ install -d "$(DESTDIR)"
+ install -d "$(DESTDIR)/bin"
+- install -d "/usr/share"
+- install -d "/usr/share/icons"
++ install -d "$(DESTDIR)/share"
++ install -d "$(DESTDIR)/share/icons"
+ install -d "$(DESTDIR)/share/applications"
+ install -d "$(DESTDIR)/share/man"
+ install -d "$(DESTDIR)/share/man/man1"
+@@ -67,7 +67,7 @@
+ # Copy all files in the filesystem
+ install -m 755 build/gprename "$(DESTDIR)/bin/"
+ install -m 644 gprename-nautilus-actions.xml "$(DESTDIR)/share/applications/"
+- install -m 644 icon/gprename.png "/usr/share/icons/"
++ install -m 644 icon/gprename.png "$(DESTDIR)/share/icons/"
+ install -m 644 man/gprename.1 "$(DESTDIR)/share/man/man1/"
+ install -m 644 build/locale/ca.mo "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/de.mo "$(DESTDIR)/share/locale/de/LC_MESSAGES/gprename.mo"
+@@ -82,13 +82,12 @@
+ install -m 644 build/locale/ru.mo "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/sv.mo "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/zh_CN.mo "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
+- desktop-file-install bin/gprename.desktop
+- update-desktop-database
++ install -m 644 bin/gprename.desktop "$(DESTDIR)/share/applications/"
+ @echo "Installation completed."
+
+ uninstall: clean
+ rm -f "$(DESTDIR)/bin/gprename"
+- rm -f "/usr/share/applications/gprename.desktop"
++ rm -f "$(DESTDIR)/share/applications/gprename.desktop"
+ rm -f "$(DESTDIR)/share/applications/gprename-nautilus-actions.xml"
+ rm -f "$(DESTDIR)/share/man/man1/gprename.1"
+ rm -f "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
+@@ -104,8 +103,7 @@
+ rm -f "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
+ rm -f "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
+ rm -f "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
+- rm -fr "/usr/share/icons/gprename"
+- update-desktop-database
++ rm -fr "$(DESTDIR)/share/icons/gprename"
+
+ clean:
+ rm -rf build
diff --git a/misc/gprename/gprename.SlackBuild b/misc/gprename/gprename.SlackBuild
index a17544aa4d..979d0d9273 100644
--- a/misc/gprename/gprename.SlackBuild
+++ b/misc/gprename/gprename.SlackBuild
@@ -48,6 +48,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Don't run update-desktop-database or install icons on the build host
+patch -p1 < $CWD/gprename-makefile-fixups.patch
+
make -j1 install DESTDIR=$PKG/usr PREFIX=/usr
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \