summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-03-09 17:45:26 +0100
committer Willy Sudiarto Raharjo2018-03-10 01:11:07 +0100
commit86846c78f46cdc09f8fafd22a3ad6304fb8adf1f (patch)
tree25bce6381a936df635d3b92887eb6a122fb20301 /gis
parentda9bb7119e4d10ecfc1e2353359fe0484872e38a (diff)
downloadold.slackbuilds-86846c78f46cdc09f8fafd22a3ad6304fb8adf1f.tar.gz
gis/Shapely: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis')
-rw-r--r--gis/Shapely/Shapely.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/gis/Shapely/Shapely.SlackBuild b/gis/Shapely/Shapely.SlackBuild
index a7f2ecc45c..d9de959e2f 100644
--- a/gis/Shapely/Shapely.SlackBuild
+++ b/gis/Shapely/Shapely.SlackBuild
@@ -73,6 +73,9 @@ find -L . \
sed -i "s/data_files\s*=.*/data_files = [],/g" setup.py
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true